summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Kelly <pioto@gentoo.org>2006-11-06 06:44:14 +0000
committerMike Kelly <pioto@gentoo.org>2006-11-06 06:44:14 +0000
commit8026836d2f80619b7af7ce739f29f5874fb780a2 (patch)
treed7c82f1532486455efb419551a28e6bd128c081e /app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild
parentNew upstream version. (diff)
downloadhistorical-8026836d2f80619b7af7ce739f29f5874fb780a2.tar.gz
historical-8026836d2f80619b7af7ce739f29f5874fb780a2.tar.bz2
historical-8026836d2f80619b7af7ce739f29f5874fb780a2.zip
Version bump. Fixes: Bug #122890 and Bug #145999. See Bug #148985 for more details.
Package-Manager: portage-2.1.2_rc1-r3
Diffstat (limited to 'app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild')
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild
new file mode 100644
index 000000000000..0c7a3a9e2df2
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20061106.ebuild,v 1.1 2006/11/06 06:44:13 pioto Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ einfo "Note for developers and anyone else who edits ebuilds:"
+ einfo " This release of gentoo-syntax now contains filetype rules to set"
+ einfo " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ einfo " If you find this feature breaks things, please submit a bug and"
+ einfo " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ einfo " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}