summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-12-17 03:47:49 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-12-17 03:47:49 +0000
commitd6e374bf4a2b5245c7acc2601d64c9745b5d2771 (patch)
treeb5b2d0d460ebd7764975170fc92d39db5bd7198d /app-vim/vimoutliner/vimoutliner-0.3.4.ebuild
parentfix install target so we dont need preplib (diff)
downloadhistorical-d6e374bf4a2b5245c7acc2601d64c9745b5d2771.tar.gz
historical-d6e374bf4a2b5245c7acc2601d64c9745b5d2771.tar.bz2
historical-d6e374bf4a2b5245c7acc2601d64c9745b5d2771.zip
New version, bug #101778.
Package-Manager: portage-2.0.53 I can kill you with my brain edition
Diffstat (limited to 'app-vim/vimoutliner/vimoutliner-0.3.4.ebuild')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.4.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.4.ebuild
new file mode 100644
index 000000000000..0fc031ceb9b8
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.3.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimoutliner/vimoutliner-0.3.4.ebuild,v 1.1 2005/12/17 03:47:49 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easy and fast outlining"
+HOMEPAGE="http://www.vimoutliner.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ find ${S} -type f | xargs chmod a+r
+}
+
+src_install() {
+ cd ${S}
+ p=/usr/share/vim/vimfiles
+ for d in doc ftdetect ftplugin syntax ; do
+ dodir ${p}/${d}
+ cp -R ${d} ${D}/${p}/
+ done
+
+ dodir ${p}/vimoutliner/plugins
+ cp -R add-ons/plugins ${D}/${p}/vimoutliner/
+
+ for d in scripts/* add-ons/scripts/* ; do
+ dobin ${d}
+ done
+
+ dodoc vimoutlinerrc
+}
+