summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2005-04-23 10:22:38 +0000
committerDavid Holm <dholm@gentoo.org>2005-04-23 10:22:38 +0000
commit3b3fd4d4f163657ce8a23c876fd04a1acd22b55d (patch)
treec1026dbb94ebe116f218bbd6849da27025520fed /dev-ada
parentNew version 0.3.6 (diff)
downloadhistorical-3b3fd4d4f163657ce8a23c876fd04a1acd22b55d.tar.gz
historical-3b3fd4d4f163657ce8a23c876fd04a1acd22b55d.tar.bz2
historical-3b3fd4d4f163657ce8a23c876fd04a1acd22b55d.zip
Fixed bug #76491
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/cbind/ChangeLog5
-rw-r--r--dev-ada/cbind/Manifest4
-rw-r--r--dev-ada/cbind/files/cbind6.diff217
3 files changed, 169 insertions, 57 deletions
diff --git a/dev-ada/cbind/ChangeLog b/dev-ada/cbind/ChangeLog
index c382b82f9f13..81be415e3c65 100644
--- a/dev-ada/cbind/ChangeLog
+++ b/dev-ada/cbind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ada/cbind
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/ChangeLog,v 1.8 2005/01/01 17:24:00 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/ChangeLog,v 1.9 2005/04/23 10:22:38 dholm Exp $
+
+ 23 Apr 2005; David Holm <dholm@gentoo.org> files/cbind6.diff:
+ Updated the patch to fix bug #76491
19 Mar 2004; Daniel Ahlberg <aliz@gentoo.org> cbind-6.ebuild:
Inherit eutils.
diff --git a/dev-ada/cbind/Manifest b/dev-ada/cbind/Manifest
index 3b4f5d323e29..c5182ed006e1 100644
--- a/dev-ada/cbind/Manifest
+++ b/dev-ada/cbind/Manifest
@@ -1,5 +1,5 @@
-MD5 9f78f821df10b5d133a0768aa2b00f72 ChangeLog 754
+MD5 28304db570435c6c2e9277b12b47e018 ChangeLog 852
MD5 de771bd575fb25bcf3fc383f36fbe1e4 cbind-6.ebuild 732
MD5 b1a57b79797c5cfb1af44255bee44d06 metadata.xml 451
-MD5 aa4cf2876e3e245ad93133ff4deb78c5 files/cbind6.diff 5268
+MD5 80954a80503e3f112b8ff5ed44110c20 files/cbind6.diff 7066
MD5 54d17954817798fdfed5399cee7f0373 files/digest-cbind-6 55
diff --git a/dev-ada/cbind/files/cbind6.diff b/dev-ada/cbind/files/cbind6.diff
index 0655765ece75..7eb212151d39 100644
--- a/dev-ada/cbind/files/cbind6.diff
+++ b/dev-ada/cbind/files/cbind6.diff
@@ -1,6 +1,42 @@
+diff -Naur cbind6.orig/Makefile cbind6/Makefile
+--- cbind6.orig/Makefile 2005-04-23 12:10:05.490371464 +0200
++++ cbind6/Makefile 2005-04-23 12:10:18.803347584 +0200
+@@ -91,8 +91,11 @@
+
+ install: all
+ - strip cbpp cbfe cbind cdep
+- - rm -f $(HOME)/bin/cbpp $(HOME)/bin/cbfe $(HOME)/bin/cbind $(HOME)/bin/cdep
+- - cp cbpp cbfe cbind cdep $(HOME)/bin
++ - rm -f $(PREFIX)/bin/cbpp $(PREFIX)/bin/cbfe $(PREFIX)/bin/cbind $(PREFIX)/bin/cdep
++ - install -D cbpp $(PREFIX)/bin/cbpp
++ - install -D cbfe $(PREFIX)/bin/cbfe
++ - install -D cbind $(PREFIX)/bin/cbind
++ - install -D cdep $(PREFIX)/bin/cdep
+
+
+
+@@ -132,14 +135,14 @@
+ mkmf -f $(MAKEFILE)
+
+ backup:
+- - rm -f $(HOME)/save/newc2a.tar.Z
+- tar -chf $(HOME)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
+- compress $(HOME)/save/newc2a.tar
++ - rm -f $(PREFIX)/save/newc2a.tar.Z
++ tar -chf $(PREFIX)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
++ compress $(PREFIX)/save/newc2a.tar
+
+ touch:; touch $(GENED_SRC)
+
+ hostinfo.h: htype hostinfo
+- hostinfo $@
++ ./hostinfo $@
+
+ c_perf.c: c.prf
+ gperf -N c_rsvd -t -p c.prf > $@
diff -Naur cbind6.orig/allocate.c cbind6/allocate.c
---- cbind6.orig/allocate.c 1995-05-19 16:53:10.000000000 +0200
-+++ cbind6/allocate.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/allocate.c 2005-04-23 12:10:05.403384688 +0200
++++ cbind6/allocate.c 2005-04-23 12:10:18.790349560 +0200
@@ -4,7 +4,7 @@
#include <sys/types.h>
#include <unistd.h>
@@ -11,8 +47,8 @@ diff -Naur cbind6.orig/allocate.c cbind6/allocate.c
#include "config.h"
#include "allocate.h"
diff -Naur cbind6.orig/buffer.c cbind6/buffer.c
---- cbind6.orig/buffer.c 1995-05-19 16:53:44.000000000 +0200
-+++ cbind6/buffer.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/buffer.c 2005-04-23 12:10:05.405384384 +0200
++++ cbind6/buffer.c 2005-04-23 12:10:18.792349256 +0200
@@ -5,7 +5,7 @@
*/
@@ -23,8 +59,8 @@ diff -Naur cbind6.orig/buffer.c cbind6/buffer.c
#include "buffer.h"
#include "allocate.h"
diff -Naur cbind6.orig/cbind.c cbind6/cbind.c
---- cbind6.orig/cbind.c 1995-05-19 17:17:06.000000000 +0200
-+++ cbind6/cbind.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/cbind.c 2005-04-23 12:10:05.417382560 +0200
++++ cbind6/cbind.c 2005-04-23 12:10:18.793349104 +0200
@@ -6,7 +6,7 @@
#include <sys/types.h>
#include <string.h>
@@ -35,8 +71,8 @@ diff -Naur cbind6.orig/cbind.c cbind6/cbind.c
#undef NULL
#define NULL 0
diff -Naur cbind6.orig/cdep.c cbind6/cdep.c
---- cbind6.orig/cdep.c 1995-05-19 19:19:36.000000000 +0200
-+++ cbind6/cdep.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/cdep.c 2005-04-23 12:10:05.419382256 +0200
++++ cbind6/cdep.c 2005-04-23 12:10:18.794348952 +0200
@@ -12,6 +12,7 @@
#include "cpp.h"
#include "cpp_hide.h"
@@ -46,9 +82,86 @@ diff -Naur cbind6.orig/cdep.c cbind6/cdep.c
#undef NULL
#define NULL 0
diff -Naur cbind6.orig/errors.c cbind6/errors.c
---- cbind6.orig/errors.c 1994-10-28 19:44:44.000000000 +0100
-+++ cbind6/errors.c 2003-06-09 21:48:02.000000000 +0200
-@@ -118,9 +118,6 @@
+--- cbind6.orig/errors.c 2005-04-23 12:10:05.422381800 +0200
++++ cbind6/errors.c 2005-04-23 12:10:57.882406664 +0200
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include <errno.h>
++#include <string.h>
+
+ int Num_Errors;
+ int Num_Warnings;
+@@ -33,14 +34,11 @@
+ }
+
+ void
+-fatal(f, l, fmt, va_alist)
+- char *f, *fmt;
+- int l;
+- va_dcl
++fatal(char *f, int l, const char *fmt, ...)
+ {
+ va_list args;
+
+- va_start(args);
++ va_start(args,fmt);
+
+ prefix(f,l,"Internal error");
+ vfprintf(stderr, fmt, args);
+@@ -52,14 +50,11 @@
+ }
+
+ void
+-error(f, l, fmt, va_alist)
+- char *f, *fmt;
+- int l;
+- va_dcl
++error(char *f, int l, char *fmt, ...)
+ {
+ va_list args;
+
+- va_start(args);
++ va_start(args,fmt);
+
+ Num_Errors++;
+ prefix(f,l,"Error");
+@@ -70,14 +65,11 @@
+ }
+
+ void
+-warning(f, l, fmt, va_alist)
+- char *f, *fmt;
+- int l;
+- va_dcl
++warning(char *f, int l, char *fmt, ...)
+ {
+ va_list args;
+
+- va_start(args);
++ va_start(args,fmt);
+
+ Num_Warnings++;
+ prefix(f,l,"Warning");
+@@ -88,14 +80,11 @@
+ }
+
+ void
+-inform(f, l, fmt, va_alist)
+- char *f, *fmt;
+- int l;
+- va_dcl
++inform(char *f, int l, char *fmt, ...)
+ {
+ va_list args;
+
+- va_start(args);
++ va_start(args,fmt);
+
+ prefix(f,l,"Info");
+ vfprintf(stderr, fmt, args);
+@@ -118,12 +107,9 @@
static void
unix_error()
{
@@ -56,11 +169,16 @@ diff -Naur cbind6.orig/errors.c cbind6/errors.c
- extern int sys_nerr;
-
if (errno != 0) {
- if (errno > 0 && errno < sys_nerr) {
- fputs(sys_errlist[errno], stderr);
+- if (errno > 0 && errno < sys_nerr) {
+- fputs(sys_errlist[errno], stderr);
++ if (errno > 0) {
++ fputs(strerror(errno), stderr);
+ }
+ else {
+ fprintf(stderr, "errno = %d", errno);
diff -Naur cbind6.orig/files.c cbind6/files.c
---- cbind6.orig/files.c 1995-05-19 16:45:30.000000000 +0200
-+++ cbind6/files.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/files.c 2005-04-23 12:10:05.422381800 +0200
++++ cbind6/files.c 2005-04-23 12:10:18.797348496 +0200
@@ -1,5 +1,6 @@
#include "ansi.h"
#include "hostinfo.h"
@@ -78,8 +196,8 @@ diff -Naur cbind6.orig/files.c cbind6/files.c
#undef NULL
diff -Naur cbind6.orig/hostinfo cbind6/hostinfo
---- cbind6.orig/hostinfo 1994-04-07 15:03:16.000000000 +0200
-+++ cbind6/hostinfo 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/hostinfo 2005-04-23 12:10:05.489371616 +0200
++++ cbind6/hostinfo 2005-04-23 12:10:18.798348344 +0200
@@ -4,25 +4,10 @@
echo '/* This file is automatically generated */' > $1
@@ -108,8 +226,8 @@ diff -Naur cbind6.orig/hostinfo cbind6/hostinfo
echo '#define HOST_OS '`uname` >> $1
diff -Naur cbind6.orig/htype.c cbind6/htype.c
---- cbind6.orig/htype.c 1995-05-19 16:52:08.000000000 +0200
-+++ cbind6/htype.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/htype.c 2005-04-23 12:10:05.447378000 +0200
++++ cbind6/htype.c 2005-04-23 12:10:18.801347888 +0200
@@ -132,10 +132,14 @@
printf("\n#define CHARS_ARE_%sSIGNED\n", (((char)-1) < 0) ? "" : "UN");
@@ -127,7 +245,7 @@ diff -Naur cbind6.orig/htype.c cbind6/htype.c
return 0;
diff -Naur cbind6.orig/llchk.c cbind6/llchk.c
--- cbind6.orig/llchk.c 1970-01-01 01:00:00.000000000 +0100
-+++ cbind6/llchk.c 2003-06-09 21:48:02.000000000 +0200
++++ cbind6/llchk.c 2005-04-23 12:10:18.802347736 +0200
@@ -0,0 +1,13 @@
+
+main()
@@ -142,45 +260,36 @@ diff -Naur cbind6.orig/llchk.c cbind6/llchk.c
+}
+
+
-diff -Naur cbind6.orig/Makefile cbind6/Makefile
---- cbind6.orig/Makefile 1995-09-22 12:21:32.000000000 +0200
-+++ cbind6/Makefile 2003-06-09 21:49:16.000000000 +0200
-@@ -91,8 +91,11 @@
-
- install: all
- - strip cbpp cbfe cbind cdep
-- - rm -f $(HOME)/bin/cbpp $(HOME)/bin/cbfe $(HOME)/bin/cbind $(HOME)/bin/cdep
-- - cp cbpp cbfe cbind cdep $(HOME)/bin
-+ - rm -f $(PREFIX)/bin/cbpp $(PREFIX)/bin/cbfe $(PREFIX)/bin/cbind $(PREFIX)/bin/cdep
-+ - install -D cbpp $(PREFIX)/bin/cbpp
-+ - install -D cbfe $(PREFIX)/bin/cbfe
-+ - install -D cbind $(PREFIX)/bin/cbind
-+ - install -D cdep $(PREFIX)/bin/cdep
-
-
-
-@@ -132,14 +135,14 @@
- mkmf -f $(MAKEFILE)
+diff -Naur cbind6.orig/nodeop.c cbind6/nodeop.c
+--- cbind6.orig/nodeop.c 2005-04-23 12:10:05.449377696 +0200
++++ cbind6/nodeop.c 2005-04-23 12:11:30.862392944 +0200
+@@ -1,5 +1,5 @@
+ #include <sys/types.h>
+-#include <varargs.h>
++#include <stdarg.h>
+ #include <stdio.h>
+ #include "ansi.h"
+ #include "host.h"
+@@ -85,14 +85,12 @@
+ }
- backup:
-- - rm -f $(HOME)/save/newc2a.tar.Z
-- tar -chf $(HOME)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
-- compress $(HOME)/save/newc2a.tar
-+ - rm -f $(PREFIX)/save/newc2a.tar.Z
-+ tar -chf $(PREFIX)/save/newc2a.tar *.1 *.c *.h *.y *.prf $(SCRIPTS) DOCS README makefile
-+ compress $(PREFIX)/save/newc2a.tar
+ node_t*
+-new_node(kind, va_alist)
+- node_kind_t kind;
+- va_dcl
++new_node(node_kind_t kind, ...)
+ {
+ va_list args;
+ node_t *n;
- touch:; touch $(GENED_SRC)
+- va_start(args);
++ va_start(args, kind);
- hostinfo.h: htype hostinfo
-- hostinfo $@
-+ ./hostinfo $@
+ n = alloc_node(kind);
- c_perf.c: c.prf
- gperf -N c_rsvd -t -p c.prf > $@
diff -Naur cbind6.orig/units.c cbind6/units.c
---- cbind6.orig/units.c 1995-09-22 12:06:46.000000000 +0200
-+++ cbind6/units.c 2003-06-09 21:48:02.000000000 +0200
+--- cbind6.orig/units.c 2005-04-23 12:10:05.453377088 +0200
++++ cbind6/units.c 2005-04-23 12:10:18.804347432 +0200
@@ -2,6 +2,7 @@
#include <sys/types.h>
#include <sys/stat.h>