summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2008-04-04 01:10:49 +0000
committerMark Loeser <halcy0n@gentoo.org>2008-04-04 01:10:49 +0000
commit10b4ee438676d7058ba6e6c9cca1d4e597d3e7cb (patch)
treea991d5158a17795286b0e07042ecfd287b391472 /dev-cpp/rudiments/rudiments-0.31.ebuild
parentamd64 stable, bug #214782 (diff)
downloadhistorical-10b4ee438676d7058ba6e6c9cca1d4e597d3e7cb.tar.gz
historical-10b4ee438676d7058ba6e6c9cca1d4e597d3e7cb.tar.bz2
historical-10b4ee438676d7058ba6e6c9cca1d4e597d3e7cb.zip
Version bump and a bit of a cleanup; bug #212613
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-cpp/rudiments/rudiments-0.31.ebuild')
-rw-r--r--dev-cpp/rudiments/rudiments-0.31.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/rudiments/rudiments-0.31.ebuild b/dev-cpp/rudiments/rudiments-0.31.ebuild
new file mode 100644
index 000000000000..5a2ff75672c3
--- /dev/null
+++ b/dev-cpp/rudiments/rudiments-0.31.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/rudiments/rudiments-0.31.ebuild,v 1.1 2008/04/04 01:10:49 halcy0n Exp $
+
+DESCRIPTION="C++ class library for daemons, clients and servers"
+HOMEPAGE="http://rudiments.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rudiments/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="debug pcre ssl"
+
+DEPEND="pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # It's a buggy configure-script
+ # We can only disable, but not enable
+ local options
+ use pcre || options="${options} --disable-pcre"
+ use ssl || options="${options} --disable-ssl"
+ econf \
+ $(use_enable debug) \
+ ${options} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${D}/usr/share/doc/${PF}/html" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}