summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-11-25 12:31:27 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-11-25 12:31:27 +0000
commita97e19699758f02caacfe7fedf73b9c46e7ccce9 (patch)
treeb1e204c0a76b1577ea128bd770f721ef05e6c854 /dev-cpp
parentversion bump, remove old version (diff)
downloadhistorical-a97e19699758f02caacfe7fedf73b9c46e7ccce9.tar.gz
historical-a97e19699758f02caacfe7fedf73b9c46e7ccce9.tar.bz2
historical-a97e19699758f02caacfe7fedf73b9c46e7ccce9.zip
Initial commit.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libebt/ChangeLog10
-rw-r--r--dev-cpp/libebt/Manifest14
-rw-r--r--dev-cpp/libebt/files/digest-libebt-0.8.21
-rw-r--r--dev-cpp/libebt/libebt-0.8.2.ebuild27
-rw-r--r--dev-cpp/libebt/metadata.xml13
5 files changed, 65 insertions, 0 deletions
diff --git a/dev-cpp/libebt/ChangeLog b/dev-cpp/libebt/ChangeLog
new file mode 100644
index 000000000000..9c24ef49f612
--- /dev/null
+++ b/dev-cpp/libebt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-cpp/libebt
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/ChangeLog,v 1.1 2005/11/25 12:31:27 ka0ttic Exp $
+
+*libebt-0.8.2 (25 Nov 2005)
+
+ 25 Nov 2005; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ +libebt-0.8.2.ebuild:
+ Initial commit.
+
diff --git a/dev-cpp/libebt/Manifest b/dev-cpp/libebt/Manifest
new file mode 100644
index 000000000000..9956252715d2
--- /dev/null
+++ b/dev-cpp/libebt/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 bf7bd6290f1f449cd585c282c27f5b94 ChangeLog 338
+MD5 4d2a12dae8034b77b03aeadb458749fb files/digest-libebt-0.8.2 65
+MD5 679ea6d879d532697e6db8037a984200 libebt-0.8.2.ebuild 799
+MD5 49b5ca6a324b8f95eba6721c1e5e7793 metadata.xml 582
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDhwQwEZCkKN40op4RAkJfAJ40a4Dg1VKB3FEsGCUZZyUjp0InZwCcDI3P
+lywm3xDEOGBMzBwtvpYrIYw=
+=24dw
+-----END PGP SIGNATURE-----
diff --git a/dev-cpp/libebt/files/digest-libebt-0.8.2 b/dev-cpp/libebt/files/digest-libebt-0.8.2
new file mode 100644
index 000000000000..d2bdbf671286
--- /dev/null
+++ b/dev-cpp/libebt/files/digest-libebt-0.8.2
@@ -0,0 +1 @@
+MD5 d532167be6de8e5cf24602aceeb47924 libebt-0.8.2.tar.bz2 139701
diff --git a/dev-cpp/libebt/libebt-0.8.2.ebuild b/dev-cpp/libebt/libebt-0.8.2.ebuild
new file mode 100644
index 000000000000..052199833227
--- /dev/null
+++ b/dev-cpp/libebt/libebt-0.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libebt/libebt-0.8.2.ebuild,v 1.1 2005/11/25 12:31:27 ka0ttic Exp $
+
+DESCRIPTION="A pure C++ template library that provides a clean way of getting human-readable backtrace messages."
+HOMEPAGE="http://libebt.berlios.de/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ use doc && { emake doxygen || die "failed to build API docs" ; }
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog README
+ use doc && dohtml -r doc/html/*
+}
diff --git a/dev-cpp/libebt/metadata.xml b/dev-cpp/libebt/metadata.xml
new file mode 100644
index 000000000000..e7a49b01b54a
--- /dev/null
+++ b/dev-cpp/libebt/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <longdescription lang="en">
+The libebt library provides a clean way of getting human-readable backtrace
+messages in C++. It uses the RAII (resource acquisition is initialisation)
+idiom to manage backtrace stack items. libebt is a pure template library,
+so there is no need to link your application against anything. libebt is
+installed into the standard include path, so no CXXFLAGS are needed either.
+ </longdescription>
+</pkgmetadata>
+