summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-12-06 13:21:04 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-12-06 13:21:04 +0000
commitb70bb313e597878f7af90730f6626333dd5d2541 (patch)
tree77bf5764dabfa81d17915bb72cc10eca9cc15891 /dev-db/hk_classes/hk_classes-0.6.2a.ebuild
parentnew version (diff)
downloadhistorical-b70bb313e597878f7af90730f6626333dd5d2541.tar.gz
historical-b70bb313e597878f7af90730f6626333dd5d2541.tar.bz2
historical-b70bb313e597878f7af90730f6626333dd5d2541.zip
new version
Diffstat (limited to 'dev-db/hk_classes/hk_classes-0.6.2a.ebuild')
-rw-r--r--dev-db/hk_classes/hk_classes-0.6.2a.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/hk_classes/hk_classes-0.6.2a.ebuild b/dev-db/hk_classes/hk_classes-0.6.2a.ebuild
new file mode 100644
index 000000000000..3fbdb5434386
--- /dev/null
+++ b/dev-db/hk_classes/hk_classes-0.6.2a.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hk_classes/hk_classes-0.6.2a.ebuild,v 1.1 2003/12/06 13:18:33 caleb Exp $
+
+DESCRIPTION="GUI-independent C++ libraries for database applications, including API documentation and tutorials."
+HOMEPAGE="http://hk-classes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sourceforge/hk-classes/${P}.tar.bz2
+ mirror://sourceforge/sourceforge/knoda/knodapython.tar.bz2
+ mirror://sourceforge/sourceforge/knoda/hk_docs-0.6.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mysql postgres odbc doc"
+
+# At least one of the following is required
+DEPEND="mysql? ( >=dev-db/mysql-3.23.54a )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ use doc && dohtml -r ${WORKDIR}/hk_docs-0.6
+ use doc && dohtml -r ${WORKDIR}/knodapythondoc
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ echo
+ einfo "hk_classes has been installed in /usr/lib/hk_classes"
+ if [ `use mysql` ]; then
+ einfo "MySQL driver is installed in /usr/lib/hk_classes/drivers"
+ fi
+ if [ `use postgres` ]; then
+ einfo "PostgreSQL driver is installed in /usr/lib/hk_classes/drivers"
+ fi
+ if [ `use odbc` ]; then
+ einfo "ODBC driver is installed in /usr/lib/hk_classes/drivers"
+ fi
+ if [ `use doc` ]; then
+ echo
+ einfo "API documentation and tutorial are installed in"
+ einfo " /usr/share/doc/${P}/html/hk_docs-0.6"
+ einfo "A small Python tutorial is installed in"
+ einfo " /usr/share/doc/${P}/html/knodapythondoc"
+ fi
+ echo
+}