summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrancesco Riosa <vivo@gentoo.org>2007-01-03 15:18:12 +0000
committerFrancesco Riosa <vivo@gentoo.org>2007-01-03 15:18:12 +0000
commitcfea4d6aff6e40904421f4a0958e572c372af7e3 (patch)
treee49c3504926f06ab1c610e45d08d0e0a24d93b3c /dev-db/mysql/mysql-5.0.26-r1.ebuild
parentpbxt and slotted (diff)
downloadhistorical-cfea4d6aff6e40904421f4a0958e572c372af7e3.tar.gz
historical-cfea4d6aff6e40904421f4a0958e572c372af7e3.tar.bz2
historical-cfea4d6aff6e40904421f4a0958e572c372af7e3.zip
lot of changes
Package-Manager: portage-2.1.2_rc4-r1
Diffstat (limited to 'dev-db/mysql/mysql-5.0.26-r1.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.0.26-r1.ebuild43
1 files changed, 32 insertions, 11 deletions
diff --git a/dev-db/mysql/mysql-5.0.26-r1.ebuild b/dev-db/mysql/mysql-5.0.26-r1.ebuild
index 3e15c2eb4b91..b7b73a181f6c 100644
--- a/dev-db/mysql/mysql-5.0.26-r1.ebuild
+++ b/dev-db/mysql/mysql-5.0.26-r1.ebuild
@@ -1,13 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.26-r1.ebuild,v 1.13 2006/12/09 22:33:45 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.26-r1.ebuild,v 1.14 2007/01/03 15:18:12 vivo Exp $
# Leave this empty
MYSQL_VERSION_ID=""
-MYSQL_RERELEASE=""
-# Set the patchset revision to use, must be either empty or a decimal number
-MYSQL_PATCHSET_REV="3"
-BASE_URI="mirror://mysql/Downloads/MySQL-${PV%.*}"
+SERVER_URI="mirror://mysql/Downloads/MySQL-${PV%.*}/mysql-${PV//_/-}.tar.gz"
inherit mysql
@@ -15,17 +12,41 @@ inherit mysql
KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
src_test() {
- cd "${S}"
- einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+
make check || die "make check failed"
if ! useq "minimal" ; then
+ cd "${S}"
einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
local retstatus
+ local t
addpredict /this-dir-does-not-exist/t9.MYI
- cd mysql-test
- sed -i -e "s|PORT=3306|PORT=3307|g" mysql-test-run
- ./mysql-test-run
+ # mysqladmin start before dir creation
+ mkdir mysql-test/var{,/log}
+
+ if [[ ${UID} -eq 0 ]] ; then
+ mysql_disable_test "im_daemon_life_cycle" "fail as root"
+ mysql_disable_test "im_life_cycle" "fail as root"
+ mysql_disable_test "im_options_set" "fail as root"
+ mysql_disable_test "im_options_unset" "fail as root"
+ mysql_disable_test "im_utils" "fail as root"
+ fi
+
+ for t in \
+ loaddata_autocom_ndb \
+ ndb_{alter_table{,2},autodiscover{,2,3},basic,bitfield,blob} \
+ ndb_{cache{,2},cache_multi{,2},charset,condition_pushdown,config} \
+ ndb_{database,gis,index,index_ordered,index_unique,insert,limit} \
+ ndb_{loaddatalocal,lock,minmax,multi,read_multi_range,rename,replace} \
+ ndb_{restore,subquery,transaction,trigger,truncate,types,update} \
+ ps_7ndb rpl_ndb_innodb_trans strict_autoinc_5ndb
+ do
+ mysql_disable_test "${t}" "fail in sandbox"
+ done
+
+ useq "extraengine" && mysql_disable_test "federated" "fail with extraengine"
+
+ make test-force-pl
retstatus=$?
# Just to be sure ;)