summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-05-04 11:38:55 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-05-04 11:38:55 +0000
commit4afb46980157fee7a4206a22a7f97e14da8c0cfe (patch)
treecfaf57e846c5114c689b0c51d18d31bcfdaa925e /dev-db/mysqltool
parentnew version with proper apache2+mod_perl support and bugfixes (diff)
downloadhistorical-4afb46980157fee7a4206a22a7f97e14da8c0cfe.tar.gz
historical-4afb46980157fee7a4206a22a7f97e14da8c0cfe.tar.bz2
historical-4afb46980157fee7a4206a22a7f97e14da8c0cfe.zip
new version with proper apache2+mod_perl support and bugfixes
Diffstat (limited to 'dev-db/mysqltool')
-rw-r--r--dev-db/mysqltool/Manifest4
-rw-r--r--dev-db/mysqltool/files/90_mysqltool.conf.m414
-rw-r--r--dev-db/mysqltool/files/digest-mysqltool-0.95-r21
-rw-r--r--dev-db/mysqltool/mysqltool-0.95-r2.ebuild83
4 files changed, 100 insertions, 2 deletions
diff --git a/dev-db/mysqltool/Manifest b/dev-db/mysqltool/Manifest
index 57cc34d4b5ab..a095fc1f3eca 100644
--- a/dev-db/mysqltool/Manifest
+++ b/dev-db/mysqltool/Manifest
@@ -1,6 +1,6 @@
-MD5 98e9aeeeb3bab4769a811541e28ffb00 mysqltool-0.95-r2.ebuild 3256
+MD5 ed0f0fdef3112cd3b1b6580de1bb4133 mysqltool-0.95-r2.ebuild 3255
MD5 3c384ea592e925a5ef7264c5699fbd73 mysqltool-0.95-r1.ebuild 2286
-MD5 3f948a5d828531b87b295056140a7012 ChangeLog 1260
+MD5 654fa7c656afb7bd8b4ceaf3053b8371 ChangeLog 1436
MD5 7c7ea28a4d6d8d49920c08d7129e6581 files/90_mysqltool.conf.m4 362
MD5 f19ea0fa37a19ab341ca96aacd0418c9 files/digest-mysqltool-0.95-r1 65
MD5 f19ea0fa37a19ab341ca96aacd0418c9 files/digest-mysqltool-0.95-r2 65
diff --git a/dev-db/mysqltool/files/90_mysqltool.conf.m4 b/dev-db/mysqltool/files/90_mysqltool.conf.m4
new file mode 100644
index 000000000000..6c84b34ec809
--- /dev/null
+++ b/dev-db/mysqltool/files/90_mysqltool.conf.m4
@@ -0,0 +1,14 @@
+<IfDefine MYSQLTOOL>
+ <IfDefine PERL>
+ PerlRequire __APACHE_SERVER_ROOT__/__APACHE_MODULES_CONF_DIR__/mysqltool.pl
+ </IfDefine>
+ <Directory __APACHE_DOCUMENT_ROOT__/htdocs/mysqltool>
+ Options ExecCGI
+ <Files *.cgi>
+ SetHandler perl-script
+ <IfDefine PERL>
+ PerlHandler MysqlTool
+ </IfDefine>
+ </Files>
+ </Directory>
+</IfDefine>
diff --git a/dev-db/mysqltool/files/digest-mysqltool-0.95-r2 b/dev-db/mysqltool/files/digest-mysqltool-0.95-r2
new file mode 100644
index 000000000000..e506852425e2
--- /dev/null
+++ b/dev-db/mysqltool/files/digest-mysqltool-0.95-r2
@@ -0,0 +1 @@
+MD5 9650d62eec7dab21d39c83d30f79a08b MysqlTool-0.95.tar.gz 44898
diff --git a/dev-db/mysqltool/mysqltool-0.95-r2.ebuild b/dev-db/mysqltool/mysqltool-0.95-r2.ebuild
new file mode 100644
index 000000000000..d6589376249e
--- /dev/null
+++ b/dev-db/mysqltool/mysqltool-0.95-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysqltool/mysqltool-0.95-r2.ebuild,v 1.1 2003/05/04 11:38:50 robbat2 Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/MysqlTool-${PV}
+DESCRIPTION="Web interface for managing one or more mysql server installations"
+SRC_URI="http://www.dajoba.com/projects/mysqltool/MysqlTool-${PV}.tar.gz"
+HOMEPAGE="http://www.dajoba.com/projects/mysqltool/"
+IUSE="apache2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ >=net-www/apache-1.3.24-r1
+ apache2? ( >=net-www/apache-2.0.45 )
+ >=dev-db/mysql-3.23.38
+ dev-perl/CGI
+ dev-perl/Apache-DBI
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ dev-perl/Crypt-Blowfish"
+
+src_install() {
+ eval `perl '-V:installarchlib'`
+ dodir /$installarchlib
+
+ cp ${S}/Makefile ${S}/Makefile.orig
+ cat ${S}/Makefile | sed -e "s!INSTALLMAN1DIR = /usr/share/man/man1!INSTALLMAN1DIR = ${D}/usr/share/man/man1!" -e "s!INSTALLMAN3DIR = /usr/share/man/man3!INSTALLMAN3DIR = ${D}/usr/share/man/man3!" > ${S}/Makefile.gentoo
+ mv ${S}/Makefile.gentoo ${S}/Makefile
+
+ make install || die
+
+ dodoc COPYING Changes MANIFEST README Upgrade
+
+ local __apache_server_root__
+ __apache_server_root__=`grep "^ServerRoot" /etc/apache2/conf/*.conf -h | cut -d' ' -f2`
+ local __apache_document_root__
+ __apache_document_root__=`grep "^DocumentRoot" /etc/apache2/conf/*.conf -h | cut -d' ' -f2`
+ local __apache_modules_conf_dir__
+ if [ "`use apache2`" ]; then
+ __apache_modules_conf_dir__="conf/modules.d"
+ else
+ __apache_modules_conf_dir__="conf/addon-modules"
+ fi;
+
+ # the cgi and images..
+ dodir ${__apache_document_root__}/mysqltool
+ cp -a htdocs/* ${D}/${__apache_document_root__}/mysqltool
+ rm ${D}/${__apache_document_root__}/mysqltool/mysqltool.conf
+
+ # the config file..
+ local apacheconfbase
+ apacheconfbase=${FILESDIR}/90_mysqltool.conf.m4
+ insinto ${__apache_server_root__}/${__apache_modules_conf_dir__}
+ cp ${S}/htdocs/mysqltool.conf ${S}/htdocs/mysqltool.pl
+ doins htdocs/mysqltool.pl
+ fowners apache.apache ${__apache_server_root__}/${__apache_modules_conf_dir__}/mysqltool.pl
+ fperms 0600 ${__apache_server_root__}/${__apache_modules_conf_dir__}/mysqltool.pl
+ m4 -D__APACHE_SERVER_ROOT__=${__apache_server_root__} -D__APACHE_DOCUMENT_ROOT__=${__apache_document_root__} -D__APACHE_MODULES_CONF_DIR__=${__apache_modules_conf_dir__} ${apacheconfbase} >${D}/${__apache_server_root__}/${__apache_modules_conf_dir__}/`basename ${apacheconfbase} .m4`
+
+ # now fix its location in the main cgi..
+ cp ${D}/${__apache_document_root__}/mysqltool/index.cgi \
+ ${D}/${__apache_document_root__}/mysqltool/index.cgi.orig
+ sed -e "s:^\(require\).*:\1 '${__apache_server_root__}/${__apache_modules_conf_dir__}/mysqltool.pl';:" \
+ ${D}/${__apache_document_root__}/mysqltool/index.cgi.orig > \
+ ${D}/${__apache_document_root__}/mysqltool/index.cgi
+ rm ${D}/${__apache_document_root__}/mysqltool/index.cgi.orig
+}
+
+pkg_postinst() {
+ einfo "To have Apache support MySQLTool, please do the following:"
+ if [ "`use apache2`" ] ; then
+ einfo "Edit /etc/conf.d/apache2 and add \"-D MYSQLTOOL\""
+ else
+ einfo "Edit /etc/conf.d/apache and add \"-D MYSQLTOOL\""
+ fi
+}