summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-06-21 18:35:13 +0000
committerDon Seiler <rizzo@gentoo.org>2004-06-21 18:35:13 +0000
commita487bbae4e7286c340e8caca7809c54480900cf2 (patch)
treefafde00df5730992d90515f3613a170284de608e /dev-db/oracle-instantclient-jdbc
parentMore accurately defining dep (diff)
downloadhistorical-a487bbae4e7286c340e8caca7809c54480900cf2.tar.gz
historical-a487bbae4e7286c340e8caca7809c54480900cf2.tar.bz2
historical-a487bbae4e7286c340e8caca7809c54480900cf2.zip
Methodology fixes and new version to close Bug #52920
Diffstat (limited to 'dev-db/oracle-instantclient-jdbc')
-rw-r--r--dev-db/oracle-instantclient-jdbc/ChangeLog10
-rw-r--r--dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2_p21
-rw-r--r--dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2_p2.ebuild50
3 files changed, 60 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient-jdbc/ChangeLog b/dev-db/oracle-instantclient-jdbc/ChangeLog
index de8a68e1d096..1b85adb7a225 100644
--- a/dev-db/oracle-instantclient-jdbc/ChangeLog
+++ b/dev-db/oracle-instantclient-jdbc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/oracle-instantclient-jdbc
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.1 2004/03/22 21:31:36 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/ChangeLog,v 1.2 2004/06/21 18:35:12 rizzo Exp $
+
+*oracle-instantclient-jdbc-10.1.0.2_p2 (21 Jun 2004)
+
+ 21 Jun 2004; Don Seiler <rizzo@gentoo.org>
+ +oracle-instantclient-jdbc-10.1.0.2_p2.ebuild:
+ New an improved version, using insinto to fix permissions problem from bug
+ #46338, and using proper patch numbering. Also closes Bug #52920, thanks to
+ Miles Grant for reporting that.
*oracle-instantclient-jdbc-10.1.0.2 (22 Mar 2004)
diff --git a/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2_p2 b/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2_p2
new file mode 100644
index 000000000000..2e5b67cdd7ec
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/files/digest-oracle-instantclient-jdbc-10.1.0.2_p2
@@ -0,0 +1 @@
+MD5 484c155eaf765c0db27904208dd17abc oracle-instantclient-jdbc-10.1.0.2-2.i386.rpm 4578884
diff --git a/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2_p2.ebuild b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2_p2.ebuild
new file mode 100644
index 000000000000..13d76e0a290e
--- /dev/null
+++ b/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2_p2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-jdbc/oracle-instantclient-jdbc-10.1.0.2_p2.ebuild,v 1.1 2004/06/21 18:35:12 rizzo Exp $
+
+inherit eutils
+
+MY_PV=${PV/_p/-}
+MY_P="${PN}-${MY_PV}.i386"
+
+S=${WORKDIR}
+DESCRIPTION="Oracle 10g client installation for Linux: JDBC supplement"
+HOMEPAGE="http://otn.oracle.com/software/tech/oci/instantclient/htdocs/linuxsoft.html"
+SRC_URI="${MY_P}.rpm"
+
+LICENSE="OTN"
+SLOT="${KV}"
+KEYWORDS="~x86"
+RESTRICT="fetch"
+IUSE=""
+
+DEPEND="app-arch/rpm2targz
+ >=dev-db/oracle-instantclient-basic-10.1.0.2_p1"
+
+pkg_nofetch() {
+ eerror "Please go to:"
+ eerror " ${HOMEPAGE}"
+ eerror "and download the JDBC supplemental package. Put it in:"
+ eerror " ${DISTDIR}"
+ eerror "after downloading it."
+}
+
+src_unpack() {
+ rpm2targz ${DISTDIR}/${MY_P}.rpm
+ tar zxf ${WORKDIR}/${MY_P}.tar.gz
+}
+
+src_install() {
+ dodir /usr/lib/oracle/10.1.0.2/client/lib
+ cd ${S}/usr/lib/oracle/10.1.0.2/client/lib
+ insinto /usr/lib/oracle/10.1.0.2/client/lib
+ doins libheteroxa10.so ocrs12.jar orai18n.jar
+}
+
+pkg_postinst() {
+ echo
+ einfo "The JDBC supplement package for Oracle 10g has been installed."
+ einfo "You may wish to install the oracle-instantclient-sqlplus (for "
+ einfo "running the SQL*Plus application) package as well."
+ echo
+}