summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-04-09 10:04:42 +0000
committerTom William Payne <twp@gentoo.org>2003-04-09 10:04:42 +0000
commit4bb88ddfd2dce6d52385f05ece187789bd66a809 (patch)
treef1366c73de059bbd2195f0a19beee19e4002c066 /dev-db/phpmyadmin
parentversion bump (diff)
downloadhistorical-4bb88ddfd2dce6d52385f05ece187789bd66a809.tar.gz
historical-4bb88ddfd2dce6d52385f05ece187789bd66a809.tar.bz2
historical-4bb88ddfd2dce6d52385f05ece187789bd66a809.zip
Dynamically determine DocumentRoot.
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/files/digest-phpmyadmin-2.4.02
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild19
3 files changed, 18 insertions, 10 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 3268b726f053..471276b863e2 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.16 2003/04/08 10:17:26 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.17 2003/04/09 10:04:04 twp Exp $
*phpmyadmin-2.4.0 (08 Apr 2003)
+ 09 Apr 2003; Tom Payne <twp@gentoo.org> phpmyadmin-2.4.0.ebuild :
+
+ Dynamically determine DocumentRoot. No bump to ebuild revision number since
+ existing users won't see a change.
+
08 Apr 2003; Tom Payne <twp@gentoo.org> phpmyadmin-2.4.0.ebuild files/phpmyadmin-config.patch files/phpmyadmin-mysql-setup.sql.in :
Version bump. Improved config file handling (doesn't overwrite on upgrade,
diff --git a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.4.0 b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.4.0
index 6a9ebe9b437f..b1d204099e4c 100644
--- a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.4.0
+++ b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.4.0
@@ -1,4 +1,4 @@
MD5 c6a79ab6f3c9e6d657a5bee36b1f6565 /files/phpmyadmin-config.patch 4857
MD5 396133c1da8d8b716ad2da23aa0a5a30 /files/phpmyadmin-mysql-setup.sql.in 2712
-MD5 a9cf5af188599198da55cb137e979303 /phpmyadmin-2.4.0.ebuild 2371
+MD5 7669a6c65ef19ce4412668c208dfd76e /phpmyadmin-2.4.0.ebuild 2503
MD5 dcd26212b311a096e1d02aa3156eec1f phpMyAdmin-2.4.0-php.tar.bz2 769848
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild
index 47145597d229..5012a93893ae 100644
--- a/dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild
+++ b/dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild,v 1.1 2003/04/08 10:17:26 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.4.0.ebuild,v 1.2 2003/04/09 10:04:04 twp Exp $
inherit eutils
@@ -36,22 +36,25 @@ src_compile() {
src_install () {
cd ${S}
- insinto /home/httpd/htdocs/phpmyadmin
+ local DocumentRoot="`grep '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+ [ -z "${DocumentRoot}" ] && DocumentRoot="/home/httpd/htdocs"
+
+ insinto ${DocumentRoot}/phpmyadmin
doins *.{php,html} ChangeLog
- insinto /home/httpd/htdocs/phpmyadmin/images
+ insinto ${DocumentRoot}/phpmyadmin/images
doins images/*.{gif,png}
- insinto /home/httpd/htdocs/phpmyadmin/scripts
+ insinto ${DocumentRoot}/phpmyadmin/scripts
doins scripts/*.sh
- insinto /home/httpd/htdocs/phpmyadmin/lang
+ insinto ${DocumentRoot}/phpmyadmin/lang
doins lang/*.{php,sh}
- insinto /home/httpd/htdocs/phpmyadmin/libraries
+ insinto ${DocumentRoot}/phpmyadmin/libraries
doins libraries/*.{php,js}
- insinto /home/httpd/htdocs/phpmyadmin/libraries/auth
+ insinto ${DocumentRoot}/phpmyadmin/libraries/auth
doins libraries/auth/*.php
dodoc ANNOUNCE.txt CREDITS ChangeLog TODO Documentation.{txt,html} \
@@ -60,7 +63,7 @@ src_install () {
insinto /etc/phpmyadmin
doins config.inc.php mysql-setup.sql
- dosym /etc/phpmyadmin/config.inc.php /home/httpd/htdocs/phpmyadmin/config.inc.php
+ dosym /etc/phpmyadmin/config.inc.php ${DocumentRoot}/phpmyadmin/config.inc.php
}