summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 15:48:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 15:48:30 +0000
commitee554fa8473e1012b8ade7be4d9ccaad57d5f23b (patch)
treeb4a2dea1efa46d394ffae163a6ac40aa9054c5cb /dev-db/postgresql-server
parentVersion bump. (diff)
downloadhistorical-ee554fa8473e1012b8ade7be4d9ccaad57d5f23b.tar.gz
historical-ee554fa8473e1012b8ade7be4d9ccaad57d5f23b.tar.bz2
historical-ee554fa8473e1012b8ade7be4d9ccaad57d5f23b.zip
Bump to 9.0_alpha4
Package-Manager: portage-2.2_rc63/cvs/Linux x86_64
Diffstat (limited to 'dev-db/postgresql-server')
-rw-r--r--dev-db/postgresql-server/ChangeLog10
-rw-r--r--dev-db/postgresql-server/files/postgresql-9.0-common.patch69
-rw-r--r--dev-db/postgresql-server/files/postgresql-9.0-makefile.patch18
-rw-r--r--dev-db/postgresql-server/files/postgresql-9.0-server.patch211
-rw-r--r--dev-db/postgresql-server/files/postgresql.conf-9.052
-rw-r--r--dev-db/postgresql-server/files/postgresql.init-9.0100
-rw-r--r--dev-db/postgresql-server/postgresql-server-9.0_alpha4.ebuild257
7 files changed, 716 insertions, 1 deletions
diff --git a/dev-db/postgresql-server/ChangeLog b/dev-db/postgresql-server/ChangeLog
index acb85d47a7f2..775d187201a2 100644
--- a/dev-db/postgresql-server/ChangeLog
+++ b/dev-db/postgresql-server/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/postgresql-server
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/ChangeLog,v 1.55 2010/02/21 10:19:48 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/ChangeLog,v 1.56 2010/02/26 15:48:30 patrick Exp $
+
+*postgresql-server-9.0_alpha4 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-server-9.0_alpha4.ebuild, +files/postgresql.conf-9.0,
+ +files/postgresql.init-9.0, +files/postgresql-9.0-common.patch,
+ +files/postgresql-9.0-makefile.patch, +files/postgresql-9.0-server.patch:
+ Bump of the alpha, 8.5 became 9.0
21 Feb 2010; Patrick Lauer <patrick@gentoo.org>
postgresql-server-8.4.2-r1.ebuild:
diff --git a/dev-db/postgresql-server/files/postgresql-9.0-common.patch b/dev-db/postgresql-server/files/postgresql-9.0-common.patch
new file mode 100644
index 000000000000..a10346ee092b
--- /dev/null
+++ b/dev-db/postgresql-server/files/postgresql-9.0-common.patch
@@ -0,0 +1,69 @@
+=== configure.in
+==================================================================
+--- configure.in 2009-06-27 02:14:47.000000000 +0200
++++ configure.in 2009-07-09 15:05:02.000000000 +0200
+@@ -19,10 +19,6 @@
+
+ AC_INIT([PostgreSQL], [9.0alpha4], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.63], [], [m4_fatal([Autoconf version 2.63 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2010, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
+=== src/include/storage/s_lock.h
+==================================================================
+--- src/include/storage/s_lock.h 2009-01-01 18:24:01.000000000 +0100
++++ src/include/storage/s_lock.h 2009-07-09 15:03:08.000000000 +0200
+@@ -298,6 +298,29 @@
+
+ #endif /* __s390__ || __s390x__ */
+
++#if defined(__sh__)
++#define HAS_TEST_AND_SET
++
++typedef unsigned char slock_t;
++
++#define TAS(lock) tas(lock)
++
++static __inline__ int
++tas(volatile slock_t *lock)
++{
++ register int _res = 1;
++
++ __asm__ __volatile__(
++ "tas.b @%1\n\t"
++ "movt %0\n\t"
++ "xor #1,%0"
++: "=z"(_res)
++: "r"(lock)
++: "t","memory");
++ return _res;
++}
++
++#endif /* __sh__ */
+
+ #if defined(__sparc__) /* Sparc */
+ #define HAS_TEST_AND_SET
+=== src/makefiles/Makefile.darwin
+==================================================================
+--- src/makefiles/Makefile.darwin 2008-11-14 11:22:47.000000000 +0100
++++ src/makefiles/Makefile.darwin 2009-07-09 15:07:11.000000000 +0200
+@@ -5,7 +5,15 @@
+ CFLAGS_SL =
+
+ ifdef PGXS
++ifdef PGXS_IN_SERVER
++ifndef PGXS_WITH_SERVER
++BE_DLLLIBS= -bundle_loader $(top_builddir)/src/backend/postgres
++else
++BE_DLLLIBS= -bundle_loader ${PGXS_WITH_SERVER}
++endif
++else
+ BE_DLLLIBS= -bundle_loader $(bindir)/postgres
++endif
+ else
+ BE_DLLLIBS= -bundle_loader $(top_builddir)/src/backend/postgres
+ endif
diff --git a/dev-db/postgresql-server/files/postgresql-9.0-makefile.patch b/dev-db/postgresql-server/files/postgresql-9.0-makefile.patch
new file mode 100644
index 000000000000..c5b60a5c5d02
--- /dev/null
+++ b/dev-db/postgresql-server/files/postgresql-9.0-makefile.patch
@@ -0,0 +1,18 @@
+--- GNUmakefile.in.old 2010-01-22 17:07:56.574071514 +0100
++++ GNUmakefile.in 2010-01-22 17:08:13.644073319 +0100
+@@ -9,7 +9,6 @@
+ include $(top_builddir)/src/Makefile.global
+
+ all:
+- $(MAKE) -C doc all
+ $(MAKE) -C src all
+ $(MAKE) -C config all
+ @echo "All of PostgreSQL successfully made. Ready to install."
+@@ -18,7 +17,6 @@
+ $(MAKE) -C doc $@
+
+ install:
+- $(MAKE) -C doc $@
+ $(MAKE) -C src $@
+ $(MAKE) -C config $@
+ @echo "PostgreSQL installation complete."
diff --git a/dev-db/postgresql-server/files/postgresql-9.0-server.patch b/dev-db/postgresql-server/files/postgresql-9.0-server.patch
new file mode 100644
index 000000000000..5f0df2b2facc
--- /dev/null
+++ b/dev-db/postgresql-server/files/postgresql-9.0-server.patch
@@ -0,0 +1,211 @@
+diff -Naur postgresql-8.5alpha3.orig/contrib/adminpack/Makefile postgresql-8.5alpha3/contrib/adminpack/Makefile
+--- postgresql-8.5alpha3.orig/contrib/adminpack/Makefile 2007-11-11 00:59:50.000000000 +0100
++++ postgresql-8.5alpha3/contrib/adminpack/Makefile 2009-07-09 18:10:56.000000000 +0200
+@@ -1,7 +1,7 @@
+ # $PostgreSQL: pgsql/contrib/adminpack/Makefile,v 1.6 2007/11/10 23:59:50 momjian Exp $
+
+ MODULE_big = adminpack
+-PG_CPPFLAGS = -I$(libpq_srcdir)
++PG_CPPFLAGS = -I$(libpq_srcdir) -I../../src/include/
+ DATA_built = adminpack.sql
+ DATA = uninstall_adminpack.sql
+ OBJS = adminpack.o
+diff -Naur postgresql-8.5alpha3.orig/contrib/dblink/Makefile postgresql-8.5alpha3/contrib/dblink/Makefile
+--- postgresql-8.5alpha3.orig/contrib/dblink/Makefile 2007-11-11 00:59:50.000000000 +0100
++++ postgresql-8.5alpha3/contrib/dblink/Makefile 2009-07-09 22:22:02.000000000 +0200
+@@ -1,7 +1,7 @@
+ # $PostgreSQL: pgsql/contrib/dblink/Makefile,v 1.15 2007/11/10 23:59:50 momjian Exp $
+
+ MODULE_big = dblink
+-PG_CPPFLAGS = -I$(libpq_srcdir)
++PG_CPPFLAGS = -I$(libpq_srcdir) -I../../src/include/
+ OBJS = dblink.o
+ SHLIB_LINK = $(libpq)
+
+diff -Naur postgresql-8.5alpha3.orig/contrib/Makefile postgresql-8.5alpha3/contrib/Makefile
+--- postgresql-8.5alpha3.orig/contrib/Makefile 2009-03-26 00:20:01.000000000 +0100
++++ postgresql-8.5alpha3/contrib/Makefile 2009-07-09 18:13:23.000000000 +0200
+@@ -23,23 +23,18 @@
+ isn \
+ lo \
+ ltree \
+- oid2name \
+ pageinspect \
+- passwordcheck \
+ pg_buffercache \
+ pg_freespacemap \
+ pg_standby \
+ pg_stat_statements \
+ pg_trgm \
+- pgbench \
+ pgcrypto \
+ pgrowlocks \
+ pgstattuple \
+ seg \
+ spi \
+ tablefunc \
+ test_parser \
+ tsearch2 \
+- unaccent \
+- vacuumlo
+
+ ifeq ($(with_openssl),yes)
+ WANTED_DIRS += sslinfo
+diff -Naur postgresql-8.5alpha3.orig/contrib/uuid-ossp/Makefile postgresql-8.5alpha3/contrib/uuid-ossp/Makefile
+--- postgresql-8.5alpha3.orig/contrib/uuid-ossp/Makefile 2007-11-13 01:13:19.000000000 +0100
++++ postgresql-8.5alpha3/contrib/uuid-ossp/Makefile 2009-07-09 19:12:44.000000000 +0200
+@@ -1,11 +1,13 @@
+ # $PostgreSQL: pgsql/contrib/uuid-ossp/Makefile,v 1.4 2007/11/13 00:13:19 tgl Exp $
+
++PG_CPPFLAGS += "-DHAVE_OSSP_UUID_H"
++
+ MODULE_big = uuid-ossp
+ OBJS = uuid-ossp.o
+ DATA_built = uuid-ossp.sql
+ DATA = uninstall_uuid-ossp.sql
+
+-SHLIB_LINK += $(OSSP_UUID_LIBS)
++SHLIB_LINK += -lossp-uuid
+
+ ifdef USE_PGXS
+ PG_CONFIG = pg_config
+diff -Naur postgresql-8.5alpha3.orig/contrib/xml2/Makefile postgresql-8.5alpha3/contrib/xml2/Makefile
+--- postgresql-8.5alpha3.orig/contrib/xml2/Makefile 2008-05-08 18:49:37.000000000 +0200
++++ postgresql-8.5alpha3/contrib/xml2/Makefile 2009-07-09 19:14:32.000000000 +0200
+@@ -4,7 +4,8 @@
+
+ OBJS = $(if $(filter -lxslt, $(LIBS)), xpath.o xslt_proc.o, xpath.o)
+
+-SHLIB_LINK += $(filter -lxslt, $(LIBS)) $(filter -lxml2, $(LIBS))
++PG_CPPFLAGS = $(shell xml2-config --cflags)
++SHLIB_LINK += $(shell xml2-config --libs) $(shell xslt-config --libs)
+
+ DATA_built = pgxml.sql
+ DATA = uninstall_pgxml.sql
+diff -Naur postgresql-8.5alpha3.orig/GNUmakefile.in postgresql-8.5alpha3/GNUmakefile.in
+--- postgresql-8.5alpha3.orig/GNUmakefile.in 2009-01-15 02:53:49.000000000 +0100
++++ postgresql-8.5alpha3/GNUmakefile.in 2009-07-09 19:16:19.000000000 +0200
+@@ -11,7 +11,6 @@
+ all:
+ $(MAKE) -C doc all
+ $(MAKE) -C src all
+- $(MAKE) -C config all
+ @echo "All of PostgreSQL successfully made. Ready to install."
+
+ world:
+@@ -27,7 +26,6 @@
+ install:
+ $(MAKE) -C doc $@
+ $(MAKE) -C src $@
+- $(MAKE) -C config $@
+ @echo "PostgreSQL installation complete."
+
+ install-world:
+@@ -40,7 +38,6 @@
+ installdirs uninstall coverage:
+ $(MAKE) -C doc $@
+ $(MAKE) -C src $@
+- $(MAKE) -C config $@
+
+ distprep:
+ $(MAKE) -C doc $@
+diff -Naur postgresql-8.5alpha3.orig/src/bin/initdb/Makefile
+postgresql-8.5alpha3/src/bin/initdb/Makefile
+--- postgresql-8.5alpha3.orig/src/bin/initdb/Makefile 2009-01-01 18:23:53.000000000 +0100
++++ postgresql-8.5alpha3/src/bin/initdb/Makefile 2009-07-09 19:17:40.000000000 +0200
+@@ -14,7 +14,7 @@
+ top_builddir = ../../..
+ include $(top_builddir)/src/Makefile.global
+
+-override CPPFLAGS := -DFRONTEND -I$(libpq_srcdir) $(CPPFLAGS)
++override CPPFLAGS := -DFRONTEND -I$(top_srcdir)/src/interfaces/libpq $(CPPFLAGS)
+
+ OBJS= initdb.o encnames.o pqsignal.o $(WIN32RES)
+
+diff -Naur postgresql-8.5alpha3.orig/src/bin/Makefile postgresql-8.5alpha3/src/bin/Makefile
+--- postgresql-8.5alpha3.orig/src/bin/Makefile 2009-01-01 18:23:53.000000000 +0100
++++ postgresql-8.5alpha3/src/bin/Makefile 2009-07-09 19:18:21.000000000 +0200
+@@ -13,8 +13,8 @@
+ top_builddir = ../..
+ include $(top_builddir)/src/Makefile.global
+
+-SUBDIRS = initdb pg_ctl pg_dump \
+- psql scripts pg_config pg_controldata pg_resetxlog
++SUBDIRS = initdb pg_ctl \
++ pg_controldata pg_resetxlog
+ ifeq ($(PORTNAME), win32)
+ SUBDIRS+=pgevent
+ endif
+diff -Naur postgresql-8.5alpha3.orig/src/include/pg_config_manual.h postgresql-8.5alpha3/src/include/pg_config_manual.h
+--- postgresql-8.5alpha3.orig/src/include/pg_config_manual.h 2009-06-11 16:49:08.000000000 +0200
++++ postgresql-8.5alpha3/src/include/pg_config_manual.h 2009-07-09 19:19:40.000000000 +0200
+@@ -146,7 +146,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/var/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
+diff -Naur postgresql-8.5alpha3.orig/src/Makefile postgresql-8.5alpha3/src/Makefile
+--- postgresql-8.5alpha3.orig/src/Makefile 2009-02-24 11:06:32.000000000 +0100
++++ postgresql-8.5alpha3/src/Makefile 2009-07-09 19:20:44.000000000 +0200
+@@ -19,15 +19,11 @@
+ $(MAKE) -C backend $@
+ $(MAKE) -C backend/utils/mb/conversion_procs $@
+ $(MAKE) -C backend/snowball $@
+- $(MAKE) -C include $@
+- $(MAKE) -C interfaces $@
+- $(MAKE) -C backend/replication/libpqwalreceiver $@
+ $(MAKE) -C bin $@
+ $(MAKE) -C pl $@
+- $(MAKE) -C makefiles $@
+ $(MAKE) -C test/regress $@
+
+-install: install-local
++install:
+
+ install-local: installdirs-local
+ $(INSTALL_DATA) Makefile.global '$(DESTDIR)$(pgxsdir)/$(subdir)/Makefile.global'
+diff -Naur postgresql-8.5alpha3.orig/src/Makefile.global.in postgresql-8.5alpha3/src/Makefile.global.in
+--- postgresql-8.5alpha3.orig/src/Makefile.global.in 2009-06-23 05:46:00.000000000 +0200
++++ postgresql-8.5alpha3/src/Makefile.global.in 2009-07-09 19:39:46.000000000 +0200
+@@ -443,6 +441,8 @@
+ LDFLAGS += $(PROFILE)
+ endif
+
++CFLAGS += -I${top_srcdir}/src/include
++
+
+ ##########################################################################
+ #
+diff -Naur postgresql-8.5alpha3.orig/src/port/Makefile postgresql-8.5alpha3/src/port/Makefile
+--- postgresql-8.5alpha3.orig/src/port/Makefile 2008-11-25 19:19:31.000000000 +0100
++++ postgresql-8.5alpha3/src/port/Makefile 2009-07-09 19:24:34.000000000 +0200
+@@ -39,11 +39,10 @@
+ # foo_srv.o and foo.o are both built from foo.c, but only foo.o has -DFRONTEND
+ OBJS_SRV = $(OBJS:%.o=%_srv.o)
+
+-all: libpgport.a libpgport_srv.a
++all: libpgport_srv.a
+
+ # libpgport is needed by some contrib
+-install: all installdirs
+- $(INSTALL_STLIB) libpgport.a '$(DESTDIR)$(libdir)/libpgport.a'
++install:
+
+ installdirs:
+ $(mkinstalldirs) '$(DESTDIR)$(libdir)'
+diff -Naur postgresql-8.5alpha3.orig/src/test/regress/GNUmakefile postgresql-8.5alpha3/src/test/regress/GNUmakefile
+--- postgresql-8.5alpha3.orig/src/test/regress/GNUmakefile 2009-01-01 18:24:04.000000000 +0100
++++ postgresql-8.5alpha3/src/test/regress/GNUmakefile 2009-07-09 19:28:25.000000000 +0200
+@@ -141,7 +141,7 @@
+ pg_regress_call = ./pg_regress --inputdir=$(srcdir) --dlpath=. --multibyte=$(MULTIBYTE) --load-language=plpgsql $(NOLOCALE)
+
+ check: all
+- $(pg_regress_call) --temp-install=./tmp_check --top-builddir=$(top_builddir) --schedule=$(srcdir)/parallel_schedule $(MAXCONNOPT) $(TEMP_CONF)
++ $(pg_regress_call) --temp-install=./tmp_check --top-builddir=$(top_builddir) --schedule=$(srcdir)/parallel_schedule $(MAXCONNOPT) $(TEMP_CONF) --psqldir=/usr/lib/postgresql-${SLOT}/bin/
+
+ installcheck: all
+ $(pg_regress_call) --psqldir=$(PSQLDIR) --schedule=$(srcdir)/serial_schedule
diff --git a/dev-db/postgresql-server/files/postgresql.conf-9.0 b/dev-db/postgresql-server/files/postgresql.conf-9.0
new file mode 100644
index 000000000000..fc14f0ca46be
--- /dev/null
+++ b/dev-db/postgresql-server/files/postgresql.conf-9.0
@@ -0,0 +1,52 @@
+# PostgreSQL's Database Directory
+PGDATA="/var/lib/postgresql/9.0/data"
+
+# PostgreSQL User
+PGUSER="postgres"
+
+# PostgreSQL Group
+PGGROUP="postgres"
+
+# Extra options to run postmaster with, e.g.:
+# -N is the maximal number of client connections
+# -B is the number of shared buffers and has to be at least 2x the value for -N
+# Please read the man-page to postmaster for more options. Many of these options
+# can be set directly in the configuration-file.
+#PGOPTS="-N 512 -B 1024"
+
+
+# SERVER SHUTDOWN:
+# The server will receive 3 signals in the worst case:
+# 1. SIGTERM
+# This signals the server to ignore new connections and to
+# wait for all clients to end their transactions before shutting down.
+# Use WAIT_FOR_DISCONNECT to control how much time the clients
+# should have until the next signal is being sent.
+# 2. SIGINT
+# Tell the server to forcefully disconnect all clients.
+# Terminating a client results in a rollback of the open transactions for this client.
+# Use WAIT_FOR_CLEANUP to determine how much time the server has
+# for cleanup.
+# 3. SIGQUIT
+# This will terminate the server immediately and results in a recovery run for the next start.
+
+# Wait for clients to disconnect
+WAIT_FOR_DISCONNECT=30
+
+# Time the server has to clean up
+WAIT_FOR_CLEANUP=60
+
+# Time the server has to quit (with a recover-run on next startup)
+# Set to 0 to deactivate it
+WAIT_FOR_QUIT=60
+
+# Comment this out if you don't want to wait for the server to
+# startup before continuing. For example, if this server is a
+# PITR log shipping based replication standby
+WAIT_FOR_START="-w"
+
+# If you have to export environment variables for the database process,
+# this can be done here.
+#
+# Example:
+# export R_HOME="/usr/lib/R"
diff --git a/dev-db/postgresql-server/files/postgresql.init-9.0 b/dev-db/postgresql-server/files/postgresql.init-9.0
new file mode 100644
index 000000000000..6bb74d0dc5a6
--- /dev/null
+++ b/dev-db/postgresql-server/files/postgresql.init-9.0
@@ -0,0 +1,100 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/files/postgresql.init-9.0,v 1.1 2010/02/26 15:48:28 patrick Exp $
+
+opts="${opts} reload"
+
+depend() {
+ use net
+ if [ -L /etc/eselect/postgresql/service ] ; then
+ local p_service="$(for f in /etc/eselect/postgresql/service/* ; do . $f ; done ; echo $postgres_service )"
+ test "${p_service}" = "${SVCNAME}" && provide postgresql
+ fi
+}
+
+checkconfig() {
+ if [ ! -d "$PGDATA" ] ; then
+ eerror "Directory not found: $PGDATA"
+ eerror "Please make sure that PGDATA points to the right path."
+ eerror "You can run 'emerge postgresql-server --config' to setup a new database cluster."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting PostgreSQL"
+
+ if [ -f "$PGDATA/postmaster.pid" ] ; then
+ rm -f "$PGDATA/postmaster.pid"
+ fi
+
+ local retval
+
+ su -l ${PGUSER} \
+ -c "env PGDATA=\"${PGDATA}\" /usr/lib/postgresql-9.0/bin/pg_ctl start ${WAIT_FOR_START} -o '--silent-mode=true ${PGOPTS}'"
+ retval=$?
+ [ $retval -ne 0 ] && eend $retval && return $retval
+
+ # The following is to catch the case of an already running server
+ # in which pg_ctl doesn't know to which server it connected to and false reports the server as 'up'
+ sleep 2
+ if [ ! -f "$PGDATA/postmaster.pid" ] ; then
+ eerror "The pid-file doesn't exist but pg_ctl reported a running server."
+ eerror "Please check whether there is another server running on the same port or read the log-file."
+ eend 1
+ return 1
+ fi
+
+ local pid=$(grep "^[0-9]\+" "$PGDATA/postmaster.pid")
+ ps -p "${pid}" &> /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping PostgreSQL (this can take up to $(( ${WAIT_FOR_DISCONNECT} + ${WAIT_FOR_CLEANUP} )) seconds)"
+
+ local retval
+
+ su -l ${PGUSER} \
+ -c "env PGDATA=\"${PGDATA}\" /usr/lib/postgresql-9.0/bin/pg_ctl stop -t ${WAIT_FOR_DISCONNECT} -m smart"
+
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
+
+ ewarn "Some clients did not disconnect within ${WAIT_FOR_DISCONNECT} seconds."
+ ewarn "Going to shutdown the server anyway."
+
+ su -l ${PGUSER} \
+ -c "env PGDATA=\"${PGDATA}\" /usr/lib/postgresql-9.0/bin/pg_ctl stop -m fast"
+
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
+
+ if [ ${WAIT_FOR_QUIT} -eq 0 ] ; then
+ eerror "Server did not shut down and sending the SIGQUIT has been disabled."
+ eend $retval
+ return $retval
+ fi
+
+ ewarn "Shutting down the server gracefully failed."
+ ewarn "Forcing it to shutdown which leads to a recover-run on next startup."
+
+ su -l ${PGUSER} \
+ -c "env PGDATA=\"${PGDATA}\" /usr/lib/postgresql-9.0/bin/pg_ctl stop -m immediate"
+
+ retval=$?
+ [ $retval -eq 0 ] && eend $retval && return $retval
+
+ eerror "Forced shutdown failed!!! Something is wrong with your system, please take care of it manually."
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading PostgreSQL configuration"
+ su -l ${PGUSER} \
+ -c "env PGDATA=\"${PGDATA}\" /usr/lib/postgresql-9.0/bin/pg_ctl reload"
+ eend $?
+}
diff --git a/dev-db/postgresql-server/postgresql-server-9.0_alpha4.ebuild b/dev-db/postgresql-server/postgresql-server-9.0_alpha4.ebuild
new file mode 100644
index 000000000000..e880d7a76db2
--- /dev/null
+++ b/dev-db/postgresql-server/postgresql-server-9.0_alpha4.ebuild
@@ -0,0 +1,257 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-server/postgresql-server-9.0_alpha4.ebuild,v 1.1 2010/02/26 15:48:30 patrick Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2"
+
+# weird test failures.
+RESTRICT="test"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="none"
+inherit autotools eutils multilib python toolchain-funcs versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="PostgreSQL server"
+HOMEPAGE="http://www.postgresql.org/"
+
+MY_PV=${PV/_/}
+SRC_URI="mirror://postgresql/source/${MY_PV}/postgresql-${MY_PV}.tar.bz2"
+S=${WORKDIR}/postgresql-${MY_PV}
+
+LICENSE="POSTGRESQL"
+SLOT="$(get_version_component_range 1-2)"
+IUSE_LINGUAS="
+ linguas_af linguas_cs linguas_de linguas_es linguas_fa linguas_fr
+ linguas_hr linguas_hu linguas_it linguas_ko linguas_nb linguas_pl
+ linguas_pt_BR linguas_ro linguas_ru linguas_sk linguas_sl linguas_sv
+ linguas_tr linguas_zh_CN linguas_zh_TW"
+IUSE="pg_legacytimestamp doc perl python selinux tcl uuid xml nls kernel_linux ${IUSE_LINGUAS}"
+
+wanted_languages() {
+ for u in ${IUSE_LINGUAS} ; do
+ use $u && echo -n "${u#linguas_} "
+ done
+}
+
+RDEPEND="~dev-db/postgresql-base-${PV}:${SLOT}[pg_legacytimestamp=]
+ perl? ( >=dev-lang/perl-5.6.1-r2 )
+ python? ( dev-python/egenix-mx-base )
+ selinux? ( sec-policy/selinux-postgresql )
+ tcl? ( >=dev-lang/tcl-8 )
+ uuid? ( dev-libs/ossp-uuid )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ xml? ( dev-util/pkgconfig )"
+PDEPEND="doc? ( dev-db/postgresql-docs:${SLOT} )"
+
+pkg_setup() {
+ enewgroup postgres 70
+ enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
+
+ if use python; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/postgresql-${SLOT}-common.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-server.patch" \
+ "${FILESDIR}/postgresql-${SLOT}-makefile.patch"
+
+ if hasq test ${FEATURES}; then
+ sed -e "s|/no/such/location|${S}/src/test/regress/tmp_check/no/such/location|g" -i src/test/regress/{input,output}/tablespace.source
+ else
+ echo "all install:" > "${S}/src/test/regress/GNUmakefile"
+ fi
+
+ eautoconf
+}
+
+src_configure() {
+ # TODO: test if PPC really cannot work with other CFLAGS settings
+ # use ppc && CFLAGS="-pipe -fsigned-char"
+
+ # eval is needed to get along with pg_config quotation of space-rich entities.
+ eval econf "$(/usr/$(get_libdir)/postgresql-${SLOT}/bin/pg_config --configure)" \
+ --disable-thread-safety \
+ $(use_with perl) \
+ $(use_with python) \
+ $(use_with tcl) \
+ $(use_with xml libxml) \
+ $(use_with xml libxslt) \
+ $(use_with uuid ossp-uuid) \
+ --with-system-tzdata="/usr/share/zoneinfo" \
+ --with-includes="/usr/include/postgresql-${SLOT}/" \
+ --with-libraries="/usr/$(get_libdir)/postgresql-${SLOT}/$(get_libdir)" \
+ "$(built_with_use ~dev-db/postgresql-base-${PV} nls && use_enable nls nls "$(wanted_languages)")"
+}
+
+src_compile() {
+ local bd
+ for bd in . contrib $(use xml && echo contrib/xml2); do
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+ emake -C $bd -j1 LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die "emake in $bd failed"
+ done
+}
+
+src_install() {
+ if use perl ; then
+ mv -f "${S}/src/pl/plperl/GNUmakefile" "${S}/src/pl/plperl/GNUmakefile_orig"
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ "${S}/src/pl/plperl/GNUmakefile_orig" > "${S}/src/pl/plperl/GNUmakefile"
+ fi
+
+ for bd in . contrib $(use xml && echo contrib/xml2) ; do
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+ emake install -C $bd -j1 DESTDIR="${D}" || die "emake install in $bd failed"
+ done
+
+ rm -rf "${D}/usr/share/postgresql-${SLOT}/man/man7/" "${D}/usr/share/doc/postgresql-${SLOT}/html"
+ rm "${D}"/usr/share/postgresql-${SLOT}/man/man1/{clusterdb,create{db,lang,user},drop{db,lang,user},ecpg,pg_{config,dump,dumpall,restore},psql,reindexdb,vacuumdb}.1
+
+ dodoc README HISTORY doc/{README.*,TODO,bug.template}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ cat >"${D}/etc/eselect/postgresql/slots/${SLOT}/service" <<-__EOF__
+ postgres_ebuilds="\${postgres_ebuilds} ${PF}"
+ postgres_service="postgresql-${SLOT}"
+ __EOF__
+
+ newinitd "${FILESDIR}/postgresql.init-${SLOT}" postgresql-${SLOT} || die "Inserting init.d-file failed"
+ newconfd "${FILESDIR}/postgresql.conf-${SLOT}" postgresql-${SLOT} || die "Inserting conf.d-file failed"
+
+ keepdir /var/run/postgresql
+ fperms 0770 /var/run/postgresql
+ fowners postgres:postgres /var/run/postgresql
+}
+
+pkg_postinst() {
+ eselect postgresql update
+ [[ "$(eselect postgresql show)" = "(none)" ]] && eselect postgresql set ${SLOT}
+ [[ "$(eselect postgresql show-service)" = "(none)" ]] && eselect postgresql set-service ${SLOT}
+
+ ewarn "Please note that the standard location of the socket has changed from /tmp"
+ ewarn "to /var/run/postgresql and you have to be in the 'postgres' group to access"
+ ewarn "the socket."
+ ewarn "This can break applications which have the standard location hard-coded."
+ ewarn "If such an application links against the libpq, please re-emerge it,"
+ ewarn "if that doesn't help or the application accesses the socket without using libpq,"
+ ewarn "please file a bug-report."
+ ewarn "You can set PGOPTS='-k /tmp' in /etc/conf.d/postgresql-${SLOT} to restore the original location."
+
+ elog "Execute the following command to setup the initial database environment:"
+ elog
+ elog "emerge --config =${CATEGORY}/${PF}"
+ elog
+ elog "The autovacuum function, which was in contrib, has been moved to the main"
+ elog "PostgreSQL functions starting with 8.1 and starting with 8.4 is now"
+ elog "enabled by default. You can disable it in the cluster's postgresql.conf."
+ elog
+ elog "The timestamp format is 64bit integers now. If you upgrade from older databases"
+ elog "this may force you to either do a dump and reload or enable pg_legacytimestamp"
+ elog "until you find time to do so. If the database can't start please try enabling"
+ elog "pg_legacytimestamp and rebuild."
+}
+
+pkg_postrm() {
+ eselect postgresql update
+}
+
+pkg_config() {
+ [[ -z "${PGDATA}" ]] && PGDATA="/var/lib/postgresql/${SLOT}/data"
+
+ einfo "You can pass options to initdb by setting the PG_INITDB_OPTS variable."
+ einfo "More information can be found here:"
+ einfo " http://www.postgresql.org/docs/${SLOT}/static/creating-cluster.html"
+ einfo " http://www.postgresql.org/docs/${SLOT}/static/app-initdb.html"
+ einfo "Simply add the options you would have added to initdb to the PG_INITDB_OPTS variable."
+ einfo
+ einfo "You can change the directory where the database cluster is being created by setting"
+ einfo "the PGDATA variable."
+ einfo
+ einfo "PG_INITDB_OPTS is currently set to:"
+ einfo " \"${PG_INITDB_OPTS}\""
+ einfo "and the database cluster will be created in:"
+ einfo " \"${PGDATA}\""
+ einfo "Are you ready to continue? (Y/n)"
+ read answer
+ [ -z $answer ] && answer=Y
+ [ "$answer" == "Y" ] || [ "$answer" == "y" ] || die "aborted"
+
+ if [[ -f "${PGDATA}/PG_VERSION" ]] ; then
+ eerror "The given directory \"${PGDATA}\" already contains a database cluster."
+ die "cluster already exists"
+ fi
+
+ [ -z "${PG_MAX_CONNECTIONS}" ] && PG_MAX_CONNECTIONS="128"
+ einfo "Checking system parameters..."
+
+ if ! use kernel_linux ; then
+ SKIP_SYSTEM_TESTS=yes
+ einfo " Tests not supported on this OS (yet)"
+ fi
+
+ if [ -z ${SKIP_SYSTEM_TESTS} ] ; then
+ einfo "Checking whether your system supports at least ${PG_MAX_CONNECTIONS} connections..."
+
+ local SEMMSL=$(sysctl -n kernel.sem | cut -f1)
+ local SEMMNS=$(sysctl -n kernel.sem | cut -f2)
+ local SEMMNI=$(sysctl -n kernel.sem | cut -f4)
+ local SHMMAX=$(sysctl -n kernel.shmmax)
+
+ local SEMMSL_MIN=17
+ local SEMMNS_MIN=$(( ( ${PG_MAX_CONNECTIONS}/16 ) * 17 ))
+ local SEMMNI_MIN=$(( ( ${PG_MAX_CONNECTIONS}+15 ) / 16 ))
+ local SHMMAX_MIN=$(( 500000 + ( 30600 * ${PG_MAX_CONNECTIONS} ) ))
+
+ for p in SEMMSL SEMMNS SEMMNI SHMMAX ; do
+ if [ $(eval echo \$$p) -lt $(eval echo \$${p}_MIN) ] ; then
+ eerror "The value for ${p} $(eval echo \$$p) is below the recommended value $(eval echo \$${p}_MIN)"
+ eerror "You have now several options:"
+ eerror " - Change the mentioned system parameter"
+ eerror " - Lower the number of max.connections by setting PG_MAX_CONNECTIONS to a value lower than ${PG_MAX_CONNECTIONS}"
+ eerror " - Set SKIP_SYSTEM_TESTS in case you want to ignore this test completely"
+ eerror "More information can be found here:"
+ eerror " http://www.postgresql.org/docs/${SLOT}/static/kernel-resources.html"
+ die "system test failed"
+ fi
+ done
+ einfo "Passed."
+ else
+ einfo "Skipped."
+ fi
+
+ einfo "Creating the data directory ..."
+ mkdir -p "${PGDATA}"
+ chown -Rf postgres:postgres "${PGDATA}"
+ chmod 0700 "${PGDATA}"
+
+ einfo "Initializing the database ..."
+
+ su postgres -c "/usr/$(get_libdir)/postgresql-${SLOT}/bin/initdb --pgdata \"${PGDATA}\" ${PG_INITDB_OPTS}"
+
+ einfo
+ einfo "You can use the '${ROOT}/etc/init.d/postgresql-${SLOT}' script to run PostgreSQL instead of 'pg_ctl'."
+ einfo
+
+ if [ "${PGDATA}" != "/var/lib/postgresql/${SLOT}/data" ] ; then
+ ewarn "You didn't install the database cluster in the standard location, please make sure that you set"
+ ewarn "PGDATA=\"${PGDATA}\" in the appropriate conf.d file (probably /etc/conf.d/postgresql-${SLOT})"
+ fi
+}
+
+src_test() {
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ PATH="/usr/$(get_libdir)/postgresql-${SLOT}/bin:${PATH}" \
+ emake -j1 check || die "Make check failed. See above for details."
+
+ einfo "Yes, there are other tests which could be run."
+ einfo "... and no, we don't plan to add/support them."
+ einfo "For now, the main regressions tests will suffice."
+ einfo "If you think other tests are necessary, please submit a"
+ einfo "bug including a patch for this ebuild to enable them."
+}