summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-02 17:03:55 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-02 17:03:55 +0000
commit59fe870916a412408648a505a7144651b9f55157 (patch)
treebaaefc852f4dda23a653938d57702a0af28c7334 /dev-db/postgresql
parentunmasked WindowMaker (diff)
downloadhistorical-59fe870916a412408648a505a7144651b9f55157.tar.gz
historical-59fe870916a412408648a505a7144651b9f55157.tar.bz2
historical-59fe870916a412408648a505a7144651b9f55157.zip
Fixes to startup script. Fixes #4416. Thanks to Tom von Schwerdtner
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/ChangeLog11
-rw-r--r--dev-db/postgresql/files/7.2/postgresql2
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.2-r31
-rw-r--r--dev-db/postgresql/postgresql-7.2-r3.ebuild154
4 files changed, 166 insertions, 2 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 5a37397e4010..1f817a8f0ca0 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.12 2002/06/20 14:25:45 prez Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.13 2002/07/02 17:03:55 rphillips Exp $
+
+*postgresql-7.2-r3 (02 Jul 2002)
+
+ 02 Jul 2002; Ryan Phillips <rphillips@gentoo.org> files/7.2/postgresql,
+ postgresql-7.2-r3.ebuild
+
+ Fixes to the path of the postmaster pidfile.
+ Fixes to the ebuild to disable java version checking if java
+ is not in the use vars.
*postgresql-7.2.1-r1 (20 Jun 2002)
diff --git a/dev-db/postgresql/files/7.2/postgresql b/dev-db/postgresql/files/7.2/postgresql
index a69795b64259..0129b56440bf 100644
--- a/dev-db/postgresql/files/7.2/postgresql
+++ b/dev-db/postgresql/files/7.2/postgresql
@@ -16,6 +16,6 @@ start() {
stop () {
ebegin "Stopping postgres"
- start-stop-daemon --stop --quiet --pidfile=/var/lib/postgresql/postmaster.pid
+ start-stop-daemon --stop --quiet --pidfile=/var/lib/postgresql/data/postmaster.pid
eend $?
}
diff --git a/dev-db/postgresql/files/digest-postgresql-7.2-r3 b/dev-db/postgresql/files/digest-postgresql-7.2-r3
new file mode 100644
index 000000000000..c0daa65f8ba7
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.2-r3
@@ -0,0 +1 @@
+MD5 4174777cd91f3cc96f91efb2e4e1bc7c postgresql-7.2.tar.gz 9180168
diff --git a/dev-db/postgresql/postgresql-7.2-r3.ebuild b/dev-db/postgresql/postgresql-7.2-r3.ebuild
new file mode 100644
index 000000000000..3c52ac10a795
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.2-r3.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Geert Bevin <gbevin@theleaf.be>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2-r3.ebuild,v 1.3 2002/07/02 17:03:55 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.easynet.be/postgresql/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.postgresql.org"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( =virtual/jdk-1.3* >=dev-java/ant-1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( =virtual/jdk-1.3* )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+SLOT="0"
+
+pkg_setup() {
+ local foo
+ if [ "`use java`" ] ; then
+ foo=`java-config --java-version 2>&1 | grep "1.4.0"`
+ if [ ! -z "$foo" ] ; then
+ einfo "Cannot build with Sun JDK 1.4.0, use an 1.3.x JDK instead."
+ exit 1
+ fi
+ fi
+}
+src_unpack() {
+
+ unpack postgresql-${PV}.tar.gz
+
+ cd ${S}
+
+ # we know that a shared libperl is present, the default perl
+ # config is however set to the static libperl.a
+ # just remove the check
+ patch -p1 < ${FILESDIR}/${P}-dyn-libperl-gentoo.diff || die
+}
+
+src_compile() {
+
+ local myconf
+ if [ "`use tcltk`" ]
+ then
+ myconf="--with-tcl"
+ fi
+ if [ "`use python`" ]
+ then
+ myconf="$myconf --with-python"
+ fi
+ if [ "`use perl`" ]
+ then
+ myconf="$myconf --with-perl"
+ fi
+ if [ "`use java`" ]
+ then
+ myconf="$myconf --with-java"
+ fi
+ if [ "`use ssl`" ]
+ then
+ myconf="$myconf --with-openssl=/usr"
+ fi
+ if [ "`use nls`" ]
+ then
+ myconf="$myconf --enable-locale"
+ fi
+ if [ "`use libg++`" ]
+ then
+ myconf="$myconf --with-CXX"
+ fi
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/lib \
+ --enable-syslog \
+ $myconf || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ if [ "`use perl`" ]
+ then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} install-all-headers || die
+ dodoc COPYRIGHT HISTORY INSTALL README register.txt
+ cd ${S}/doc
+ dodoc FAQ* KNOWN_BUGS MISSING_FEATURES README*
+ dodoc TODO internals.ps bug.template
+ dodoc *.tar.gz
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto sgml/graphics
+ dodoc src/graphics/*
+ rm -rf ${D}/usr/doc ${D}/mnt
+ exeinto /usr/bin
+
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/${PV}/${PN}
+
+ einfo ">>> Execute the following command"
+ einfo ">>> ebuild /var/db/pkg/dev-db/${P}/${P}.ebuild config"
+ einfo ">>> to setup the initial database environment."
+}
+
+
+pkg_config() {
+
+ einfo ">>> Creating data directory ..."
+ mkdir -p /var/lib/postgresql/data
+ chown -Rf postgres.postgres /var/lib/postgresql
+ chmod 700 /var/lib/postgresql/data
+
+ einfo ">>> Initializing the database ..."
+ if [ -f /var/lib/postgresql/data/PG_VERSION ] ; then
+ echo -n "A postgres data directory already exists from version "; cat /var/lib/postgresql/data/PG_VERSION
+ echo "Read the documentation to check how to upgrade to version ${PV}."
+ else
+ su - postgres -c "/usr/bin/initdb --pgdata /var/lib/postgresql/data"
+ fi
+
+}