summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-14 17:37:58 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-14 17:37:58 +0000
commit97daf7d82d0fe182fbeb8179e09daaeae7355595 (patch)
tree38a0ad522259546917da694a701725e414ffc980 /dev-db/sqlite/sqlite-2.8.16-r4.ebuild
parentFix the test broken RESTRICT atom that Cardoe added. The tcl use flag must be... (diff)
downloadhistorical-97daf7d82d0fe182fbeb8179e09daaeae7355595.tar.gz
historical-97daf7d82d0fe182fbeb8179e09daaeae7355595.tar.bz2
historical-97daf7d82d0fe182fbeb8179e09daaeae7355595.zip
Fix the rest of the ebuilds wrt tcl and test suite.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-db/sqlite/sqlite-2.8.16-r4.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r4.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
index a000f0a60b65..51b8f823d493 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.18 2007/05/23 01:14:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.19 2007/06/14 17:37:58 betelgeuse Exp $
inherit eutils alternatives toolchain-funcs
@@ -21,13 +21,20 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
-RESTRICT="tcl? ( test )"
+RESTRICT="!tcl? ( test )"
src_unpack() {
# test
- if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
+ if has test ${FEATURES}; then
+ if ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl; then
+ ewarn "You must enable the tcl use flag if you want to run the test"
+ ewarn "suite."
+ eerror "Testsuite will not be run."
+ fi
fi
unpack ${A}