summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-12-10 07:31:22 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-12-10 07:31:22 +0000
commitc83866a093b621def3452216e3309e5e4c2c5801 (patch)
tree6cbf576ef9c9126fc4a30dd7dc05ae2282bca7c5 /dev-db/tora
parentkeywords blah (diff)
downloadhistorical-c83866a093b621def3452216e3309e5e4c2c5801.tar.gz
historical-c83866a093b621def3452216e3309e5e4c2c5801.tar.bz2
historical-c83866a093b621def3452216e3309e5e4c2c5801.zip
keywords blah
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/Manifest2
-rw-r--r--dev-db/tora/files/digest-tora-1.3.11-r21
-rw-r--r--dev-db/tora/tora-1.3.11-r2.ebuild56
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-db/tora/Manifest b/dev-db/tora/Manifest
index 4e8ea17d6caf..5e2071e66bf4 100644
--- a/dev-db/tora/Manifest
+++ b/dev-db/tora/Manifest
@@ -1,4 +1,4 @@
-MD5 dfe5ee70936d7c075a8f2f765a951f36 tora-1.3.11-r2.ebuild 1452
+MD5 c250706e6aa3747124b7050c0372b9b5 tora-1.3.11-r2.ebuild 1448
MD5 b57d4b199d428af9f22aa328e1b7be81 tora-1.3.12.ebuild 1325
MD5 53010cf88b5b626651dac3df85960a04 ChangeLog 3102
MD5 bda8803c4adc9cf0b308b71157891f05 metadata.xml 536
diff --git a/dev-db/tora/files/digest-tora-1.3.11-r2 b/dev-db/tora/files/digest-tora-1.3.11-r2
new file mode 100644
index 000000000000..d176267843c8
--- /dev/null
+++ b/dev-db/tora/files/digest-tora-1.3.11-r2
@@ -0,0 +1 @@
+MD5 e056c5c84db1da8bccd7688a0aef9317 tora-alpha-1.3.11.tar.gz 2405314
diff --git a/dev-db/tora/tora-1.3.11-r2.ebuild b/dev-db/tora/tora-1.3.11-r2.ebuild
new file mode 100644
index 000000000000..8cf4a9ee09be
--- /dev/null
+++ b/dev-db/tora/tora-1.3.11-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.11-r2.ebuild,v 1.7 2003/12/10 07:31:20 seemant Exp $
+
+IUSE="kde oci8"
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://www.globecom.se/tora/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ dev-lang/perl
+ kde? ( >=kde-base/kdebase-3.1 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ ewarn "ORACLE_HOME variable is not set."
+ ewarn ""
+ ewarn "You must install Oracle >= 8i client for Linux in"
+ ewarn "order to compile TOra with Oracle support."
+ ewarn ""
+ ewarn "Otherwise specify -oci8 in your USE variable."
+ ewarn ""
+ ewarn "You can download the Oracle software from"
+ ewarn "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${PN}-alpha-${PV}.tar.gz
+ cd ${P}
+ epatch ${FILESDIR}/tora-index-segfault.patch
+ epatch ${FILESDIR}/tora-clipboard.patch
+}
+
+src_compile() {
+ local myconf
+
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use oci8 || myconf="$myconf --without-oracle"
+
+ ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir ${D}/usr/bin
+ einstall ROOT=${D}
+ dodoc LICENSE.txt BUGS INSTALL NEWS README TODO
+}