summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorWill Woods <wwoods@gentoo.org>2003-02-06 23:58:28 +0000
committerWill Woods <wwoods@gentoo.org>2003-02-06 23:58:28 +0000
commit1c7cc86193b3837d7ea2177b93f8833651790d68 (patch)
tree8e5d6da197dcda8035d29cba5fc693f80d5475e5 /dev-db
parentadd ~alpha (diff)
downloadhistorical-1c7cc86193b3837d7ea2177b93f8833651790d68.tar.gz
historical-1c7cc86193b3837d7ea2177b93f8833651790d68.tar.bz2
historical-1c7cc86193b3837d7ea2177b93f8833651790d68.zip
disable berkdb on alpha, since it's unsupported there
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog5
-rw-r--r--dev-db/mysql/mysql-3.23.54a.ebuild6
-rw-r--r--dev-db/mysql/mysql-3.23.55.ebuild6
3 files changed, 12 insertions, 5 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 098a154b0a55..ee06add5e846 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-db/mysql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.32 2003/01/30 00:11:03 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.33 2003/02/06 23:58:28 wwoods Exp $
+
+ 06 Feb 2003; Will Woods <wwoods@gentoo.org>: mysql-3.23.54a.ebuild, mysql-3.23.54a.ebuild
+ Disable berkdb on alpha, since it's not supported there.
*mysql-3.23.55 (29 Jan 2003)
diff --git a/dev-db/mysql/mysql-3.23.54a.ebuild b/dev-db/mysql/mysql-3.23.54a.ebuild
index e6c6faf54011..17450aff2e66 100644
--- a/dev-db/mysql/mysql-3.23.54a.ebuild
+++ b/dev-db/mysql/mysql-3.23.54a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.54a.ebuild,v 1.2 2003/01/20 15:21:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.54a.ebuild,v 1.3 2003/02/06 23:58:28 wwoods Exp $
# bug #11681; get b0rked code when using -march=k6 with this package.
inherit flag-o-matic
@@ -55,7 +55,9 @@ src_compile() {
local myconf
# The following fix is due to a bug with bdb on sparc's. See:
# http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
- if use sparc || use sparc64
+ # same for alpha (see http://www.mysql.com/doc/en/BDB_portability.html)
+ # thanks to peter@icebear.net for noticing this.
+ if use sparc || use sparc64 || use alpha
then
myconf="${myconf} --without-berkeley-db"
else
diff --git a/dev-db/mysql/mysql-3.23.55.ebuild b/dev-db/mysql/mysql-3.23.55.ebuild
index 601757051279..20dcde2e3263 100644
--- a/dev-db/mysql/mysql-3.23.55.ebuild
+++ b/dev-db/mysql/mysql-3.23.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.55.ebuild,v 1.1 2003/01/30 00:11:03 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.55.ebuild,v 1.2 2003/02/06 23:58:28 wwoods Exp $
# bug #11681; get b0rked code when using -march=k6 with this package.
inherit flag-o-matic
@@ -55,7 +55,9 @@ src_compile() {
local myconf
# The following fix is due to a bug with bdb on sparc's. See:
# http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
- if use sparc || use sparc64
+ # same for alpha (see http://www.mysql.com/doc/en/BDB_portability.html)
+ # thanks to peter@icebear.net for noticing this.
+ if use sparc || use sparc64 || use alpha
then
myconf="${myconf} --without-berkeley-db"
else