summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-07-26 03:01:13 +0000
committerJon Nelson <jnelson@gentoo.org>2002-07-26 03:01:13 +0000
commit7b4a98038eedbcdb2ecbcde9705bb5f787155acc (patch)
treeb5bfb599cf7b59eb0312ca07157991d0b04e9ddb /dev-db
parentacroread unmasked (diff)
downloadhistorical-7b4a98038eedbcdb2ecbcde9705bb5f787155acc.tar.gz
historical-7b4a98038eedbcdb2ecbcde9705bb5f787155acc.tar.bz2
historical-7b4a98038eedbcdb2ecbcde9705bb5f787155acc.zip
fix bug 5152 and clean up old versions
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog11
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.49-r21
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.51-r11
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.51-r21
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.51-r3 (renamed from dev-db/mysql/files/digest-mysql-3.23.51)0
-rw-r--r--dev-db/mysql/files/mysql.init (renamed from dev-db/mysql/files/mysql.rc6)10
-rw-r--r--dev-db/mysql/mysql-3.23.49-r2.ebuild218
-rw-r--r--dev-db/mysql/mysql-3.23.51-r1.ebuild195
-rw-r--r--dev-db/mysql/mysql-3.23.51-r3.ebuild (renamed from dev-db/mysql/mysql-3.23.51-r2.ebuild)2
-rw-r--r--dev-db/mysql/mysql-3.23.51.ebuild199
10 files changed, 19 insertions, 619 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 1bbbff6323e7..3ad56d5e33a9 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/mysql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.11 2002/07/25 08:25:55 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.12 2002/07/26 03:01:13 jnelson Exp $
+
+*mysql-3.23.51-r3 (25 Jul 2002)
+
+ 25 Jul 2002; Jon Nelson <jnelson@gentoo.org> mysql-3.23.51-r3.ebuild files/digest-mysql-3.23.51-r3 files/mysql.init:
+
+ Fixed 5152 - used some fancy awk to extract the datadir from
+ /etc/mysql/my.cnf -- new init file is mysql.init
+ Removed mysql-3.23.49.ebuild, mysql-3.23.51-r2.ebuild and assoc. digests
+ Removed files/mysql.rc6
*mysql-3.23.51-r2 (07 Jul 2002)
diff --git a/dev-db/mysql/files/digest-mysql-3.23.49-r2 b/dev-db/mysql/files/digest-mysql-3.23.49-r2
deleted file mode 100644
index 27dede324a6d..000000000000
--- a/dev-db/mysql/files/digest-mysql-3.23.49-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 1eec75578df021ee22bb229268359d8f mysql-3.23.49.tar.gz 11844905
diff --git a/dev-db/mysql/files/digest-mysql-3.23.51-r1 b/dev-db/mysql/files/digest-mysql-3.23.51-r1
deleted file mode 100644
index 6b2531a6f4cf..000000000000
--- a/dev-db/mysql/files/digest-mysql-3.23.51-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 af9f2aaba408898df82cccf462766542 mysql-3.23.51.tar.gz 11203102
diff --git a/dev-db/mysql/files/digest-mysql-3.23.51-r2 b/dev-db/mysql/files/digest-mysql-3.23.51-r2
deleted file mode 100644
index 6b2531a6f4cf..000000000000
--- a/dev-db/mysql/files/digest-mysql-3.23.51-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 af9f2aaba408898df82cccf462766542 mysql-3.23.51.tar.gz 11203102
diff --git a/dev-db/mysql/files/digest-mysql-3.23.51 b/dev-db/mysql/files/digest-mysql-3.23.51-r3
index 6b2531a6f4cf..6b2531a6f4cf 100644
--- a/dev-db/mysql/files/digest-mysql-3.23.51
+++ b/dev-db/mysql/files/digest-mysql-3.23.51-r3
diff --git a/dev-db/mysql/files/mysql.rc6 b/dev-db/mysql/files/mysql.init
index f8911e7b4c82..8d1517022251 100644
--- a/dev-db/mysql/files/mysql.rc6
+++ b/dev-db/mysql/files/mysql.init
@@ -1,14 +1,20 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql.rc6,v 1.1 2002/01/06 00:53:24 woodchip Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/mysql.init,v 1.1 2002/07/26 03:01:13 jnelson Exp $
depend() {
need net
}
checkconfig() {
- if [ ! -d /var/lib/mysql/mysql ] ; then
+ if [ ! -f /etc/mysql/my.cnf ] ; then
+ eerror "No /etc/mysql/my.cnf file exists!"
+ fi
+
+ dir=`awk '{ if ( $0 ~ /^datadir[ \t]+=/ ) { print $3 } }' < /etc/mysql/my.cnf`
+
+ if [ ! -d $dir/mysql ] ; then
eerror "You dont appear to have the mysql database installed yet."
eerror "Please run /usr/bin/mysql_install_db to have this done..."
return 1
diff --git a/dev-db/mysql/mysql-3.23.49-r2.ebuild b/dev-db/mysql/mysql-3.23.49-r2.ebuild
deleted file mode 100644
index d217ecad563f..000000000000
--- a/dev-db/mysql/mysql-3.23.49-r2.ebuild
+++ /dev/null
@@ -1,218 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.49-r2.ebuild,v 1.2 2002/07/23 03:05:05 rphillips Exp $
-
-# NB: Databases are now in /var/lib/mysql vs. the old /var/mysql. If you are
-# upgrading from a recent mysql version, you should be able to simply move your
-# databases into the new directory, but to be absolutely *safe* you should:
-# - dump all of your databases
-# - stop mysql if it is running
-# - delete the old /var/mysql directory
-# - emerge this ebuild
-# - run /usr/bin/mysql_install_db or ebuild this-ebuild.ebuild config
-# - start up mysql
-# - re-create all of your databases
-# - re-load your data
-# If you are *not* upgrading, then you can just emerge this ebuild and
-# either run /usr/bin/mysql_install_db or ebuild this-ebuild.ebuild config :)
-
-DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
-HOMEPAGE="http://www.mysql.com/"
-
-S=${WORKDIR}/${P}
-SRC_URI="http://www.kernelnotes.de/MySQL/Downloads/MySQL-3.23/${P}.tar.gz
- ftp://mysql.valueclick.com/pub/mysql/Downloads/MySQL-3.23/${P}.tar.gz
- http://mysql.he.net/Downloads/MySQL-3.23/${P}.tar.gz
- http://web.tryc.on.ca/mysql/Downloads/MySQL-3.23/${P}.tar.gz
- ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/MySQL-3.23/${P}.tar.gz"
-
-RDEPEND="virtual/glibc readline? ( >=sys-libs/readline-4.1 ) >=sys-libs/ncurses-5.1 >=sys-libs/zlib-1.1.3"
-DEPEND="${RDEPEND} tcpd? ( >=sys-apps/tcp-wrappers-7.6 ) sys-devel/perl sys-apps/procps"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-src_unpack() {
-
- unpack ${A} ; cd ${S}
- # Gentoo 1.3+ uses db 4.0.x by default..
- if [[ "${COMPILER}" != "gcc3" ]]; then
- # for -ldb-3.2 instead of -ldb, because gentoo has -ldb1 instead
- echo "blep"
- patch -p1 < ${FILESDIR}/mysql-3.23-db-3.2.3.diff || die
- fi
- # required for qmail-mysql
- patch -p0 < ${FILESDIR}/mysql-3.23-nisam.h.diff || die
- # zap startup script messages
- patch -p1 < ${FILESDIR}/mysql-3.23-install-db-sh.diff || die
- # zap binary distribution stuff
- patch -p1 < ${FILESDIR}/mysql-3.23-safe-mysqld-sh.diff || die
- # for correct hardcoded sysconf directory
- patch -p1 < ${FILESDIR}/mysql-3.23-my-print-defaults.diff || die
-
- aclocal || die
- automake || die
- autoconf || die
-}
-
-src_compile() {
-
- local myconf
- # means use the system readline
- use readline && myconf="${myconf} --without-readline"
- if [[ "${COMPILER}" != "gcc3" ]]; then
- echo "jsqkdk"
- use berkdb && myconf="${myconf} --with-berkeley-db --with-berkeley-db-includes=/usr/include/db3 --with-berkeley-db-libs=/usr/lib"
- else
- echo "bleh"
- use berkdb && myconf="${myconf} --with-berkeley-db"
- fi
- use berkdb || myconf="${myconf} --without-berkeley-db"
- use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
- use static || myconf="${myconf} --enable-shared --enable-static"
- use tcpd && myconf="${myconf} --with-libwrap"
- use innodb && myconf="${myconf} --with-innodb"
-
- if [ "$DEBUG" == "true" ] ; then
- myconf="${myconf} --with-debug"
- else
- myconf="${myconf} --without-debug"
- fi
-
- # CXX must be g++ because gcc|c++ does not find /usr/lib/gcc-lib/libstc+++.so.
- # the compiler flags are needed to address stability issues.
- CC=gcc \
- CFLAGS="${CFLAGS/-O?/} -O2 -fomit-frame-pointer" \
- CXX=g++ \
- CXXFLAGS="${CXXFLAGS/-O?/} -O2 -fomit-frame-pointer -felide-constructors -fno-exceptions -fno-rtti" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --exec-prefix=/usr \
- --datadir=/usr/share \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/mysql \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --includedir=/usr/include \
- --localstatedir=/var/lib/mysql \
- --with-raid \
- --with-low-memory \
- --enable-assembler \
- --with-charset=latin1 \
- --with-mysqld-user=mysql \
- --with-extra-charsets=all \
- --enable-thread-safe-client \
- --with-client-ldflags=-lstdc++ \
- --with-comment="${PF}.ebuild package" \
- --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
- --host=${CHOST} ${myconf} || die "bad ./configure"
-
- make || die "compile problem"
-}
-
-src_install() {
-
- dodir /var/lib/mysql /var/run/mysqld /var/log/mysql
- make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
-
- # eeek, not sure whats going on here.. are these needed by anything?
- use innodb && ( insinto /usr/lib/mysql ; doins ${WORKDIR}/../libs/* )
-
- # move client libs, install a couple of missing headers
- mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
- dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
- insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
-
- # convenience links
- dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
- dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
- dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
-
- # while my broom gently sweeps...
- rm -f ${D}/usr/share/mysql/binary-configure
- rm -f ${D}/usr/share/mysql/mysql.server
- rm -f ${D}/usr/share/mysql/make_binary_distribution
- rm -f ${D}/usr/share/mysql/mi_test_all*
- rm -f ${D}/usr/share/mysql/mysql-log-rotate
- rm -f ${D}/usr/share/mysql/mysql*.spec
- rm -f ${D}/usr/share/mysql/my-*.cnf
-
- dodoc README COPYING COPYING.LIB MIRRORS Docs/{manual.ps,manual.txt}
- docinto conf-samples ; dodoc support-files/my-*.cnf
- docinto html ; dodoc Docs/*.html
-
- insinto /etc/mysql
- doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
- exeinto /etc/init.d ; newexe ${FILESDIR}/mysql.rc6 mysql
-}
-
-pkg_config() {
-
- if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
- einfo "Press ENTER to create the mysql database and set proper"
- einfo "permissions on it, or Control-C to abort now..."
- read
- ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
- else
- einfo "Hmm, it appears as though you already have the mysql"
- einfo "database in place. If you are having problems trying"
- einfo "to start mysqld, perhaps you need to manually run"
- einfo "/usr/bin/mysql_install_db and/or check your config"
- einfo "file(s) and/or database(s) and/or logfile(s) :>"
- fi
-
- # ensure permissions on these just in case...
- chown -R mysql ${ROOT}/var/lib/mysql ${ROOT}/var/run/mysqld
-}
-
-pkg_prerm() {
-
- if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/mysql ] ; then
- /etc/init.d/mysql stop
- fi
-}
-
-pkg_preinst() {
-
- if [ "$ROOT" = "/" ] && [ -e /dev/shm/.init.d/started/mysql ] ; then
- /etc/init.d/mysql stop
- fi
-}
-
-pkg_postinst() {
-
- # NB: most of this stuff has been integrated into Gentoo's baselayout
- # now, for convenience. So Ill remove it soon. Shouldnt hurt to leave
- # it here for a few more versions though...
-
- # ensure the following arrangement:
- # /etc/passwd: mysql:x:60:60:mysql:/var/lib/mysql:/dev/null
- # /etc/group: mysql::60:
- #
- # creating mysql group if he isn't already there
- if ! grep -q ^mysql: /etc/group ; then
- #echo Adding system group: mysql.
- groupadd -g 60 mysql || die "problem adding group mysql"
- fi
- # creating mysql user if he isn't already there
- if ! grep -q ^mysql: /etc/passwd ; then
- #echo Adding system user: mysql.
- useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
- assert "problem adding user mysql"
- fi
- # modifying him if he was already there
- usermod -c "mysql" mysql || die "usermod problem"
- usermod -d "/var/lib/mysql" mysql || die "usermod problem"
- usermod -g "mysql" mysql || die "usermod problem"
- usermod -s "/dev/null" mysql || die "usermod problem"
-
- # ensure sane permissions on existing databases and /var/run/mysqld
- chown mysql.mysql ${ROOT}/var/lib/mysql ${ROOT}/var/run/mysqld
- find ${ROOT}/var/lib/mysql -not \( -group root -or -group mysql \) -exec chgrp mysql {} \;
-
- # get these proper and ready to go
- touch ${ROOT}/var/log/mysql/mysql.log ${ROOT}/var/log/mysql/mysql.err
- chown mysql.mysql ${ROOT}/var/log/mysql/mysql.log ${ROOT}/var/log/mysql/mysql.err
- chmod 0600 ${ROOT}/var/log/mysql/mysql.log ${ROOT}/var/log/mysql/mysql.err
-}
diff --git a/dev-db/mysql/mysql-3.23.51-r1.ebuild b/dev-db/mysql/mysql-3.23.51-r1.ebuild
deleted file mode 100644
index ede47aed9fb3..000000000000
--- a/dev-db/mysql/mysql-3.23.51-r1.ebuild
+++ /dev/null
@@ -1,195 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51-r1.ebuild,v 1.3 2002/07/23 03:05:06 rphillips Exp $
-
-SVER=${PV%.*}
-# normal releases:
-SDIR=MySQL-${SVER}
-#for a pre-release:
-#SDIR=MySQL-${SVER}-Pre
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
-HOMEPAGE="http://www.mysql.com/"
-SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR}/${P}.tar.gz
- ftp://mysql.valueclick.com/pub/mysql/Downloads/${SDIR}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-DEPEND="virtual/glibc
- readline? ( >=sys-libs/readline-4.1 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- >=sys-libs/zlib-1.1.3
- sys-devel/perl
- sys-apps/procps
- berkdb? ( >sys-libs/db-3* )"
-# on >=gentoo-1.3, USE berkdb will build the bundled 3.2.9a version.
-# on <gentoo-1.3, sys-libs/db-3 is used for the USE berkdb component.
-
-# HEY!
-# the benchmark stuff in /usr/share/mysql/sql-bench and
-# the /usr/bin/mysql_setpermission script need dev-perl/DBD-mysql.
-# Can't add it here: circ depend. Emerge it either before or after
-# mysql; easier before, then it pulls in mysql.
-
-pkg_setup() {
- if ! groupmod mysql; then
- groupadd -g 60 mysql || die "problem adding group mysql"
- fi
-
- if ! id mysql; then
- useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
- assert "problem adding user mysql"
- fi
-}
-
-src_unpack() {
- unpack ${A} ; cd ${S}
- # gentoo 1.3+ uses db 4.0.x by default..
- if [ "${COMPILER}" != "gcc3" ]
- then
- einfo "patching for <gentoo-1.3 system (gcc-2.95.x).."
- # for -ldb-3.2 instead of -ldb, because gentoo has -ldb1 instead
- patch -p1 < ${FILESDIR}/mysql-3.23-db-3.2.3.diff || die
- fi
- # required for qmail-mysql
- patch -p0 < ${FILESDIR}/mysql-3.23-nisam.h.diff || die
- # zap startup script messages
- patch -p1 < ${FILESDIR}/mysql-3.23-install-db-sh.diff || die
- # zap binary distribution stuff
- patch -p1 < ${FILESDIR}/mysql-3.23-safe-mysqld-sh.diff || die
- # for correct hardcoded sysconf directory
- patch -p1 < ${FILESDIR}/mysql-3.23-my-print-defaults.diff || die
- # 3.23.51: hrmph.. not sure whats going on with this..
- patch -p1 < ${FILESDIR}/mysql-3.23.51-tcpd.patch || die
- aclocal || die
- automake || die
- autoconf || die
-}
-
-src_compile() {
- local myconf
- # use the bundled db on gentoo 1.3+
- if use berkdb; then
- myconf="${myconf} --with-berkeley-db=./bdb"
- else
- myconf="${myconf} --without-berkeley-db"
- fi
- # first one means use the system readline
- use readline && myconf="${myconf} --without-readline"
- use readline || myconf="${myconf} --with-readline"
- use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
- use static || myconf="${myconf} --enable-shared --enable-static"
- use tcpd && myconf="${myconf} --with-libwrap"
- use tcpd || myconf="${myconf} --without-libwrap"
- use innodb && myconf="${myconf} --with-innodb"
- use innodb || myconf="${myconf} --without-innodb"
- [ -n "${DEBUGBUILD}" ] && myconf="${myconf} --with-debug"
- [ -n "${DEBUGBUILD}" ] || myconf="${myconf} --without-debug"
-
- # gcc-2.95.x: CXX must be g++ because gcc|c++ does not find /usr/lib/gcc-lib/libstc+++.so.
- # gcc-3.1.x: should be okay yes?
- # the compiler flags are as per their "official" spec ;-)
- einfo "myconf is $myconf"
- CC=gcc \
- CFLAGS="${CFLAGS/-O?/} -O3" \
- CXX=g++ \
- CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --exec-prefix=/usr \
- --datadir=/usr/share \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/mysql \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --includedir=/usr/include \
- --localstatedir=/var/lib/mysql \
- --with-raid \
- --with-low-memory \
- --enable-assembler \
- --with-charset=latin1 \
- --with-mysqld-user=mysql \
- --with-extra-charsets=all \
- --enable-thread-safe-client \
- --with-client-ldflags=-lstdc++ \
- --with-comment="Gentoo ${PF}.ebuild package" \
- --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
- --host=${CHOST} ${myconf} || die "bad ./configure"
-
- make || die "compile problem"
-}
-
-src_install() {
- make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
-
- # eeek, not sure whats going on here.. are these needed by anything?
- use innodb && ( insinto /usr/lib/mysql ; doins ${WORKDIR}/../libs/* )
-
- # move client libs, install a couple of missing headers
- mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
- dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
- dosym ../libmysqlclient_r.so /usr/lib/mysql/libmysqlclient_r.so
- insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
-
- # convenience links
- dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
- dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
- dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
-
- # while my broom gently sweeps...
- rm -f ${D}/usr/share/mysql/binary-configure
- rm -f ${D}/usr/share/mysql/mysql.server
- rm -f ${D}/usr/share/mysql/make_binary_distribution
- rm -f ${D}/usr/share/mysql/mi_test_all*
- rm -f ${D}/usr/share/mysql/mysql-log-rotate
- rm -f ${D}/usr/share/mysql/mysql*.spec
- rm -f ${D}/usr/share/mysql/my-*.cnf
-
- dodoc README COPYING COPYING.LIB MIRRORS \
- Docs/{manual.ps,manual.txt}
- docinto conf-samples
- dodoc support-files/my-*.cnf
- dohtml -r Docs/*
-
- insinto /etc/mysql
- doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
- exeinto /etc/init.d
- newexe ${FILESDIR}/mysql.rc6 mysql
-}
-
-pkg_config() {
- if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
- einfo "Press ENTER to create the mysql database and set proper"
- einfo "permissions on it, or Control-C to abort now..."
- read
- ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
- else
- einfo "Hmm, it appears as though you already have the mysql"
- einfo "database in place. If you are having problems trying"
- einfo "to start mysqld, perhaps you need to manually run"
- einfo "/usr/bin/mysql_install_db and/or check your config"
- einfo "file(s) and/or database(s) and/or logfile(s)."
- fi
-}
-
-pkg_postinst() {
- # empty dirs...
- install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
- install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
- install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- # secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql.mysql ${ROOT}/var/log/mysql/mysql.{log,err}
- chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
-
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
- einfo "if this is a new install."
- einfo
-}
diff --git a/dev-db/mysql/mysql-3.23.51-r2.ebuild b/dev-db/mysql/mysql-3.23.51-r3.ebuild
index 71ea1d46d759..fb5fc4f71b72 100644
--- a/dev-db/mysql/mysql-3.23.51-r2.ebuild
+++ b/dev-db/mysql/mysql-3.23.51-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51-r2.ebuild,v 1.2 2002/07/25 08:25:55 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51-r3.ebuild,v 1.1 2002/07/26 03:01:13 jnelson Exp $
SVER=${PV%.*}
#normal releases:
diff --git a/dev-db/mysql/mysql-3.23.51.ebuild b/dev-db/mysql/mysql-3.23.51.ebuild
deleted file mode 100644
index b8b7ab42a4bd..000000000000
--- a/dev-db/mysql/mysql-3.23.51.ebuild
+++ /dev/null
@@ -1,199 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.51.ebuild,v 1.2 2002/07/23 03:05:06 rphillips Exp $
-
-SVER=${PV%.*}
-#normal releases:
-SDIR=MySQL-${SVER}
-#for a pre-release:
-#SDIR=MySQL-${SVER}-Pre
-
-S=${WORKDIR}/${P}
-DESCRIPTION="A fast, multi-threaded, multi-user SQL database server."
-HOMEPAGE="http://www.mysql.com/"
-SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR}/${P}.tar.gz
- ftp://mysql.valueclick.com/pub/mysql/Downloads/${SDIR}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-DEPEND="virtual/glibc
- readline? ( >=sys-libs/readline-4.1 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- >=sys-libs/zlib-1.1.3
- sys-devel/perl
- sys-apps/procps
- berkdb? ( >sys-libs/db-3* )"
-# on >=gentoo-1.3, USE berkdb will build the bundled 3.2.9a version.
-# on <gentoo-1.3, sys-libs/db-3 is used for the USE berkdb component.
-
-# HEY!
-# the benchmark stuff in /usr/share/mysql/sql-bench and
-# the /usr/bin/mysql_setpermission script need dev-perl/DBD-mysql.
-# Can't add it here: circ depend. Emerge it either before or after
-# mysql; easier before, then it pulls in mysql.
-
-pkg_setup() {
- if ! groupmod mysql; then
- groupadd -g 60 mysql || die "problem adding group mysql"
- fi
-
- if ! id mysql; then
- useradd -g mysql -s /dev/null -d /var/lib/mysql -c "mysql" mysql
- assert "problem adding user mysql"
- fi
-}
-
-src_unpack() {
- unpack ${A} ; cd ${S}
- # gentoo 1.3+ uses db 4.0.x by default..
- if [ "${COMPILER}" != "gcc3" ]
- then
- einfo "patching for <gentoo-1.3 system (gcc-2.95.x).."
- # for -ldb-3.2 instead of -ldb, because gentoo has -ldb1 instead
- patch -p1 < ${FILESDIR}/mysql-3.23-db-3.2.3.diff || die
- fi
- # required for qmail-mysql
- patch -p0 < ${FILESDIR}/mysql-3.23-nisam.h.diff || die
- # zap startup script messages
- patch -p1 < ${FILESDIR}/mysql-3.23-install-db-sh.diff || die
- # zap binary distribution stuff
- patch -p1 < ${FILESDIR}/mysql-3.23-safe-mysqld-sh.diff || die
- # for correct hardcoded sysconf directory
- patch -p1 < ${FILESDIR}/mysql-3.23-my-print-defaults.diff || die
- # 3.23.51: hrmph.. not sure whats going on with this..
- patch -p1 < ${FILESDIR}/mysql-3.23.51-tcpd.patch || die
- aclocal || die
- automake || die
- autoconf || die
-}
-
-src_compile() {
- local myconf
- # use the bundled db on gentoo 1.3+
- if [ "${COMPILER}" != "gcc3" ]
- then
- use berkdb && myconf="${myconf} \
- --with-berkeley-db \
- --with-berkeley-db-includes=/usr/include/db3 \
- --with-berkeley-db-libs=/usr/lib"
- else
- use berkdb && myconf="${myconf} --with-berkeley-db"
- fi
- use berkdb || myconf="${myconf} --without-berkeley-db"
- # first one means use the system readline
- use readline && myconf="${myconf} --without-readline"
- use readline || myconf="${myconf} --with-readline"
- use static && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared"
- use static || myconf="${myconf} --enable-shared --enable-static"
- use tcpd && myconf="${myconf} --with-libwrap"
- use tcpd || myconf="${myconf} --without-libwrap"
- use innodb && myconf="${myconf} --with-innodb"
- use innodb || myconf="${myconf} --without-innodb"
- [ -n "${DEBUGBUILD}" ] && myconf="${myconf} --with-debug"
- [ -n "${DEBUGBUILD}" ] || myconf="${myconf} --without-debug"
-
- # gcc-2.95.x: CXX must be g++ because gcc|c++ does not find /usr/lib/gcc-lib/libstc+++.so.
- # gcc-3.1.x: should be okay yes?
- # the compiler flags are as per their "official" spec ;-)
- einfo "myconf is $myconf"
- CC=gcc \
- CFLAGS="${CFLAGS/-O?/} -O3" \
- CXX=g++ \
- CXXFLAGS="${CXXFLAGS/-O?/} -O3 -felide-constructors -fno-exceptions -fno-rtti" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib \
- --exec-prefix=/usr \
- --datadir=/usr/share \
- --libexecdir=/usr/sbin \
- --sysconfdir=/etc/mysql \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --includedir=/usr/include \
- --localstatedir=/var/lib/mysql \
- --with-raid \
- --with-low-memory \
- --enable-assembler \
- --with-charset=latin1 \
- --with-mysqld-user=mysql \
- --with-extra-charsets=all \
- --enable-thread-safe-client \
- --with-client-ldflags=-lstdc++ \
- --with-comment="Gentoo ${PF}.ebuild package" \
- --with-unix-socket-path=/var/run/mysqld/mysqld.sock \
- --host=${CHOST} ${myconf} || die "bad ./configure"
-
- make || die "compile problem"
-}
-
-src_install() {
- make install DESTDIR=${D} benchdir_root=/usr/share/mysql || die
-
- # eeek, not sure whats going on here.. are these needed by anything?
- use innodb && ( insinto /usr/lib/mysql ; doins ${WORKDIR}/../libs/* )
-
- # move client libs, install a couple of missing headers
- mv ${D}/usr/lib/mysql/libmysqlclient*.so* ${D}/usr/lib
- dosym ../libmysqlclient.so /usr/lib/mysql/libmysqlclient.so
- insinto /usr/include/mysql ; doins include/{my_config.h,my_dir.h}
-
- # convenience links
- dosym /usr/bin/mysqlcheck /usr/bin/mysqlanalyze
- dosym /usr/bin/mysqlcheck /usr/bin/mysqlrepair
- dosym /usr/bin/mysqlcheck /usr/bin/mysqloptimize
-
- # while my broom gently sweeps...
- rm -f ${D}/usr/share/mysql/binary-configure
- rm -f ${D}/usr/share/mysql/mysql.server
- rm -f ${D}/usr/share/mysql/make_binary_distribution
- rm -f ${D}/usr/share/mysql/mi_test_all*
- rm -f ${D}/usr/share/mysql/mysql-log-rotate
- rm -f ${D}/usr/share/mysql/mysql*.spec
- rm -f ${D}/usr/share/mysql/my-*.cnf
-
- dodoc README COPYING COPYING.LIB MIRRORS \
- Docs/{manual.ps,manual.txt}
- docinto conf-samples
- dodoc support-files/my-*.cnf
- dohtml -r Docs/*
-
- insinto /etc/mysql
- doins ${FILESDIR}/my.cnf scripts/mysqlaccess.conf
- exeinto /etc/init.d
- newexe ${FILESDIR}/mysql.rc6 mysql
-}
-
-pkg_config() {
- if [ ! -d ${ROOT}/var/lib/mysql/mysql ] ; then
- einfo "Press ENTER to create the mysql database and set proper"
- einfo "permissions on it, or Control-C to abort now..."
- read
- ${ROOT}/usr/bin/mysql_install_db #>>/var/log/mysql/mysql.err 2>&1
- else
- einfo "Hmm, it appears as though you already have the mysql"
- einfo "database in place. If you are having problems trying"
- einfo "to start mysqld, perhaps you need to manually run"
- einfo "/usr/bin/mysql_install_db and/or check your config"
- einfo "file(s) and/or database(s) and/or logfile(s)."
- fi
-}
-
-pkg_postinst() {
- # empty dirs...
- install -d -m0755 -o mysql -g mysql ${ROOT}/var/lib/mysql
- install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
- install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- # secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql.mysql ${ROOT}/var/log/mysql/mysql.{log,err}
- chmod 0660 ${ROOT}/var/log/mysql/mysql.{log,err}
-
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
- einfo "if this is a new install."
- einfo
-}