summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-04-02 01:22:12 +0000
committerPeter Johanson <latexer@gentoo.org>2005-04-02 01:22:12 +0000
commit6d844eadbcde5f5d5469af85e8d08a02bd7611f4 (patch)
tree9366f9808e367869cebd2a6ec9744e54a94441dd /dev-dotnet/gconf-sharp
parentMarked stable on SPARC because our latest stable version was removed. (diff)
downloadhistorical-6d844eadbcde5f5d5469af85e8d08a02bd7611f4.tar.gz
historical-6d844eadbcde5f5d5469af85e8d08a02bd7611f4.tar.bz2
historical-6d844eadbcde5f5d5469af85e8d08a02bd7611f4.zip
Add the preview release of the gtk-sharp-2.0 stuff.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-dotnet/gconf-sharp')
-rw-r--r--dev-dotnet/gconf-sharp/ChangeLog8
-rw-r--r--dev-dotnet/gconf-sharp/Manifest2
-rw-r--r--dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.22
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-1.9.2.ebuild29
4 files changed, 40 insertions, 1 deletions
diff --git a/dev-dotnet/gconf-sharp/ChangeLog b/dev-dotnet/gconf-sharp/ChangeLog
index dc9a7bad1c82..13f30f316bca 100644
--- a/dev-dotnet/gconf-sharp/ChangeLog
+++ b/dev-dotnet/gconf-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gconf-sharp
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.13 2005/03/23 01:28:44 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/ChangeLog,v 1.14 2005/04/02 01:18:03 latexer Exp $
+
+*gconf-sharp-1.9.2 (02 Apr 2005)
+
+ 02 Apr 2005; Peter Johanson <latexer@gentoo.org>
+ +gconf-sharp-1.9.2.ebuild:
+ Add the preview release of the gtk-sharp-2.0 stuff.
22 Mar 2005; Peter Johanson <latexer@gentoo.org> gconf-sharp-1.0.4.ebuild,
gconf-sharp-1.0.6.ebuild, gconf-sharp-1.0.8.ebuild:
diff --git a/dev-dotnet/gconf-sharp/Manifest b/dev-dotnet/gconf-sharp/Manifest
index 4b40194d2600..90e07ead845b 100644
--- a/dev-dotnet/gconf-sharp/Manifest
+++ b/dev-dotnet/gconf-sharp/Manifest
@@ -1,4 +1,5 @@
MD5 c33a9235c7e60e6d4cb11f3fb478005d gconf-sharp-1.0.4.ebuild 826
+MD5 fff8cb5a16f33cdc5f68268bc95ef68c gconf-sharp-1.9.2.ebuild 713
MD5 c79a338b20f93bfb8dc4fac66c859383 gconf-sharp-1.0.6.ebuild 791
MD5 0c9f477dafa8647e11d2fe95d37b120f gconf-sharp-1.0.8.ebuild 793
MD5 aaeacf3c399f8f3ced0e70f63c5848c4 ChangeLog 1088
@@ -6,3 +7,4 @@ MD5 a60fdfbce7c7cfc52187ff86a7f8bbf8 metadata.xml 222
MD5 b63c29f6761c048a9d7943713c15c78c files/digest-gconf-sharp-1.0.4 147
MD5 ff5a2a47c3e1d785fc179c922857e409 files/digest-gconf-sharp-1.0.6 147
MD5 3af46f2e9fbd6a7f642bc1ef502d50ca files/digest-gconf-sharp-1.0.8 147
+MD5 d1dddb54802e684259aedfd27a11af15 files/digest-gconf-sharp-1.9.2 147
diff --git a/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.2 b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.2
new file mode 100644
index 000000000000..d260f726c7b7
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/files/digest-gconf-sharp-1.9.2
@@ -0,0 +1,2 @@
+MD5 b7c5afab5f736ffa4011974302831363 gtk-sharp-1.9.2.tar.gz 2159808
+MD5 e66fae7398bdbd4c5840d572d918fb93 gtk-sharp-1.9.2-configurable.diff.gz 1391
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-1.9.2.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-1.9.2.ebuild
new file mode 100644
index 000000000000..b94e794ca2c3
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-1.9.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-1.9.2.ebuild,v 1.1 2005/04/02 01:18:03 latexer Exp $
+
+inherit gtk-sharp-component
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.0
+ =dev-dotnet/glade-sharp-${PV}*
+ =dev-dotnet/gnome-sharp-${PV}*
+ =dev-dotnet/art-sharp-${PV}*"
+
+GTK_SHARP_COMPONENT_BUILD="gnome"
+GTK_SHARP_COMPONENT_BUILD_DEPS="art"
+GTK_SHARP_COMPONENT_SLOT="2"
+GTK_SHARP_COMPONENT_SLOT_DEC="-2.0"
+
+
+src_unpack() {
+ gtk-sharp-component_src_unpack
+
+ # Fix need as GConf.PropertyEditors references a locally built dll
+ sed -i "s:${GTK_SHARP_LIB_DIR}/gconf-sharp.dll:../GConf/gconf-sharp.dll:" \
+ ${S}/gconf/GConf.PropertyEditors/Makefile.in
+}