summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2005-01-16 09:51:14 +0000
committerRainer Groesslinger <scandium@gentoo.org>2005-01-16 09:51:14 +0000
commit196e8db973169c7637c4004d1fb5aec788b9c94d (patch)
tree796111113886661ef29b851a9042a28ff827c020 /dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
parentFixed bad ninja. (diff)
downloadhistorical-196e8db973169c7637c4004d1fb5aec788b9c94d.tar.gz
historical-196e8db973169c7637c4004d1fb5aec788b9c94d.tar.bz2
historical-196e8db973169c7637c4004d1fb5aec788b9c94d.zip
new version; can now be installed in parallel with mono
Package-Manager: portage-2.0.51-r12
Diffstat (limited to 'dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild')
-rw-r--r--dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild b/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
new file mode 100644
index 000000000000..f3223e8d145a
--- /dev/null
+++ b/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/ml-pnet/ml-pnet-0.6.12.ebuild,v 1.1 2005/01/16 09:51:14 scandium Exp $
+
+DESCRIPTION="Mono C# libraries for Portable.NET"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="mirror://gnu/dotgnu/pnet/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+IUSE=""
+
+DEPEND="=dev-dotnet/pnetlib-${PV}*"
+
+src_compile() {
+ local lib_profile="framework1.1"
+ einfo "Using profile: ${lib_profile}"
+
+ econf --with-profile=${lib_profile} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}