summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-07-20 21:48:43 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-07-20 21:48:43 +0000
commit4b40648ffb1b6e9ca04cbc3e0cc1c5aaeb8eff5a (patch)
treed46280f0aaa28f946f7cc7307f223d0fa1228582 /dev-dotnet/mono-addins/mono-addins-0.2.ebuild
parentnet-libs/gnet: dropping version 2.0.5 (diff)
downloadhistorical-4b40648ffb1b6e9ca04cbc3e0cc1c5aaeb8eff5a.tar.gz
historical-4b40648ffb1b6e9ca04cbc3e0cc1c5aaeb8eff5a.tar.bz2
historical-4b40648ffb1b6e9ca04cbc3e0cc1c5aaeb8eff5a.zip
dev-dotnet/mono-addins: initial version
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-dotnet/mono-addins/mono-addins-0.2.ebuild')
-rw-r--r--dev-dotnet/mono-addins/mono-addins-0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-dotnet/mono-addins/mono-addins-0.2.ebuild b/dev-dotnet/mono-addins/mono-addins-0.2.ebuild
new file mode 100644
index 000000000000..7c01410d01b6
--- /dev/null
+++ b/dev-dotnet/mono-addins/mono-addins-0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-addins/mono-addins-0.2.ebuild,v 1.1 2007/07/20 21:48:43 jurek Exp $
+
+inherit eutils mono
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+HOMEPAGE="http://www.mono-project.com/Mono.Addins"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="X"
+
+DEPEND=">=dev-lang/mono-1.2
+ X? ( >=dev-dotnet/gtk-sharp-2.0
+ >=dev-dotnet/gnome-sharp-2.0
+ >=dev-dotnet/glade-sharp-2.0 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-disable-gui.patch
+}
+
+src_compile() {
+ econf \
+ --disable-tests \
+ $(use_enable X gui) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}