summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2005-01-16 09:51:14 +0000
committerRainer Groesslinger <scandium@gentoo.org>2005-01-16 09:51:14 +0000
commit196e8db973169c7637c4004d1fb5aec788b9c94d (patch)
tree796111113886661ef29b851a9042a28ff827c020 /dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild
parentFixed bad ninja. (diff)
downloadhistorical-196e8db973169c7637c4004d1fb5aec788b9c94d.tar.gz
historical-196e8db973169c7637c4004d1fb5aec788b9c94d.tar.bz2
historical-196e8db973169c7637c4004d1fb5aec788b9c94d.zip
new version; can now be installed in parallel with mono
Package-Manager: portage-2.0.51-r12
Diffstat (limited to 'dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild')
-rw-r--r--dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild b/dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild
new file mode 100644
index 000000000000..f6c05e5d71b7
--- /dev/null
+++ b/dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnetlib/pnetlib-0.6.12.ebuild,v 1.1 2005/01/16 09:49:25 scandium Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="Portable.NET C# library"
+HOMEPAGE="http://www.dotgnu.org/"
+SRC_URI="mirror://gnu/dotgnu/pnet/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64"
+IUSE="truetype X"
+
+DEPEND="=dev-dotnet/pnet-${PV}*
+ X? ( virtual/x11 )
+ truetype? ( virtual/xft )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # patch configure.in to detect renamed resgen.pnet
+ # bug 39369
+ epatch ${FILESDIR}/${PV}-resgen.patch
+
+ # syntax error; patch not needed anymore for the next release
+ epatch ${FILESDIR}/configure-freetype.patch
+}
+
+src_compile() {
+ local lib_profile="default1.1"
+ einfo "Using profile: ${lib_profile}"
+
+ WANT_AUTOCONF=2.5 ./auto_gen.sh
+ elibtoolize
+ econf --with-profile=${lib_profile} \
+ `use_enable truetype xft` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS ChangeLog HACKING INSTALL NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*.html
+}