summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-05 11:59:06 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-05 11:59:06 +0000
commit05bd527e2b3e78d07b506a79d1c19c44af774426 (patch)
treefcf6e22a3116d613ea75d440fe3fd4cab9f59cda /dev-dotnet/xsp/xsp-2.0.9999.ebuild
parentAdd live ebuilds for trunk and >=2.0 branches (diff)
downloadhistorical-05bd527e2b3e78d07b506a79d1c19c44af774426.tar.gz
historical-05bd527e2b3e78d07b506a79d1c19c44af774426.tar.bz2
historical-05bd527e2b3e78d07b506a79d1c19c44af774426.zip
Add live ebuilds for trunk and >=2.0 branches
Package-Manager: portage-2.2_rc28/cvs/Linux x86_64
Diffstat (limited to 'dev-dotnet/xsp/xsp-2.0.9999.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-2.0.9999.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-2.0.9999.ebuild b/dev-dotnet/xsp/xsp-2.0.9999.ebuild
new file mode 100644
index 000000000000..75112efcebf9
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-2.0.9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.0.9999.ebuild,v 1.1 2009/05/05 11:59:06 loki_val Exp $
+
+EAPI=2
+
+inherit go-mono mono autotools
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.go-mono.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_preinst() {
+ enewgroup aspnet
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+ mv_command="cp -ar" go-mono_src_install
+ newinitd "${PATCHDIR}"/xsp.initd xsp || die
+ newinitd "${PATCHDIR}"/mod-mono-server.initd mod-mono-server || die
+ newconfd "${PATCHDIR}"/xsp.confd xsp || die
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server || die
+
+ keepdir /var/run/aspnet
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}