summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-17 03:09:28 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-17 03:09:28 +0000
commitfa5c41ab0a74bf80e5a492f6d69563505e345b8a (patch)
tree799782d3d9174d3eae848b900886d59c56a5ae01 /dev-embedded
parentVersion bump. (diff)
downloadhistorical-fa5c41ab0a74bf80e5a492f6d69563505e345b8a.tar.gz
historical-fa5c41ab0a74bf80e5a492f6d69563505e345b8a.tar.bz2
historical-fa5c41ab0a74bf80e5a492f6d69563505e345b8a.zip
Version bump.
Package-Manager: portage-2.2.0_alpha105/cvs/Linux x86_64
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/msp430-binutils/ChangeLog8
-rw-r--r--dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120406.ebuild25
-rw-r--r--dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120514.ebuild25
-rw-r--r--dev-embedded/msp430-libc/ChangeLog7
-rw-r--r--dev-embedded/msp430-libc/msp430-libc-20120514.ebuild43
-rw-r--r--dev-embedded/msp430mcu/ChangeLog7
-rw-r--r--dev-embedded/msp430mcu/msp430mcu-20120514.ebuild24
7 files changed, 136 insertions, 3 deletions
diff --git a/dev-embedded/msp430-binutils/ChangeLog b/dev-embedded/msp430-binutils/ChangeLog
index dbd843eca087..6240a3946949 100644
--- a/dev-embedded/msp430-binutils/ChangeLog
+++ b/dev-embedded/msp430-binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/msp430-binutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/ChangeLog,v 1.9 2012/05/17 03:00:45 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/ChangeLog,v 1.10 2012/05/17 03:03:30 radhermit Exp $
+
+*msp430-binutils-2.22_p20120514 (17 May 2012)
+
+ 17 May 2012; Tim Harder <radhermit@gentoo.org>
+ +msp430-binutils-2.22_p20120514.ebuild:
+ Version bump.
*msp430-binutils-2.21.1_p20120406 (17 May 2012)
diff --git a/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120406.ebuild b/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120406.ebuild
new file mode 100644
index 000000000000..020ecc176b3a
--- /dev/null
+++ b/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120406.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/msp430-binutils-2.21.1_p20120406.ebuild,v 1.1 2012/05/17 03:00:45 radhermit Exp $
+
+PATCHVER="1.4"
+
+BINUTILS_VER=${PV%_p*}
+
+inherit toolchain-binutils
+
+DESCRIPTION="Tools necessary to build programs for MSP430 microcontrollers"
+SRC_URI+=" http://dev.gentoo.org/~radhermit/distfiles/${P}.patch.bz2"
+
+KEYWORDS="~amd64 ~x86"
+
+# needed to fix bug #381633
+RDEPEND=">=sys-devel/binutils-config-3-r2"
+
+pkg_setup() {
+ is_cross || die "Only cross-compile builds are supported"
+}
+
+PATCHES=(
+ "${WORKDIR}"/${P}.patch
+)
diff --git a/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120514.ebuild b/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120514.ebuild
new file mode 100644
index 000000000000..d48b5ab39e18
--- /dev/null
+++ b/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120514.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-binutils/msp430-binutils-2.22_p20120514.ebuild,v 1.1 2012/05/17 03:03:30 radhermit Exp $
+
+PATCHVER="1.2"
+
+BINUTILS_VER=${PV%_p*}
+
+inherit toolchain-binutils
+
+DESCRIPTION="Tools necessary to build programs for MSP430 microcontrollers"
+SRC_URI+=" http://dev.gentoo.org/~radhermit/distfiles/${P}.patch.bz2"
+
+KEYWORDS="~amd64 ~x86"
+
+# needed to fix bug #381633
+RDEPEND=">=sys-devel/binutils-config-3-r2"
+
+pkg_setup() {
+ is_cross || die "Only cross-compile builds are supported"
+}
+
+PATCHES=(
+ "${WORKDIR}"/${P}.patch
+)
diff --git a/dev-embedded/msp430-libc/ChangeLog b/dev-embedded/msp430-libc/ChangeLog
index f2ba5e7cc0c2..f42933f4baa7 100644
--- a/dev-embedded/msp430-libc/ChangeLog
+++ b/dev-embedded/msp430-libc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/msp430-libc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-libc/ChangeLog,v 1.8 2012/04/28 10:01:08 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-libc/ChangeLog,v 1.9 2012/05/17 03:07:36 radhermit Exp $
+
+*msp430-libc-20120514 (17 May 2012)
+
+ 17 May 2012; Tim Harder <radhermit@gentoo.org> +msp430-libc-20120514.ebuild:
+ Version bump.
*msp430-libc-20120425 (28 Apr 2012)
diff --git a/dev-embedded/msp430-libc/msp430-libc-20120514.ebuild b/dev-embedded/msp430-libc/msp430-libc-20120514.ebuild
new file mode 100644
index 000000000000..996d29ca017f
--- /dev/null
+++ b/dev-embedded/msp430-libc/msp430-libc-20120514.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430-libc/msp430-libc-20120514.ebuild,v 1.1 2012/05/17 03:07:36 radhermit Exp $
+
+EAPI="4"
+
+CHOST="msp430"
+CTARGET="msp430"
+
+DESCRIPTION="C library for MSP430 microcontrollers"
+HOMEPAGE="http://mspgcc.sourceforge.net"
+SRC_URI="mirror://sourceforge/mspgcc/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crosscompile_opts_headers-only"
+
+DEPEND="sys-devel/crossdev"
+[[ ${CATEGORY/cross-} != ${CATEGORY} ]] \
+ && RDEPEND="!dev-embedded/msp430-libc" \
+ || RDEPEND=""
+
+S="${WORKDIR}/${P}/src"
+
+pkg_setup() {
+ ebegin "Checking for msp430-gcc"
+ if type -p msp430-gcc > /dev/null ; then
+ eend 0
+ else
+ eend 1
+
+ eerror
+ eerror "Failed to locate 'msp430-gcc' in \$PATH. You can install a MSP430 toolchain using:"
+ eerror " $ crossdev -t msp430"
+ eerror
+ die "MSP430 toolchain not found"
+ fi
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install
+}
diff --git a/dev-embedded/msp430mcu/ChangeLog b/dev-embedded/msp430mcu/ChangeLog
index 31e7bcda9e81..6f47faf31a41 100644
--- a/dev-embedded/msp430mcu/ChangeLog
+++ b/dev-embedded/msp430mcu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-embedded/msp430mcu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/ChangeLog,v 1.10 2012/04/28 10:02:43 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/ChangeLog,v 1.11 2012/05/17 03:09:28 radhermit Exp $
+
+*msp430mcu-20120514 (17 May 2012)
+
+ 17 May 2012; Tim Harder <radhermit@gentoo.org> +msp430mcu-20120514.ebuild:
+ Version bump.
*msp430mcu-20120425 (28 Apr 2012)
diff --git a/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild b/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild
new file mode 100644
index 000000000000..ec898c7b8713
--- /dev/null
+++ b/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/msp430mcu/msp430mcu-20120514.ebuild,v 1.1 2012/05/17 03:09:28 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="MCU-specific data for MSP430 microcontrollers"
+HOMEPAGE="http://mspgcc.sourceforge.net"
+SRC_URI="mirror://sourceforge/mspgcc/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20111205-install.patch
+}
+
+src_install() {
+ MSP430MCU_ROOT="${S}" ./scripts/install.sh "${D}/usr"
+}