summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-23 12:19:54 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-23 12:19:54 +0000
commite887bac507e4d50682f4ad2a2a0845d2175fd7b8 (patch)
tree25348bd24bf03f56421c6d0dfb64651649f5066d /dev-games/clanlib/clanlib-0.8.0.ebuild
parentMigrated to new Java build system. (diff)
downloadhistorical-e887bac507e4d50682f4ad2a2a0845d2175fd7b8.tar.gz
historical-e887bac507e4d50682f4ad2a2a0845d2175fd7b8.tar.bz2
historical-e887bac507e4d50682f4ad2a2a0845d2175fd7b8.zip
Version bump #130963 by Andrija Prcic / #146376 by Pacho Ramos.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'dev-games/clanlib/clanlib-0.8.0.ebuild')
-rw-r--r--dev-games/clanlib/clanlib-0.8.0.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-games/clanlib/clanlib-0.8.0.ebuild b/dev-games/clanlib/clanlib-0.8.0.ebuild
new file mode 100644
index 000000000000..9c2ffdca4171
--- /dev/null
+++ b/dev-games/clanlib/clanlib-0.8.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.0.ebuild,v 1.1 2006/09/23 12:19:54 vapier Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="multi-platform game development library"
+HOMEPAGE="http://www.clanlib.org/"
+SRC_URI="http://clanlib.org/download/releases-${PV:0:3}/ClanLib-${PV}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0.8"
+KEYWORDS="~amd64 ~x86" #not big endian safe #82779
+IUSE="opengl sdl vorbis doc mikmod ipv6"
+
+# opengl keyword does not drop the GL/GLU requirement.
+# Autoconf files need to be fixed
+RDEPEND="media-libs/libpng
+ media-libs/jpeg
+ virtual/opengl
+ virtual/glu
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-gfx
+ )
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ mikmod? ( >=media-libs/libmikmod-3.1.9 )
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/ClanLib-${PV}
+
+src_compile() {
+ #clanSound only controls mikmod/vorbis so there's
+ # no need to pass --{en,dis}able-clanSound ...
+ #clanDisplay only controls X, SDL, OpenGL plugins
+ # so no need to pass --{en,dis}able-clanDisplay
+ # also same reason why we don't have to use clanGUI
+ econf \
+ --enable-dyn \
+ --enable-clanNetwork \
+ --disable-dependency-tracking \
+ $(use_enable x86 asm386) \
+ $(use_enable doc docs) \
+ $(use_enable opengl clanGL) \
+ $(use_enable sdl clanSDL) \
+ $(use_enable vorbis clanVorbis) \
+ $(use_enable mikmod clanMikMod) \
+ $(use_enable ipv6 getaddr) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/clanlib/* "${D}"/usr/share/doc/${PF}/html/ || die
+ rm -rf "${D}"/usr/share/doc/clanlib
+ cp -r Examples "${D}"/usr/share/doc/${PF}/ || die
+ fi
+ dodoc CODING_STYLE CREDITS NEWS PATCHES README* INSTALL.linux
+}