summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-06-12 00:09:31 +0000
committerTristan Heaven <tristan@gentoo.org>2007-06-12 00:09:31 +0000
commitd308d044d4cbe1322ec3a721bef8967a76e222e9 (patch)
treeb470c8b3de3c29f290f535af3097e0cc84cc36be /dev-games/ogre/ogre-1.4.1.ebuild
parentStable on amd64 wrt bug 174939 (diff)
downloadhistorical-d308d044d4cbe1322ec3a721bef8967a76e222e9.tar.gz
historical-d308d044d4cbe1322ec3a721bef8967a76e222e9.tar.bz2
historical-d308d044d4cbe1322ec3a721bef8967a76e222e9.zip
Fix dev-libs/boost built_with_use test, bug #181226
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-games/ogre/ogre-1.4.1.ebuild')
-rw-r--r--dev-games/ogre/ogre-1.4.1.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-games/ogre/ogre-1.4.1.ebuild b/dev-games/ogre/ogre-1.4.1.ebuild
index 18f1e6f5d293..896397e306eb 100644
--- a/dev-games/ogre/ogre-1.4.1.ebuild
+++ b/dev-games/ogre/ogre-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.4.1.ebuild,v 1.1 2007/05/29 19:38:19 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.4.1.ebuild,v 1.2 2007/06/12 00:09:31 nyhm Exp $
inherit eutils autotools
@@ -39,17 +39,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/ogrenew
pkg_setup() {
- if use threads ; then
- if ! built_with_use dev-libs/boost threads ; then
- die "Please emerge dev-libs/boost with USE=threads"
- fi
- ewarn "Threads support is experimental in ${PN} and is not recommended."
- ewarn "See http://bugs.gentoo.org/show_bug.cgi?id=144819"
- ewarn "Read the man page for portage by typing \"man portage\""
- ewarn "and read about /etc/portage/package.use for disabling"
- ewarn "the threads use flag for ${PN} without affecting other packages."
- ebeep
- epause 10
+ if use threads && has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use dev-libs/boost threads
+ then
+ die "Please emerge dev-libs/boost with USE=threads"
fi
}