summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-11 18:18:00 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-11 18:18:00 +0000
commit2133eea48dccc38454892b28e0a1b2cff88f5f78 (patch)
tree7d69362b836af39854da31c3a85dee1b8bcef6ab /dev-haskell/c2hs/c2hs-0.14.5.ebuild
parentStable on sparc wrt security #144869 (diff)
downloadhistorical-2133eea48dccc38454892b28e0a1b2cff88f5f78.tar.gz
historical-2133eea48dccc38454892b28e0a1b2cff88f5f78.tar.bz2
historical-2133eea48dccc38454892b28e0a1b2cff88f5f78.zip
Added patch to fix building with ghc-6.6
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'dev-haskell/c2hs/c2hs-0.14.5.ebuild')
-rw-r--r--dev-haskell/c2hs/c2hs-0.14.5.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-haskell/c2hs/c2hs-0.14.5.ebuild b/dev-haskell/c2hs/c2hs-0.14.5.ebuild
index a3695bd9e80d..a1342c82b6b8 100644
--- a/dev-haskell/c2hs/c2hs-0.14.5.ebuild
+++ b/dev-haskell/c2hs/c2hs-0.14.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.14.5.ebuild,v 1.10 2006/10/05 03:09:33 cparrott Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/c2hs/c2hs-0.14.5.ebuild,v 1.11 2006/10/11 18:14:38 dcoutts Exp $
CABAL_FEATURES="bin"
inherit base eutils haskell-cabal
@@ -14,13 +14,14 @@ SLOT="0"
KEYWORDS="amd64 ~ia64 ~ppc ppc64 sparc x86"
IUSE=""
-DEPEND=">=virtual/ghc-6.0"
+DEPEND=">=virtual/ghc-6.4"
src_unpack() {
base_src_unpack
cd "${S}"
epatch "${FILESDIR}/setupfix.patch"
epatch "${FILESDIR}/ghc622inc.patch"
+ epatch "${FILESDIR}/${P}-ghc66.patch"
}
src_install() {
cabal_src_install