summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-20 02:40:43 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-20 02:40:43 +0000
commit7c34f4372f656e990b1835ac0c29b20cd96b1561 (patch)
tree350ec09e1325b4b3179ba5656f962fc5f282c84d /dev-haskell/glut/glut-2.1.1.1.ebuild
parentMarking clamav-0.91.2-r1 ppc and ppc64 for 202762 (diff)
downloadhistorical-7c34f4372f656e990b1835ac0c29b20cd96b1561.tar.gz
historical-7c34f4372f656e990b1835ac0c29b20cd96b1561.tar.bz2
historical-7c34f4372f656e990b1835ac0c29b20cd96b1561.zip
New version. Released with ghc-6.8 but works with ghc-6.6.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/glut/glut-2.1.1.1.ebuild')
-rw-r--r--dev-haskell/glut/glut-2.1.1.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-haskell/glut/glut-2.1.1.1.ebuild b/dev-haskell/glut/glut-2.1.1.1.ebuild
new file mode 100644
index 000000000000..f3f7dcd208ad
--- /dev/null
+++ b/dev-haskell/glut/glut-2.1.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/glut/glut-2.1.1.1.ebuild,v 1.1 2007/12/20 02:36:07 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+CABAL_MIN_VERSION=1.2
+inherit haskell-cabal
+
+MY_PN="GLUT"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="GLUT bindings for haskell"
+HOMEPAGE="http://www.haskell.org/HOpenGL/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.4
+ >=dev-haskell/opengl-2.2.1
+ virtual/glu
+ virtual/glut"
+
+S="${WORKDIR}/${MY_P}"
+
+# TODO: Install examples when the "examples" USE flag is set