summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-02-14 12:34:00 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-02-14 12:34:00 +0000
commitab27129d48023f4e94251f512ef224d1ada8a9fc (patch)
tree5d2f9052f4985f1f25ba92ad1829a89708e9d533 /dev-haskell/gtk2hs/files
parentNew pre-release. (diff)
downloadhistorical-ab27129d48023f4e94251f512ef224d1ada8a9fc.tar.gz
historical-ab27129d48023f4e94251f512ef224d1ada8a9fc.tar.bz2
historical-ab27129d48023f4e94251f512ef224d1ada8a9fc.zip
Added a patch to fix the use of CFLAGS which was causing problems on sparc. Marked ~sparc.
Package-Manager: portage-2.0.54
Diffstat (limited to 'dev-haskell/gtk2hs/files')
-rw-r--r--dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch b/dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch
new file mode 100644
index 000000000000..91356788108e
--- /dev/null
+++ b/dev-haskell/gtk2hs/files/gtk2hs-0.9.10-cflags.patch
@@ -0,0 +1,22 @@
+diff -urwpN gtk2hs-0.9.10.orig/mk/common.mk gtk2hs-0.9.10/mk/common.mk
+--- gtk2hs-0.9.10.orig/mk/common.mk 2006-02-13 16:31:33.184111717 +0000
++++ gtk2hs-0.9.10/mk/common.mk 2006-02-13 17:26:41.972180579 +0000
+@@ -79,6 +79,8 @@ noDeps := $(strip $(findstring clean,$
+ $(strip $(HC) -c $< -o $@ $(INCLUDES) \
+ $(AM_CPPFLAGS) $($(PKG)_CPPFLAGS) $(CPPFLAGS) \
+ $(addprefix -optc,$(AM_CFLAGS) $($(PKG)_CFLAGS) \
++ $(call getVar,$<,CFLAGS) $(CFLAGS)) \
++ $(addprefix -opta,$(AM_CFLAGS) $($(PKG)_CFLAGS) \
+ $(call getVar,$<,CFLAGS) $(CFLAGS)))
+
+ # The cheeky rule for .hi files says that .hi files can be created as
+@@ -106,7 +108,8 @@ noDeps := $(strip $(findstring clean,$
+ $(strip $(HSC2HS) $(HSCFLAGS) +RTS $(HSTOOLFLAGS) -RTS \
+ $(addprefix -L-optl,$(AM_LDFLAGS) $(LDFLAGS) $($(PKG)_LIBS)) \
+ $(addprefix -C, $(filter-out -I%,$(AM_CPPFLAGS) $(CPPFLAGS)) \
+- $(addprefix -optc,$(AM_CFLAGS) $(CFLAGS) $($(PKG)_CFLAGS)))\
++ $(addprefix -optc,$(AM_CFLAGS) $(CFLAGS) $($(PKG)_CFLAGS)) \
++ $(addprefix -opta,$(AM_CFLAGS) $(CFLAGS) $($(PKG)_CFLAGS))) \
+ $(filter -I%,$(AM_CPPFLAGS) $(CPPFLAGS)) $($(PKG)_CPPFLAGS)\
+ -C'-optc-include' -C'-optc$(CONFIG_HEADER)' \
+ --include $($(PKG)_HEADER) \