summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 13:56:24 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-03-28 13:56:24 +0000
commit46ab6f814317e9713adc1674edb9dbcf118ada43 (patch)
tree6c1af96a9d8c8aab7ad2041dc338561c05563ce4 /dev-haskell/happy/happy-1.18.4.ebuild
parentAutomated update of use.local.desc (diff)
downloadhistorical-46ab6f814317e9713adc1674edb9dbcf118ada43.tar.gz
historical-46ab6f814317e9713adc1674edb9dbcf118ada43.tar.bz2
historical-46ab6f814317e9713adc1674edb9dbcf118ada43.zip
Bundle dev-haskell/mtl with dev-haskell/haddock.
Package-Manager: portage-2.1.7.17/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/happy/happy-1.18.4.ebuild')
-rw-r--r--dev-haskell/happy/happy-1.18.4.ebuild30
1 files changed, 25 insertions, 5 deletions
diff --git a/dev-haskell/happy/happy-1.18.4.ebuild b/dev-haskell/happy/happy-1.18.4.ebuild
index cd40c1bc6905..3a46c3a62256 100644
--- a/dev-haskell/happy/happy-1.18.4.ebuild
+++ b/dev-haskell/happy/happy-1.18.4.ebuild
@@ -1,22 +1,28 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.4.ebuild,v 1.1 2009/08/02 09:09:50 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.18.4.ebuild,v 1.2 2010/03/28 13:56:24 kolmodin Exp $
CABAL_FEATURES="bin"
inherit haskell-cabal autotools
+# we bundle mtl as we want fewer dependencies for haddock, which require happy
+# mtl needs haddock to be compiled with USE=doc
+MTL_PN="mtl"
+MTL_PV="1.1.0.2"
+MTL_P="${MTL_PN}-${MTL_PV}"
+
DESCRIPTION="Happy is a parser generator for Haskell"
HOMEPAGE="http://www.haskell.org/happy/"
-SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz
+ http://hackage.haskell.org/packages/archive/${MTL_PN}/${MTL_PV}/${MTL_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
-DEPEND=">=dev-lang/ghc-6.4
+DEPEND=">=dev-lang/ghc-6.6.1
>=dev-haskell/cabal-1.2.3
- >=dev-haskell/mtl-1.0
doc? ( ~app-text/docbook-xml-dtd-4.2
app-text/docbook-xsl-stylesheets )"
RDEPEND=""
@@ -24,6 +30,20 @@ RDEPEND=""
src_unpack() {
unpack ${A}
cd "${S}/doc" && eautoconf
+
+ # change happy.cabal to use bundled mtl
+ # remove dep on mtl, add path
+ sed -e "s|, mtl >= 1.0||" \
+ -e "s|hs-source-dirs: src|hs-source-dirs: src, ../mtl-1.1.0.2|" \
+ -i "${S}/${PN}.cabal"
+ # compile happy with the extensions mtl uses (safe?)
+ # this gives repoman whitespace warnings, ignore them
+ cat >> "${S}/${PN}.cabal" << EOF
+ extensions: MultiParamTypeClasses,
+ FunctionalDependencies,
+ FlexibleInstances,
+ TypeSynonymInstances
+EOF
}
src_compile() {