summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-20 13:28:20 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-20 13:28:20 +0000
commited8b0cff657a7cfb88937b858991cd601ddf5c24 (patch)
tree4f60d2694d6561249d67298cd2608a24b22904e8 /dev-haskell/http/http-3001.0.0.ebuild
parentAdd missing DEPEND on dev-haskell/regex-compat. (diff)
downloadhistorical-ed8b0cff657a7cfb88937b858991cd601ddf5c24.tar.gz
historical-ed8b0cff657a7cfb88937b858991cd601ddf5c24.tar.bz2
historical-ed8b0cff657a7cfb88937b858991cd601ddf5c24.zip
New version compatible with ghc-6.8. Mark older one as not working with ghc-6.8.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/http/http-3001.0.0.ebuild')
-rw-r--r--dev-haskell/http/http-3001.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-haskell/http/http-3001.0.0.ebuild b/dev-haskell/http/http-3001.0.0.ebuild
new file mode 100644
index 000000000000..cb6fbc06c5f9
--- /dev/null
+++ b/dev-haskell/http/http-3001.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-3001.0.0.ebuild,v 1.1 2007/12/20 13:28:19 dcoutts Exp $
+
+CABAL_FEATURES="profile haddock lib"
+CABAL_MIN_VERSION=1.2
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="http://www.haskell.org/http/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.4.2
+ dev-haskell/network"
+
+S="${WORKDIR}/${MY_P}"