summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-12-16 20:16:53 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-12-16 20:16:53 +0000
commit8346d5ccc218c80b4b92f125c5e62530d1d346ee (patch)
tree5c079bda2c467ac82b811a2ea570dcdf7ba10d44 /dev-haskell/http
parentAdd ~ppc64 keyword to dev-haskell/parsec 2.1.0.1. Tested by trofi. (diff)
downloadhistorical-8346d5ccc218c80b4b92f125c5e62530d1d346ee.tar.gz
historical-8346d5ccc218c80b4b92f125c5e62530d1d346ee.tar.bz2
historical-8346d5ccc218c80b4b92f125c5e62530d1d346ee.zip
Version bump dev-haskell/http.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/ChangeLog7
-rw-r--r--dev-haskell/http/http-4000.0.8.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index 342d773d2aae..bcda66907d6e 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.11 2009/05/10 21:49:10 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.12 2009/12/16 20:16:53 kolmodin Exp $
+
+*http-4000.0.8 (15 Dec 2009)
+
+ 15 Dec 2009; <kolmodin@gentoo.org> +http-4000.0.8.ebuild:
+ Version bump.
*http-4000.0.6 (10 May 2009)
diff --git a/dev-haskell/http/http-4000.0.8.ebuild b/dev-haskell/http/http-4000.0.8.ebuild
new file mode 100644
index 000000000000..c9d4fbd0df60
--- /dev/null
+++ b/dev-haskell/http/http-4000.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.0.8.ebuild,v 1.1 2009/12/16 20:16:53 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="http://projects.haskell.org/http/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/parsec"
+
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"