summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:49:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:49:58 +0000
commit1dfb300ecf05a894932fc6cfdbbe31ad2d28c112 (patch)
tree6cd4bec592aba3c762bbfe324ede066186002559 /dev-haskell/texmath/texmath-0.6.0.3.ebuild
parentFix unpacking of live git ebuilds. (diff)
downloadhistorical-1dfb300ecf05a894932fc6cfdbbe31ad2d28c112.tar.gz
historical-1dfb300ecf05a894932fc6cfdbbe31ad2d28c112.tar.bz2
historical-1dfb300ecf05a894932fc6cfdbbe31ad2d28c112.zip
Version bump.
Package-Manager: portage-2.2.0_alpha90_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/texmath/texmath-0.6.0.3.ebuild')
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/texmath/texmath-0.6.0.3.ebuild b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
new file mode 100644
index 000000000000..aeeb3de5aa4c
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.3.ebuild,v 1.1 2012/03/10 17:42:44 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-2[profile?]
+ dev-haskell/syb[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ >=dev-lang/ghc-6.8.2
+ cgi? ( dev-haskell/json[profile?]
+ dev-haskell/cgi[profile?]
+ dev-haskell/utf8-string[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}