summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2004-01-10 18:19:48 +0000
committerAdrian Almenar <strider@gentoo.org>2004-01-10 18:19:48 +0000
commit4ae3809cf70c9beca888eabd8a34981f1380d677 (patch)
tree10178137257602ba0a60a3716fdf26bcb41c8bb5 /dev-java/bsh/bsh-1.3.0.ebuild
parentupdate Manifest (diff)
downloadhistorical-4ae3809cf70c9beca888eabd8a34981f1380d677.tar.gz
historical-4ae3809cf70c9beca888eabd8a34981f1380d677.tar.bz2
historical-4ae3809cf70c9beca888eabd8a34981f1380d677.zip
Version Bump. Removed keywords arm,hppa,mips.
Diffstat (limited to 'dev-java/bsh/bsh-1.3.0.ebuild')
-rw-r--r--dev-java/bsh/bsh-1.3.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/bsh/bsh-1.3.0.ebuild b/dev-java/bsh/bsh-1.3.0.ebuild
new file mode 100644
index 000000000000..71f61deaf1d3
--- /dev/null
+++ b/dev-java/bsh/bsh-1.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bsh/bsh-1.3.0.ebuild,v 1.1 2004/01/10 18:19:48 strider Exp $
+
+inherit java-pkg
+
+At="bsh-1.3.0.jar"
+S=${WORKDIR}
+DESCRIPTION="BeanShell is a small, free, embeddable, Java source interpreter with object scripting language features."
+SRC_URI="http://www.beanshell.org/${At}"
+HOMEPAGE="http://www.beanshell.org/"
+KEYWORDS="~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+DEPEND=""
+RDEPEND=">=virtual/jdk-1.2"
+
+src_compile() {
+ einfo " This ebuild is binary-only (for now)."
+ einfo " If you get this to compile from source, please file a bug"
+ einfo " and let us know. http://bugs.gentoo.org/"
+}
+
+src_install() {
+ dobin ${FILESDIR}/bsh.Console ${FILESDIR}/bsh.Interpreter
+ java-pkg_dojar ${DISTDIR}/${At}
+}