summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-03-22 02:24:52 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-03-22 02:24:52 +0000
commit810373640333f071e9283d653ebe63275ecb3fa8 (patch)
tree4c20f3bb92ad6a864025890ad52af77e21b35d3e /dev-java/commons-codec/commons-codec-1.3-r1.ebuild
parentRESTRICT test because the upstream distribution doesn't have them. (diff)
downloadhistorical-810373640333f071e9283d653ebe63275ecb3fa8.tar.gz
historical-810373640333f071e9283d653ebe63275ecb3fa8.tar.bz2
historical-810373640333f071e9283d653ebe63275ecb3fa8.zip
Prepare for generic src_test.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-java/commons-codec/commons-codec-1.3-r1.ebuild')
-rw-r--r--dev-java/commons-codec/commons-codec-1.3-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-java/commons-codec/commons-codec-1.3-r1.ebuild b/dev-java/commons-codec/commons-codec-1.3-r1.ebuild
index 7d7692c3977f..69a86074dc01 100644
--- a/dev-java/commons-codec/commons-codec-1.3-r1.ebuild
+++ b/dev-java/commons-codec/commons-codec-1.3-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-codec/commons-codec-1.3-r1.ebuild,v 1.11 2007/07/29 19:22:17 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-codec/commons-codec-1.3-r1.ebuild,v 1.12 2008/03/22 02:24:52 betelgeuse Exp $
-JAVA_PKG_IUSE="doc source"
+EAPI=1
+JAVA_PKG_IUSE="doc source test"
inherit java-pkg-2 java-ant-2
@@ -20,6 +21,7 @@ RDEPEND=">=virtual/jre-1.3
dev-java/log4j"
DEPEND=">=virtual/jdk-1.3
+ test? ( dev-java/ant-junit:0 )
${RDEPEND}"
S="${WORKDIR}"
@@ -27,6 +29,7 @@ S="${WORKDIR}"
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/1.3-tests-fix.patch"
sed -i "s_../LICENSE_LICENSE.txt_" build.xml || die "sed failed"
echo "conf.home=./src/conf" >> build.properties
echo "source.home=./src/java" >> build.properties
@@ -34,6 +37,7 @@ src_unpack() {
echo "dist.home=./output/dist" >> build.properties
echo "test.home=./src/test" >> build.properties
echo "final.name=commons-codec" >> build.properties
+ java-ant_xml-rewrite -f build.xml -c -e javac -a encoding -v ISO8859-1
}
src_install() {