summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-04 18:38:25 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-04 18:38:25 +0000
commite5038126fe407335be56cffc41da565038d31c33 (patch)
tree98059e8a31bda0b9833e9b4dd975b32d15e2d536 /dev-java/commons-io/commons-io-1.1.ebuild
parentUpdate package path for RC3. (diff)
downloadhistorical-e5038126fe407335be56cffc41da565038d31c33.tar.gz
historical-e5038126fe407335be56cffc41da565038d31c33.tar.bz2
historical-e5038126fe407335be56cffc41da565038d31c33.zip
Version bump (bug #113585)
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-java/commons-io/commons-io-1.1.ebuild')
-rw-r--r--dev-java/commons-io/commons-io-1.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/commons-io/commons-io-1.1.ebuild b/dev-java/commons-io/commons-io-1.1.ebuild
new file mode 100644
index 000000000000..3a9f37b8aad7
--- /dev/null
+++ b/dev-java/commons-io/commons-io-1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-io/commons-io-1.1.ebuild,v 1.1 2005/12/04 18:38:25 nichoj Exp $
+
+inherit java-pkg eutils
+
+MY_P="${P}-src"
+DESCRIPTION="Commons-IO contains utility classes , stream implementations, file filters , and endian classes."
+HOMEPAGE="http://jakarta.apache.org/commons/io"
+SRC_URI="mirror://apache/jakarta/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="1"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc jikes source"
+
+DEPEND="jikes? ( >=dev-java/jikes-1.21 )
+ dev-java/ant-core
+ source? ( app-arch/zip )
+ >=virtual/jdk-1.3"
+RDEPEND=">=virtual/jre-1.3"
+
+S="${WORKDIR}/${MY_P}"
+
+# junit tests are disabled for now.
+# one of the tests (FileUtilsCleanDirectoryTestCase) always fails when run as
+# root.
+# TODO report upstream
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+
+ mkdir -p build/lib
+ cd build/lib
+# use junit && java-pkg_jar-from junit
+}
+
+src_compile() {
+ local antflags="jar -Dlibdir=build/lib"
+ use doc && antflags="${antflags} javadoc -Djavadocdir=dist/docs/api"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+# use junit && antflags="${antflags} test"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ java-pkg_newjar build/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc src/java/*
+}