summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-29 09:23:52 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-29 09:23:52 +0000
commit6967e67bd766fc4031b5883a11ce6e51bda57bb8 (patch)
tree34ce752438f3090f36e208760b11db3818913ba1 /dev-java/commons-net/commons-net-1.4.1-r1.ebuild
parentDETECT_CLIENT config directive now controls init script behaviour, #181000. (diff)
downloadhistorical-6967e67bd766fc4031b5883a11ce6e51bda57bb8.tar.gz
historical-6967e67bd766fc4031b5883a11ce6e51bda57bb8.tar.bz2
historical-6967e67bd766fc4031b5883a11ce6e51bda57bb8.zip
Depend on >=dev-java/jakarta-oro-2.0.8-r2 to prevent versions from dev-java/oro that was moved to jakarta-oro from matching. Switch to java-pkg_doexamples.
Package-Manager: portage-2.1.3_rc5
Diffstat (limited to 'dev-java/commons-net/commons-net-1.4.1-r1.ebuild')
-rw-r--r--dev-java/commons-net/commons-net-1.4.1-r1.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/dev-java/commons-net/commons-net-1.4.1-r1.ebuild b/dev-java/commons-net/commons-net-1.4.1-r1.ebuild
index 2298eac2488c..4500e0b66658 100644
--- a/dev-java/commons-net/commons-net-1.4.1-r1.ebuild
+++ b/dev-java/commons-net/commons-net-1.4.1-r1.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.4.1-r1.ebuild,v 1.10 2007/02/10 19:10:10 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-net/commons-net-1.4.1-r1.ebuild,v 1.11 2007/06/29 09:23:52 betelgeuse Exp $
+
+# disabling unit tests:
+# http://issues.apache.org/bugzilla/show_bug.cgi?id=37985
+JAVA_PKG_IUSE="doc examples source" # junit
inherit eutils java-pkg-2 java-ant-2
@@ -8,21 +12,19 @@ MY_P="${P}-src"
DESCRIPTION="The purpose of the library is to provide fundamental protocol access, not higher-level abstractions."
HOMEPAGE="http://jakarta.apache.org/commons/net/"
SRC_URI="mirror://apache/jakarta/commons/net/source/${MY_P}.tar.gz"
+
+# dev-java/oro had a package move to jakarta-oro so depend on a version
+# that oro did not have. Most likely the cause of https://bugs.gentoo.org/show_bug.cgi?id=183595
COMMON_DEP="
- >=dev-java/jakarta-oro-2.0"
+ >=dev-java/jakarta-oro-2.0.8-r2"
RDEPEND=">=virtual/jre-1.3
${COMMON_DEP}
"
DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-core-1.5.4
- source? ( app-arch/zip )
${COMMON_DEP}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd"
-# disabling unit tests:
-# http://issues.apache.org/bugzilla/show_bug.cgi?id=37985
-IUSE="doc examples source" # junit
src_unpack() {
unpack ${A}
@@ -40,9 +42,6 @@ src_install() {
java-pkg_newjar target/${P}.jar ${PN}.jar
use doc && java-pkg_dojavadoc dist/docs/api
- if use examples; then
- dodir /usr/share/doc/${PF}/examples
- cp -r src/java/examples/* ${D}/usr/share/doc/${PF}/examples
- fi
+ use examples && java-pkg_doexamples src/java/examples
use source && java-pkg_dosrc src/java/org
}