summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-01-03 03:17:03 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-01-03 03:17:03 +0000
commit9949232969ba3e10b64fedd8efbf2b43dd40dfb0 (patch)
treed5e27a362028ebcbb8c77559c09f96c88bab5665 /dev-java/ehcache/ehcache-1.2.4.ebuild
parentamd64 stable, bug 149964 (diff)
downloadhistorical-9949232969ba3e10b64fedd8efbf2b43dd40dfb0.tar.gz
historical-9949232969ba3e10b64fedd8efbf2b43dd40dfb0.tar.bz2
historical-9949232969ba3e10b64fedd8efbf2b43dd40dfb0.zip
Version bump. Added as slot 1.2 because there are a few subtle API incompatibilities.
Package-Manager: portage-2.1.2_rc4-r4
Diffstat (limited to 'dev-java/ehcache/ehcache-1.2.4.ebuild')
-rw-r--r--dev-java/ehcache/ehcache-1.2.4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-java/ehcache/ehcache-1.2.4.ebuild b/dev-java/ehcache/ehcache-1.2.4.ebuild
new file mode 100644
index 000000000000..90ee8b411087
--- /dev/null
+++ b/dev-java/ehcache/ehcache-1.2.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ehcache/ehcache-1.2.4.ebuild,v 1.1 2007/01/03 03:17:03 nichoj Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Ehcache is a pure Java, fully-featured, in-process cache."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://ehcache.sourceforge.net"
+
+LICENSE="Apache-1.1"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+COMMON_DEPEND="
+ dev-java/commons-collections
+ dev-java/concurrent-util
+ dev-java/commons-logging
+ ~dev-java/servletapi-2.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}
+ source? ( app-arch/zip )
+ >=dev-java/ant-core-1.5"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ mkdir src && cd src
+ unzip -qq ../${P}-sources.jar || die
+ rm -rf net/sf/ehcache/hibernate
+}
+
+src_compile() {
+ mkdir ${S}/classes
+ cd ${S}/src
+
+ ejavac -d ${S}/classes \
+ -classpath $(java-pkg_getjars commons-logging,commons-collections,servletapi-2.4) \
+ $(find . -name "*.java")
+
+ cd ${S}/classes
+ jar cf ${S}/${P}.jar * || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_newjar ${S}/${P}.jar
+ dodoc *.txt ehcache.xml ehcache.xsd
+ use source && java-pkg_dosrc src
+ if use doc ; then
+ unzip -qq ${P}-javadoc.zip || die
+ java-pkg_dohtml -r docs
+ fi
+}