summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Brinkmann <luckyduck@gentoo.org>2005-01-23 14:50:15 +0000
committerJan Brinkmann <luckyduck@gentoo.org>2005-01-23 14:50:15 +0000
commit3e670cfe6ad35c2bf42f3df009489e6291aa387c (patch)
treeec5a5d053a281d28c5ce04022e16ff41e82a8f82 /dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
parentRevision bump to solve false detections with static coreutils (du and ls). Bu... (diff)
downloadhistorical-3e670cfe6ad35c2bf42f3df009489e6291aa387c.tar.gz
historical-3e670cfe6ad35c2bf42f3df009489e6291aa387c.tar.bz2
historical-3e670cfe6ad35c2bf42f3df009489e6291aa387c.zip
Initial import, fixes #76209.
Package-Manager: portage-2.0.51-r14
Diffstat (limited to 'dev-java/jexcelapi/jexcelapi-2.5.1.ebuild')
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.5.1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild b/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
new file mode 100644
index 000000000000..18056f377291
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.5.1.ebuild,v 1.1 2005/01/23 14:50:15 luckyduck Exp $
+
+inherit eutils java-pkg
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~x86 ~amd64"
+
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant-core
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="nomirror"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-jikes.patch
+
+ rm -rf jxl.jar docs
+}
+
+src_compile() {
+ local antflags="jxl"
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+
+ cd ${S}/build
+ ant ${antflags} || die "ant failed"
+}
+
+src_install() {
+ mv jxl.jar ${PN}.jar
+ java-pkg_dojar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dohtml -r docs/*
+}