summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-15 20:46:56 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-15 20:46:56 +0000
commitcb422dbc714abd7ae26105a1a1e77f22dd5de2c7 (patch)
tree00a213eff1d5f7c83828026326a6d74a2422265b /dev-java/minml2/minml2-0.3.ebuild
parentdep fixes (diff)
downloadhistorical-cb422dbc714abd7ae26105a1a1e77f22dd5de2c7.tar.gz
historical-cb422dbc714abd7ae26105a1a1e77f22dd5de2c7.tar.bz2
historical-cb422dbc714abd7ae26105a1a1e77f22dd5de2c7.zip
style fixes
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/minml2/minml2-0.3.ebuild')
-rw-r--r--dev-java/minml2/minml2-0.3.ebuild16
1 files changed, 5 insertions, 11 deletions
diff --git a/dev-java/minml2/minml2-0.3.ebuild b/dev-java/minml2/minml2-0.3.ebuild
index cd7d91587f7a..98c7b2e98e36 100644
--- a/dev-java/minml2/minml2-0.3.ebuild
+++ b/dev-java/minml2/minml2-0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/minml2/minml2-0.3.ebuild,v 1.2 2005/02/05 20:14:01 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/minml2/minml2-0.3.ebuild,v 1.3 2005/07/15 20:46:56 axxo Exp $
inherit eutils java-pkg
@@ -30,20 +30,14 @@ src_unpack() {
src_compile() {
local antflags="jar"
- if use doc; then
- antflags="${antflags} docs"
- fi
- if use jikes; then
- antflags="${antflags} -Dbuild.compiler=jikes"
- fi
+ use doc && antflags="${antflags} docs"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
ant ${antflags} || die "failed to build"
}
src_install() {
java-pkg_dojar dist/minml2.jar
- dodoc history.txt licence.txt readme.txt
- if use doc; then
- java-pkg_dohtml -r docs/*
- fi
+ dodoc history.txt readme.txt
+ use doc && java-pkg_dohtml -r docs/*
}