summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2005-07-13 14:08:28 +0000
committerSven Wegener <swegener@gentoo.org>2005-07-13 14:08:28 +0000
commitc338a0e65a78971a282ed693cb9bbfce9e9a032c (patch)
tree7ad823d9d0074aea7404c6e1d6918b2c983b1bed /dev-java/sun-jdk
parentSwitch from kde-functions.eclass to qt3.eclass. Also fixes bug #97956. (diff)
downloadhistorical-c338a0e65a78971a282ed693cb9bbfce9e9a032c.tar.gz
historical-c338a0e65a78971a282ed693cb9bbfce9e9a032c.tar.bz2
historical-c338a0e65a78971a282ed693cb9bbfce9e9a032c.zip
QA: Use full atoms for best_version, has_version and built_with_use queries.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild4
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild8
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild8
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild8
4 files changed, 14 insertions, 14 deletions
diff --git a/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild b/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
index 03e34c0ecd43..60c63b6e0568 100644
--- a/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild,v 1.9 2005/07/11 18:18:03 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.3.1.13.ebuild,v 1.10 2005/07/13 14:03:49 swegener Exp $
inherit java eutils
@@ -101,7 +101,7 @@ pkg_postinst () {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
index b0d0838015f6..2fe35768ef7a 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild,v 1.1 2005/07/11 13:21:55 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08-r1.ebuild,v 1.2 2005/07/13 14:03:49 swegener Exp $
inherit java eutils
@@ -123,7 +123,7 @@ src_install() {
if use browserplugin || use mozilla; then
local plugin_dir="ns610"
- if has_version '>=gcc-3.2*' ; then
+ if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
fi
@@ -159,7 +159,7 @@ pkg_postinst() {
java_pkg_postinst
#Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
einfo
@@ -170,7 +170,7 @@ pkg_postinst() {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
index 93d114836ca8..ddc0a09e5377 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.6 2005/07/11 13:21:55 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.08.ebuild,v 1.7 2005/07/13 14:03:49 swegener Exp $
inherit java eutils
@@ -116,7 +116,7 @@ src_install() {
if use browserplugin || use mozilla; then
local plugin_dir="ns610"
- if has_version '>=gcc-3.2*' ; then
+ if has_version '>=sys-devel/gcc-3.2' ; then
plugin_dir="ns610-gcc32"
fi
@@ -152,7 +152,7 @@ pkg_postinst() {
java_pkg_postinst
#Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
einfo
@@ -163,7 +163,7 @@ pkg_postinst() {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
index 021aa7c1bb5f..a1e537032318 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild,v 1.2 2005/07/11 13:21:55 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.04.ebuild,v 1.3 2005/07/13 14:03:49 swegener Exp $
inherit java eutils
@@ -131,7 +131,7 @@ src_install() {
if use browserplugin || use mozilla; then
local plugin_dir="ns7-gcc29"
- if has_version '>=gcc-3*' ; then
+ if has_version '>=sys-devel/gcc-3' ; then
plugin_dir="ns7"
fi
@@ -177,7 +177,7 @@ pkg_postinst() {
java_pkg_postinst
#Show info about netscape
- if has_version '>=netscape-navigator-4.79-r1' || has_version '>=netscape-communicator-4.79-r1' ; then
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
echo
einfo "If you want to install the plugin for Netscape 4.x, type"
einfo
@@ -188,7 +188,7 @@ pkg_postinst() {
# if chpax is on the target system, set the appropriate PaX flags
# this will not hurt the binary, it modifies only unused ELF bits
# but may confuse things like AV scanners and automatic tripwire
- if has_version "sys-apps/chpax"
+ if has_version sys-apps/chpax
then
echo
einfo "setting up conservative PaX flags for jar, javac and java"