summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-12-16 21:10:16 +0000
committerVlastimil Babka <caster@gentoo.org>2007-12-16 21:10:16 +0000
commit874e1ca4adaa45cdc0217475ba02de102c76c8d1 (patch)
tree5fb403d8acf3749d6ee5fa55a30c0d9c44679486 /dev-java
parentbump to 2.20.2 (diff)
downloadhistorical-874e1ca4adaa45cdc0217475ba02de102c76c8d1.tar.gz
historical-874e1ca4adaa45cdc0217475ba02de102c76c8d1.tar.bz2
historical-874e1ca4adaa45cdc0217475ba02de102c76c8d1.zip
Add odbc USE flag and revdep-rebuild control file for bug #177925, tweak the deps.
Package-Manager: portage-2.1.4_rc9
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/sun-jdk/ChangeLog7
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild32
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild29
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild31
-rw-r--r--dev-java/sun-jre-bin/ChangeLog8
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild28
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild23
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild25
8 files changed, 71 insertions, 112 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index 2ae971e60155..ac586b9067bb 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.221 2007/11/25 13:51:01 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.222 2007/12/16 21:10:16 caster Exp $
+
+ 16 Dec 2007; Vlastimil Babka <caster@gentoo.org> sun-jdk-1.4.2.16.ebuild,
+ sun-jdk-1.5.0.13.ebuild, sun-jdk-1.6.0.03.ebuild:
+ Add odbc USE flag and revdep-rebuild control file for bug #177925, tweak the
+ deps.
25 Nov 2007; Vlastimil Babka <caster@gentoo.org> sun-jdk-1.4.2.16.ebuild,
sun-jdk-1.5.0.13.ebuild, sun-jdk-1.6.0.03.ebuild:
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild
index bb0e630ae919..215348a2a11a 100644
--- a/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild,v 1.5 2007/11/25 13:51:01 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild,v 1.6 2007/12/16 21:10:16 caster Exp $
JAVA_SUPPORTS_GENERATION_1="true"
inherit pax-utils java-vm-2 eutils
@@ -22,21 +22,23 @@ LICENSE="sun-bcla-java-vm"
KEYWORDS="x86"
# files are prestripped
RESTRICT="fetch strip"
-IUSE="X alsa doc examples nsplugin jce"
+IUSE="X alsa doc examples jce nsplugin odbc"
DEPEND="sys-apps/sed
app-arch/unzip"
-RDEPEND="alsa? ( media-libs/alsa-lib )
+RDEPEND="net-libs/libnet
+ alsa? ( media-libs/alsa-lib )
doc? ( =dev-java/java-sdk-docs-1.4.2* )
X? (
- x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXp
- x11-libs/libXt
x11-libs/libXtst
- )"
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
JAVA_PROVIDE="jdbc-stdext"
@@ -108,7 +110,7 @@ src_install() {
# the heap by the JIT compiler.
pax-mark srpm $(list-paxables "${D}"/opt/${P}/{,/jre}/bin/*)
- dodoc COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt || die
+ dodoc COPYRIGHT README THIRDPARTYLICENSEREADME.txt || die
dohtml README.html || die
if use examples; then
cp -pPR demo "${D}/opt/${P}/" || die
@@ -162,19 +164,5 @@ src_install() {
domenu "${T}/sun_java-${SLOT}.desktop"
set_java_env
-}
-
-pkg_postinst() {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- if ! use X; then
- ewarn "Some parts of Sun's JDK require X11 libraries to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
- fi
- elog "Starting with 1.4.2.14 the src.zip is installed to the standard"
- elog "location only (/opt/${P}/) and not /opt/${P}/share/"
- elog "as we used to. See https://bugs.gentoo.org/show_bug.cgi?id=2241 and"
- elog "http://java.sun.com/j2se/1.4.2/docs/tooldocs/linux/jdkfiles.html"
- elog "for more details."
+ java-vm_revdep-mask
}
diff --git a/dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild b/dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild
index 683012fbc446..432b8f4cd143 100644
--- a/dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild,v 1.4 2007/11/25 13:51:01 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.5.0.13.ebuild,v 1.5 2007/12/16 21:10:16 caster Exp $
inherit versionator java-vm-2 eutils pax-utils
@@ -17,7 +17,7 @@ SLOT="1.5"
LICENSE="dlj-1.1"
KEYWORDS="amd64 x86"
RESTRICT="strip"
-IUSE="X alsa doc examples jce nsplugin"
+IUSE="X alsa doc examples jce nsplugin odbc"
QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so opt/${P}/jre/lib/i386/libdeploy.so"
@@ -25,18 +25,19 @@ DEPEND="
doc? ( =dev-java/java-sdk-docs-1.5.0* )
jce? ( =dev-java/sun-jce-bin-1.5.0* )"
-RDEPEND="
+RDEPEND="x86? ( net-libs/libnet )
sys-libs/glibc
alsa? ( media-libs/alsa-lib )
doc? ( =dev-java/java-sdk-docs-1.5.0* )
X? (
- x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXp
- x11-libs/libXt
x11-libs/libXtst
- )"
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
S="${WORKDIR}/jdk$(replace_version_separator 3 _)"
@@ -117,27 +118,13 @@ src_install() {
newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
set_java_env
+ java-vm_revdep-mask
}
pkg_postinst() {
# Set as default VM if none exists
java-vm-2_pkg_postinst
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-
- echo
- elog " Be careful: ${P}'s Java compiler uses"
- elog " '-source 1.5' as default. Some keywords such as 'enum'"
- elog " are not valid identifiers any more in that mode,"
- elog " which can cause incompatibility with certain sources."
-
- echo
elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
elog "The epoll-based implementation of SelectorProvider is not selected by"
elog "default."
diff --git a/dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild b/dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild
index 0bcf3d41d57e..885c08443f0b 100644
--- a/dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild
+++ b/dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild,v 1.4 2007/11/25 13:51:01 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.6.0.03.ebuild,v 1.5 2007/12/16 21:10:16 caster Exp $
inherit versionator java-vm-2 eutils pax-utils
@@ -22,7 +22,7 @@ SLOT="1.6"
LICENSE="dlj-1.1"
KEYWORDS="amd64 x86"
RESTRICT="strip"
-IUSE="X alsa doc examples jce nsplugin"
+IUSE="X alsa doc examples jce nsplugin odbc"
QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/motif21/libmawt.so
opt/${P}/jre/lib/i386/libdeploy.so
@@ -35,16 +35,21 @@ DEPEND="
RDEPEND="
${DEPEND}
- x86? ( =virtual/libstdc++-3.3 )
+ x86? (
+ =virtual/libstdc++-3.3
+ net-libs/libnet
+ )
sys-libs/glibc
alsa? ( media-libs/alsa-lib )
X? (
- x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXp
x11-libs/libXtst
- )"
+ amd64? ( x11-libs/libXt )
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
JAVA_PROVIDE="jdbc-stdext jdbc-rowset"
@@ -123,27 +128,13 @@ src_install() {
newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
set_java_env
+ java-vm_revdep-mask
}
pkg_postinst() {
# Set as default VM if none exists
java-vm-2_pkg_postinst
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-
- echo
- elog " Be careful: ${P}'s Java compiler uses"
- elog " '-source 1.6' as default. Some keywords such as 'enum'"
- elog " are not valid identifiers any more in that mode,"
- elog " which can cause incompatibility with certain sources."
-
- echo
elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
elog "The epoll-based implementation of SelectorProvider is not selected by"
elog "default."
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 687d53338009..bf39b860a977 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.115 2007/11/25 13:52:13 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.116 2007/12/16 21:08:51 caster Exp $
+
+ 16 Dec 2007; Vlastimil Babka <caster@gentoo.org>
+ sun-jre-bin-1.4.2.16.ebuild, sun-jre-bin-1.5.0.13.ebuild,
+ sun-jre-bin-1.6.0.03.ebuild:
+ Add odbc USE flag and revdep-rebuild control file for bug #177925, tweak the
+ deps.
25 Nov 2007; Vlastimil Babka <caster@gentoo.org>
sun-jre-bin-1.5.0.13.ebuild, sun-jre-bin-1.6.0.03.ebuild:
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild
index f371885c6f39..15210eaf6a06 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild,v 1.4 2007/10/12 00:14:43 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.4.2.16.ebuild,v 1.5 2007/12/16 21:08:51 caster Exp $
inherit eutils pax-utils java-vm-2
@@ -16,19 +16,21 @@ LICENSE="sun-bcla-java-vm-1.4.2"
KEYWORDS="-* x86"
# pre stripped
RESTRICT="fetch strip"
-IUSE="X alsa nsplugin"
+IUSE="X alsa nsplugin odbc"
DEPEND=""
-RDEPEND="alsa? ( media-libs/alsa-lib )
+RDEPEND="net-libs/libnet
+ alsa? ( media-libs/alsa-lib )
X? (
- x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXp
- x11-libs/libXt
x11-libs/libXtst
- )"
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=j2re-${MY_PV}-oth-JPR&SiteId=JSC&TransactionId=noreg"
@@ -82,7 +84,7 @@ src_install() {
pax-mark srpm $(list-paxables "${D}"/opt/${P}/bin/*)
- dodoc CHANGES COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt || die
+ dodoc CHANGES COPYRIGHT README THIRDPARTYLICENSEREADME.txt || die
dohtml Welcome.html ControlPanel.html || die
if use nsplugin; then
@@ -115,15 +117,5 @@ src_install() {
domenu "${T}/sun_java-jre.desktop"
set_java_env
-}
-
-pkg_postinst () {
- # Set as default VM if none exists
- java-vm-2_pkg_postinst
-
- if ! use X; then
- echo
- ewarn "Some parts of Sun's JDK require X11 libraries to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
- fi
+ java-vm_revdep-mask
}
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild
index bc0d8a5d3ba9..436975b10ce8 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild,v 1.5 2007/11/25 13:52:13 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.13.ebuild,v 1.6 2007/12/16 21:08:51 caster Exp $
inherit pax-utils eutils java-vm-2
@@ -19,19 +19,20 @@ SLOT="1.5"
LICENSE="dlj-1.1"
KEYWORDS="-* amd64 x86"
RESTRICT="strip"
-IUSE="X alsa nsplugin"
+IUSE="X alsa nsplugin odbc"
-RDEPEND="
+RDEPEND="x86? ( net-libs/libnet )
sys-libs/glibc
alsa? ( media-libs/alsa-lib )
X? (
- x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXp
- x11-libs/libXt
x11-libs/libXtst
- )"
+ x11-libs/libXt
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
DEPEND=""
@@ -94,21 +95,13 @@ src_install() {
fontconfig.properties || die
set_java_env
+ java-vm_revdep-mask
}
pkg_postinst() {
# Set as default VM if none exists
java-vm-2_pkg_postinst
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-
- echo
elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
elog "The epoll-based implementation of SelectorProvider is not selected by"
elog "default."
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild
index ced12d4139f2..ff5823b8d9f5 100644
--- a/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild,v 1.5 2007/11/25 13:52:13 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.6.0.03.ebuild,v 1.6 2007/12/16 21:08:51 caster Exp $
inherit versionator pax-utils eutils java-vm-2
@@ -24,19 +24,24 @@ SLOT="1.6"
LICENSE="dlj-1.1"
KEYWORDS="-* amd64 x86"
RESTRICT="strip"
-IUSE="X alsa nsplugin"
+IUSE="X alsa nsplugin odbc"
RDEPEND="
sys-libs/glibc
- x86? ( =virtual/libstdc++-3.3 )
+ x86? (
+ =virtual/libstdc++-3.3
+ net-libs/libnet
+ )
alsa? ( media-libs/alsa-lib )
X? (
- x11-libs/libX11
x11-libs/libXext
x11-libs/libXi
x11-libs/libXp
x11-libs/libXtst
- )"
+ amd64? ( x11-libs/libXt )
+ x11-libs/libX11
+ )
+ odbc? ( dev-db/unixODBC )"
DEPEND=""
@@ -101,21 +106,13 @@ src_install() {
newins "${FILESDIR}"/fontconfig.Gentoo.properties fontconfig.properties
set_java_env
+ java-vm_revdep-mask
}
pkg_postinst() {
# Set as default VM if none exists
java-vm-2_pkg_postinst
- if ! use X; then
- local xwarn="X11 libraries and/or"
- fi
-
- echo
- ewarn "Some parts of Sun's JDK require ${xwarn} virtual/lpr to be installed."
- ewarn "Be careful which Java libraries you attempt to use."
-
- echo
elog "Beginning with 1.5.0.10 the hotspot vm can use epoll"
elog "The epoll-based implementation of SelectorProvider is not selected by"
elog "default."