summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-19 15:31:05 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-19 15:31:05 +0000
commite65d8605143dd97ec91acc46dd271530824529a0 (patch)
tree8763abb2ad7ea6c2296826caed7d46c99c69b536 /dev-java
parenttested on sparc, ~sparc (diff)
downloadhistorical-e65d8605143dd97ec91acc46dd271530824529a0.tar.gz
historical-e65d8605143dd97ec91acc46dd271530824529a0.tar.bz2
historical-e65d8605143dd97ec91acc46dd271530824529a0.zip
no longer uses packed jars
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/batik/ChangeLog7
-rw-r--r--dev-java/batik/batik-1.5.1-r1.ebuild44
-rw-r--r--dev-java/batik/files/digest-batik-1.5.1-r11
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-java/batik/ChangeLog b/dev-java/batik/ChangeLog
index 3d5bb30754cb..e325de28aab0 100644
--- a/dev-java/batik/ChangeLog
+++ b/dev-java/batik/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/batik
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.11 2004/08/13 21:24:33 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.12 2004/09/19 15:31:05 axxo Exp $
+
+*batik-1.5.1-r1 (19 Sep 2004)
+
+ 19 Sep 2004; Thomas Matthijs <axxo@gentoo.org> +batik-1.5.1-r1.ebuild:
+ no longer uses packed jars
13 Aug 2004; Chris Aniszczyk <zx@gentoo.org> -batik-1.5.ebuild:
Clean up
diff --git a/dev-java/batik/batik-1.5.1-r1.ebuild b/dev-java/batik/batik-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..406944f41530
--- /dev/null
+++ b/dev-java/batik/batik-1.5.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.5.1-r1.ebuild,v 1.1 2004/09/19 15:31:05 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Batik is a Java(tm) technology based toolkit for applications or applets that want to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
+SRC_URI="mirror://apache/xml/batik/${PN}-src-${PV}.zip"
+HOMEPAGE="http://xml.apache.org/batik/"
+IUSE="doc"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/rhino
+ dev-java/fop
+ >=dev-java/xerces-2.6.2-r1
+ dev-java/ant"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc"
+
+S=${WORKDIR}/xml-batik
+
+src_unpack() {
+ jar xvf ${DISTDIR}/${PN}-src-${PV}.zip
+ cd ${S}/lib
+ rm -f *.jar
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from rhino
+ java-pkg_jar-from fop fop.jar fop.jar
+}
+
+src_compile() {
+ local antflags="jars"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ java-pkg_dojar ${P}/batik*.jar
+ insinto /usr/share/${PN}/lib/lib
+ doins ${P}/lib/*.jar
+
+ dodoc README LICENSE
+ use doc && dohtml -r ${P}/docs/
+}
diff --git a/dev-java/batik/files/digest-batik-1.5.1-r1 b/dev-java/batik/files/digest-batik-1.5.1-r1
new file mode 100644
index 000000000000..cab50b8d6f96
--- /dev/null
+++ b/dev-java/batik/files/digest-batik-1.5.1-r1
@@ -0,0 +1 @@
+MD5 8a3ba8b76dcef9415216d6a5b9685a9c batik-src-1.5.1.zip 11474737