summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-12-10 21:16:56 +0000
committerJustin Lecher <jlec@gentoo.org>2012-12-10 21:16:56 +0000
commit28634fe85682cd5cf0d3a37094d4436b72b6aaba (patch)
tree4bac71af311e96085acb82750cb36a7d454bdfbb /dev-lang/idb/idb-13.0.1.117-r1.ebuild
parentdev-libs/intel-common: Manpagges are handled in the eclass (diff)
downloadhistorical-28634fe85682cd5cf0d3a37094d4436b72b6aaba.tar.gz
historical-28634fe85682cd5cf0d3a37094d4436b72b6aaba.tar.bz2
historical-28634fe85682cd5cf0d3a37094d4436b72b6aaba.zip
dev-lang/idb: Fix launcher script; add missing dep
Package-Manager: portage-2.2.0_alpha147/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'dev-lang/idb/idb-13.0.1.117-r1.ebuild')
-rw-r--r--dev-lang/idb/idb-13.0.1.117-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/idb/idb-13.0.1.117-r1.ebuild b/dev-lang/idb/idb-13.0.1.117-r1.ebuild
new file mode 100644
index 000000000000..12efe9bd791e
--- /dev/null
+++ b/dev-lang/idb/idb-13.0.1.117-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/idb/idb-13.0.1.117-r1.ebuild,v 1.1 2012/12/10 21:16:55 jlec Exp $
+
+EAPI=4
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=2872
+INTEL_DPV=2013_update1
+INTEL_SUBDIR=composerxe
+
+inherit intel-sdp
+
+DESCRIPTION="Intel C/C++/FORTRAN debugger"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="eclipse"
+
+DEPEND="~dev-libs/intel-common-${PV}[compiler]"
+RDEPEND="${DEPEND}
+ virtual/jre
+ eclipse? ( dev-util/eclipse-sdk )"
+
+INTEL_BIN_RPMS="idb"
+INTEL_DAT_RPMS="idb-common idbcdt"
+
+src_prepare() {
+ sed \
+ -e "/^INSTALLDIR/s:=.*:=${INTEL_SDP_EDIR}:g" \
+ -i opt/intel/composerxe-2013_update1.1.117/bin/intel64/idb || die
+}