summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2006-11-27 23:02:36 +0000
committerMatti Bickel <mabi@gentoo.org>2006-11-27 23:02:36 +0000
commit1602c5fadef4e8eacba4b36ad10364e828ff4768 (patch)
tree74a3c0b337d48a1819e957be42a9c93d3ec7f5b1 /dev-lang/lua/files
parentVersion bump, bug 154092. Ebuild by Andrew Cremins. (diff)
downloadhistorical-1602c5fadef4e8eacba4b36ad10364e828ff4768.tar.gz
historical-1602c5fadef4e8eacba4b36ad10364e828ff4768.tar.bz2
historical-1602c5fadef4e8eacba4b36ad10364e828ff4768.zip
Build static library too, do tests with static lua
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'dev-lang/lua/files')
-rw-r--r--dev-lang/lua/files/lua-5.1.1-make.patch27
-rw-r--r--dev-lang/lua/files/lua-5.1.1-make_static.patch4
2 files changed, 18 insertions, 13 deletions
diff --git a/dev-lang/lua/files/lua-5.1.1-make.patch b/dev-lang/lua/files/lua-5.1.1-make.patch
index 3dc7aee59a7e..b05c841e9731 100644
--- a/dev-lang/lua/files/lua-5.1.1-make.patch
+++ b/dev-lang/lua/files/lua-5.1.1-make.patch
@@ -15,7 +15,7 @@
# Utilities.
CP= cp
-@@ -127,3 +127,21 @@
+@@ -127,3 +127,22 @@
.PHONY: all $(PLATS) clean test install local none dummy echo pecho lecho newer
# (end of Makefile)
@@ -34,12 +34,13 @@
+
+gentoo_install:
+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua-$(V) luac-$(V) $(INSTALL_BIN)
++ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
++ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.a $(INSTALL_LIB)
--- /home/mabi/gentoo/lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
+++ ./src/Makefile 2006-11-16 02:10:27.000000000 +0100
-@@ -176,3 +176,32 @@
+@@ -176,3 +176,36 @@
ltm.h lzio.h lmem.h lopcodes.h lundump.h
# (end of Makefile)
@@ -48,9 +49,7 @@
+export LIB_VERSION = 6:1:1
+
+# The following rules use libtool for compiling and linking in order to
-+# provide shared library support. While we are at it, our desired version
-+# suffixes are added to the targets, preventing conflicts with rules in
-+# the upstream makefile.
++# provide shared library support.
+
+LIB_NAME = liblua.la
+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
@@ -58,17 +57,23 @@
+%.lo %.o: %.c
+ $(LIBTOOL) --mode=compile $(CC) -c $(CPPFLAGS) $(CFLAGS) -o $@ $<
+
-+$(LIB_NAME) $(LIB_NAME:.la=.a): $(LIB_OBJS)
++$(LIB_NAME): $(LIB_OBJS)
+ $(LIBTOOL) --mode=link $(CC) -version-info $(LIB_VERSION) \
+ -rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
+
-+lua-$(V): $(LUA_O) $(LIB_NAME)
++$(LIB_NAME:.la=.a): $(LIB_OBJS)
++ $(LIBTOOL) --mode=link $(CC) -static -o $(LIB_NAME:.la=.a) $(LIB_OBJS)
++
++lua: $(LUA_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
+
-+luac-$(V): $(LUAC_O) $(LIB_NAME)
++lua_test: $(LUA_O) $(LIB_NAME)
++ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
++
++luac: $(LUAC_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)
+
+gentoo_clean:
-+ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua-$(V) luac-$(V)
++ $(LIBTOOL) --mode=clean $(RM) $(ALL_O:.o=.lo) $(LIB_NAME) lua luac
+
-+gentoo_all: $(LIB_NAME) lua-$(V) luac-$(V)
++gentoo_all: $(LIB_NAME) $(LIB_NAME:.la=.a) lua lua_test luac
diff --git a/dev-lang/lua/files/lua-5.1.1-make_static.patch b/dev-lang/lua/files/lua-5.1.1-make_static.patch
index b25cb5c89c95..53c5bd1a9cf8 100644
--- a/dev-lang/lua/files/lua-5.1.1-make_static.patch
+++ b/dev-lang/lua/files/lua-5.1.1-make_static.patch
@@ -4,9 +4,9 @@ diff -ru lua-5.1.1.orig/src/Makefile lua-5.1.1/src/Makefile
@@ -196,7 +196,7 @@
-rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
- lua-$(V): $(LUA_O) $(LIB_NAME)
+ lua: $(LUA_O) $(LIB_NAME)
- $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
- luac-$(V): $(LUAC_O) $(LIB_NAME)
+ luac: $(LUAC_O) $(LIB_NAME)
$(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)