summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-11-03 07:51:29 +0000
committerKeri Harris <keri@gentoo.org>2010-11-03 07:51:29 +0000
commit0b7a54ae4064cb399bb8a1045bd17d2cb754e744 (patch)
treeaf25b2be9a7819acf18e5234af43e841ec10f557 /dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild
parentBundle patches into distfiles tarball. (diff)
downloadhistorical-0b7a54ae4064cb399bb8a1045bd17d2cb754e744.tar.gz
historical-0b7a54ae4064cb399bb8a1045bd17d2cb754e744.tar.bz2
historical-0b7a54ae4064cb399bb8a1045bd17d2cb754e744.zip
Bundle patches into distfiles tarball.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild')
-rw-r--r--dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild b/dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild
index 3df558ac2a04..14a95b381f6f 100644
--- a/dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild
+++ b/dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild,v 1.1 2010/10/10 05:32:54 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/mercury-extras-10.04.2.ebuild,v 1.2 2010/11/03 07:51:27 keri Exp $
inherit eutils
+PATCHSET_VER="0"
+
DESCRIPTION="Additional libraries and tools that are not part of the Mercury standard library"
HOMEPAGE="http://www.cs.mu.oz.au/research/mercury/index.html"
-SRC_URI="http://www.mercury.cs.mu.oz.au/download/files/${P}.tar.gz"
+SRC_URI="http://www.mercury.cs.mu.oz.au/download/files/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo-patchset-${PATCHSET_VER}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -28,22 +31,18 @@ DEPEND="~dev-lang/mercury-${PV}
src_unpack() {
unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-curs.patch
- epatch "${FILESDIR}"/${P}-dynamic-linking.patch
- epatch "${FILESDIR}"/${P}-lex.patch
- epatch "${FILESDIR}"/${P}-mercury-glut.patch
- epatch "${FILESDIR}"/${P}-mercury-tcltk.patch
- epatch "${FILESDIR}"/${P}-mercury-opengl.patch
- epatch "${FILESDIR}"/${P}-posix.patch
- epatch "${FILESDIR}"/${P}-no-java-grade-no-erlang-grade.patch
+
+ EPATCH_FORCE=yes
+ EPATCH_SUFFIX=patch
+ epatch "${WORKDIR}"/${PV}
if use odbc; then
- epatch "${FILESDIR}"/${P}-odbc.patch
+ epatch "${WORKDIR}"/${PV}-odbc/${P}-odbc.patch
elif use iodbc; then
- epatch "${FILESDIR}"/${P}-iodbc.patch
+ epatch "${WORKDIR}"/${PV}-odbc/${P}-iodbc.patch
fi
+ cd "${S}"
sed -i -e "s:posix:posix quickcheck:" \
-e "s:references::" \
-e "s:windows_installer_generator ::" Mmakefile