summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-08 20:47:44 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-08 20:47:44 +0000
commit8afcc212c4dc8d7ed94b451a1077b14567f9b99c (patch)
tree06b42a72771f6302aa3ffc3e135c343b27ca5fc7 /dev-lang/mmix/mmix-20060324.ebuild
parentold (diff)
downloadhistorical-8afcc212c4dc8d7ed94b451a1077b14567f9b99c.tar.gz
historical-8afcc212c4dc8d7ed94b451a1077b14567f9b99c.tar.bz2
historical-8afcc212c4dc8d7ed94b451a1077b14567f9b99c.zip
Fix tetex dependency, thanks to David Klempner for reporting; bug 136559
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'dev-lang/mmix/mmix-20060324.ebuild')
-rw-r--r--dev-lang/mmix/mmix-20060324.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-lang/mmix/mmix-20060324.ebuild b/dev-lang/mmix/mmix-20060324.ebuild
index 648cc9178a0b..5044a1ce1d4a 100644
--- a/dev-lang/mmix/mmix-20060324.ebuild
+++ b/dev-lang/mmix/mmix-20060324.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20060324.ebuild,v 1.1 2006/04/20 17:06:38 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mmix/mmix-20060324.ebuild,v 1.2 2006/12/08 20:47:44 masterdriverz Exp $
S=${WORKDIR}
@@ -8,10 +8,9 @@ DESCRIPTION="Donald Knuth's MMIX Assembler and Simulator."
HOMEPAGE="http://www-cs-faculty.stanford.edu/~knuth/mmix.html"
SRC_URI="http://www-cs-faculty.stanford.edu/~knuth/programs/${P}.tar.gz"
-DEPEND="virtual/libc
- >=dev-util/cweb-3.63
- app-text/tetex"
-RDEPEND="virtual/libc"
+DEPEND=">=dev-util/cweb-3.63
+ doc? ( virtual/tetex )"
+RDEPEND=""
SLOT="0"
LICENSE="mmix"
@@ -19,9 +18,9 @@ KEYWORDS="~x86 ~sparc ~ppc"
IUSE="doc"
src_compile() {
- make all CFLAGS="${CFLAGS}" || die
+ emake -j1 all CFLAGS="${CFLAGS}" || die
if use doc ; then
- make doc || die
+ emake doc || die
fi
}