summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-07 21:30:10 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-07 21:30:10 +0000
commitf5b6817961448fcbe269fd8f9701d8915a53a03b (patch)
tree2d09724e939daa0e1ceaf0ff361c488e2d5c0382 /dev-lang/ocaml/ocaml-3.04.ebuild
parentAdded proper virtual provide (diff)
downloadhistorical-f5b6817961448fcbe269fd8f9701d8915a53a03b.tar.gz
historical-f5b6817961448fcbe269fd8f9701d8915a53a03b.tar.bz2
historical-f5b6817961448fcbe269fd8f9701d8915a53a03b.zip
ocaml-3.04
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.04.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.04.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ocaml-3.04.ebuild b/dev-lang/ocaml/ocaml-3.04.ebuild
new file mode 100644
index 000000000000..79b18d3489f6
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.04.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Sean Mitchell <sean@arawak.tzo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.build,v 1.11 2001/12/06 22:12:34 drobbins Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
+SRC_URI="ftp://ftp.inria.fr/lang/caml-light/${P}.tar.gz"
+HOMEPAGE="http://www.ocaml.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/tk-3.3.3"
+#RDEPEND=""
+
+src_compile()
+{
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/man/man1 \
+ -with-pthread \
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install ()
+{
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/man/man1 \
+ install || die
+
+ dodoc Changes INSTALL LICENSE README Upgrading
+
+}
+
+
+
+