summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-01-18 13:12:59 +0000
committerMark Wright <gienah@gentoo.org>2014-01-18 13:12:59 +0000
commit848df3cc8ffc48353071129bcccd2a3fdb716cb0 (patch)
treedc3bdd4ae9e4973ee2d93bfc64f847f49e6a223a /dev-lang/ocaml/ocaml-4.01.0.ebuild
parentversion bump (diff)
downloadhistorical-848df3cc8ffc48353071129bcccd2a3fdb716cb0.tar.gz
historical-848df3cc8ffc48353071129bcccd2a3fdb716cb0.tar.bz2
historical-848df3cc8ffc48353071129bcccd2a3fdb716cb0.zip
Fix bug #459512 - dev-lang/ocaml with sys-libs/ncurses[tinfo] - .../work/ocaml-4.00.1/byterun/terminfo.c:54: undefined reference to 'tgetent', thanks to Reinis Danne for reporting (patch by me). Add virtual/pkg-config to DEPEND as the ocaml configure script calls pkg-config. Apply patch from upstream for upstream bug http://caml.inria.fr/mantis/view.php?id=5237 to ocaml-3.11.2.
Package-Manager: portage-2.2.8/cvs/Linux x86_64 Manifest-Sign-Key: 0x618E971F
Diffstat (limited to 'dev-lang/ocaml/ocaml-4.01.0.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-4.01.0.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ocaml-4.01.0.ebuild b/dev-lang/ocaml/ocaml-4.01.0.ebuild
index 078dd4744ec0..d6276db555ae 100644
--- a/dev-lang/ocaml/ocaml-4.01.0.ebuild
+++ b/dev-lang/ocaml/ocaml-4.01.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0.ebuild,v 1.2 2014/01/15 22:05:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0.ebuild,v 1.3 2014/01/18 13:12:48 gienah Exp $
EAPI="5"
@@ -20,10 +20,11 @@ SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+RDEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
@@ -42,6 +43,8 @@ pkg_setup() {
src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ # Bug #459512
+ epatch "${FILESDIR}/${PN}-4.01.0-pkg-config-ncurses.patch"
}
src_configure() {