summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-06-19 22:21:41 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-06-19 22:21:41 +0000
commit8fb07a56b12a97122045659cfda9fedfc102a962 (patch)
tree64c4e75501ce441c286286629b9ed93331df9539 /dev-lang/open-cobol/open-cobol-0.23.ebuild
parentnew package - open cobol compiler (diff)
downloadhistorical-8fb07a56b12a97122045659cfda9fedfc102a962.tar.gz
historical-8fb07a56b12a97122045659cfda9fedfc102a962.tar.bz2
historical-8fb07a56b12a97122045659cfda9fedfc102a962.zip
new package - open cobol compiler
Diffstat (limited to 'dev-lang/open-cobol/open-cobol-0.23.ebuild')
-rw-r--r--dev-lang/open-cobol/open-cobol-0.23.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lang/open-cobol/open-cobol-0.23.ebuild b/dev-lang/open-cobol/open-cobol-0.23.ebuild
new file mode 100644
index 000000000000..6c2e51db0030
--- /dev/null
+++ b/dev-lang/open-cobol/open-cobol-0.23.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/open-cobol/open-cobol-0.23.ebuild,v 1.1 2003/06/19 22:21:24 george Exp $
+
+DESCRIPTION="an open-source COBOL compiler"
+HOMEPAGE="http://www.open-cobol.org/"
+SRC_URI="mirror://sourceforge/open-cobol/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls readline ncurses"
+
+DEPEND="sys-devel/libtool
+ >=dev-libs/gmp-3.1.1
+ >=sys-libs/db-2.0
+ readline? ( sys-libs/readline )
+ ncurses? ( >=sys-libs/ncurses-5.2 )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ econf \
+ $(use_enable nls) \
+ $(use_with readline)
+ emake
+}
+
+src_install() {
+
+ einstall
+ dodoc ABOUT-NLS AUTHORS ChangeLog INSTALL NEWS README
+}