summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-01 05:16:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-01 05:16:58 +0000
commitfc8f36e39be4d0496380de482775deae07fbc3dc (patch)
tree490f922d01927defcdef1de52dfc15f0a1e19726 /dev-lang/opendylan/opendylan-2011.1-r1.ebuild
parentRemove old (diff)
downloadhistorical-fc8f36e39be4d0496380de482775deae07fbc3dc.tar.gz
historical-fc8f36e39be4d0496380de482775deae07fbc3dc.tar.bz2
historical-fc8f36e39be4d0496380de482775deae07fbc3dc.zip
Remove old
Package-Manager: portage-2.2.0_alpha191/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/opendylan/opendylan-2011.1-r1.ebuild')
-rw-r--r--dev-lang/opendylan/opendylan-2011.1-r1.ebuild99
1 files changed, 0 insertions, 99 deletions
diff --git a/dev-lang/opendylan/opendylan-2011.1-r1.ebuild b/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
deleted file mode 100644
index 30f3a3939c98..000000000000
--- a/dev-lang/opendylan/opendylan-2011.1-r1.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/opendylan/opendylan-2011.1-r1.ebuild,v 1.7 2013/02/08 09:26:19 patrick Exp $
-EAPI=4
-
-inherit autotools
-
-RESTRICT="test"
-
-DESCRIPTION="OpenDylan language runtime environment"
-
-HOMEPAGE="http://opendylan.org"
-SRC_URI="https://github.com/dylan-lang/opendylan/zipball/v2011.1 -> opendylan-2011.1.zip"
-MY_P="dylan-lang-opendylan-23f8ab5" # WTF github, that's NOT funny
-
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Opendylan"
-SLOT="0"
-
-# not tested on x86
-KEYWORDS="~amd64 ~x86"
-
-IUSE=""
-
-DEPEND="app-arch/unzip
- dev-libs/boehm-gc
- dev-lang/perl
- dev-perl/XML-Parser
- || ( =dev-lang/opendylan-bin-2011.1 dev-lang/opendylan )
- x86? ( <dev-libs/mps-1.108 )"
-RDEPEND="${DEPEND}"
-
-# on x86 there's a dependency on mps, but the build system is a bit ... hmm ...
-# let's give it more of a chance to survive then
-NAUGHTY_FILES=(
- sources/lib/run-time/collector.c.malloc
- sources/lib/run-time/collector.c
- sources/lib/run-time/pentium-win32/buffalo-collector.c
- sources/lib/run-time/pentium-win32/heap-stats.c
- sources/lib/run-time/heap-utils.h
- )
-
-NAUGHTY_HEADERS=(
- mps.h
- mpscmv.h
- mpscamc.h
- mpsavm.h
- )
-
-src_prepare() {
- mkdir -p build-aux
- elibtoolize && eaclocal || die "Fail"
- automake --foreign --add-missing # this one dies wrongfully
- eautoconf || die "Fail"
- # mps headers, included wrong
- if use x86; then
- for i in ${NAUGHTY_FILES[@]}; do
- for header in ${NAUGHTY_HEADERS[@]}; do
- sed -i -e "s:\"${header}\":<${header}>:" $i
- done
- done
- fi
-}
-
-src_configure() {
- if has_version =dev-lang/opendylan-bin-2011.1; then
- PATH=/opt/opendylan-2011.1/bin/:$PATH
- else
- PATH=/opt/opendylan/bin:$PATH
- fi
- if use amd64; then
- econf --prefix=/opt/opendylan || die
- else
- econf --prefix=/opt/opendylan --with-mps=/usr/include/mps/ || die
- fi
- if use x86; then
- # Includedir, pointing at something wrong
- sed -i -e 's:-I$(MPS)/code:-I$(MPS):' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps path"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mmdw.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~(cd $(MPS)/code; make -f lii4gc.gmk mpsplan.a)~:;~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps building"
- sed -i -e 's~$(MPS_LIB)/mpsplan.a~/usr/lib/mpsplan.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- sed -i -e 's~$(MPS_LIB)/mmdw.a~/usr/lib/mmdw.a~' sources/lib/run-time/pentium-linux/Makefile || die "Couldn't fix mps clone"
- fi
-}
-
-src_compile() {
- ulimit -s 32000 # this is naughty build system
- emake || die
-}
-
-src_install() {
- ulimit -s 32000 # this is naughty build system
- # because of Makefile weirdness it rebuilds quite a bit here
- # upstream has been notified
- emake -j1 DESTDIR="${D}" install
- mkdir -p "${D}/etc/env.d/opendylan/"
- echo "export PATH=/opt/opendylan/bin:\$PATH" > "${D}/etc/env.d/opendylan/99-opendylan" || die "Failed to add env settings"
-}