summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-01-09 12:46:58 +0000
committerMark Wright <gienah@gentoo.org>2012-01-09 12:46:58 +0000
commit1d5b43261e598049a7b7a62825ac96bc07286b3b (patch)
treec49996f1a52768a6183cb90816680e34c1ccb116 /dev-lang/polyml/polyml-5.4.1.ebuild
parentTodays Python Patches (diff)
downloadhistorical-1d5b43261e598049a7b7a62825ac96bc07286b3b.tar.gz
historical-1d5b43261e598049a7b7a62825ac96bc07286b3b.tar.bz2
historical-1d5b43261e598049a7b7a62825ac96bc07286b3b.zip
Fix upstream bug: --without-portable was equivalent to --with-portable. Add tests.
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/polyml/polyml-5.4.1.ebuild')
-rw-r--r--dev-lang/polyml/polyml-5.4.1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-lang/polyml/polyml-5.4.1.ebuild b/dev-lang/polyml/polyml-5.4.1.ebuild
index 7571494a9201..b44696a5fc1d 100644
--- a/dev-lang/polyml/polyml-5.4.1.ebuild
+++ b/dev-lang/polyml/polyml-5.4.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.4.1.ebuild,v 1.2 2012/01/08 15:25:53 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/polyml/polyml-5.4.1.ebuild,v 1.3 2012/01/09 12:46:58 gienah Exp $
EAPI="4"
-inherit base
+inherit base autotools
MY_P=${PN}.${PV}
@@ -15,7 +15,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="X +gmp portable +threads"
+IUSE="X +gmp portable test +threads"
RDEPEND="X? ( x11-libs/openmotif )
gmp? ( >=dev-libs/gmp-5 )
@@ -24,7 +24,13 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
-PATCHES=("${FILESDIR}/${PN}-5.4.1-asm.patch")
+PATCHES=("${FILESDIR}/${PN}-5.4.1-configure.patch"
+ "${FILESDIR}/${PN}-5.4.1-asm.patch")
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
src_configure() {
econf \
@@ -33,3 +39,7 @@ src_configure() {
$(use_with portable) \
$(use_with threads)
}
+
+src_test() {
+ emake tests || die "tests failed"
+}